GD Graphics Library up to 2.2.5 gdImageBmpPt double free

EntryeditHistoryDiffjsonxmlCTI

A vulnerability was found in GD Graphics Library up to 2.2.5 (Image Processing Software). It has been rated as critical. This issue affects the function gdImageBmpPt. There is no information about possible countermeasures known. It may be suggested to replace the affected object with an alternative product.

Field06/21/2019 07:43 AM06/26/2020 03:18 PM
nameGD Graphics LibraryGD Graphics Library
version<=2.2.5<=2.2.5
functiongdImageBmpPtgdImageBmpPt
risk22
cvss2_vuldb_basescore4.14.1
cvss2_vuldb_tempscore4.14.1
cvss2_vuldb_acMM
cvss2_vuldb_ciPP
cvss2_vuldb_iiPP
cvss2_vuldb_aiPP
cvss3_meta_basescore5.35.3
cvss3_meta_tempscore5.35.3
cvss3_vuldb_basescore5.35.3
cvss3_vuldb_tempscore5.35.3
cvss3_vuldb_acLL
cvss3_vuldb_cLL
cvss3_vuldb_iLL
cvss3_vuldb_aLL
date1560988800 (06/20/2019)1560988800 (06/20/2019)
price_0day$5k-$25k$5k-$25k
cveCVE-2018-15879CVE-2018-15879
seealso136798136798
cvss3_vuldb_uiNN
cvss2_vuldb_eNDND
cvss2_vuldb_rlNDND
cvss2_vuldb_rcNDND
cvss3_vuldb_eXX
cvss3_vuldb_rlXX
cvss3_vuldb_rcXX
cvss2_vuldb_avLL
cvss2_vuldb_auSS
cvss3_vuldb_avLL
cvss3_vuldb_prLL
cvss3_vuldb_sUU
typeImage Processing Software
cve_assigned1535241600
cve_nvd_summaryThe GD Graphics Library (aka libgd) through 2.2.5 has a Double Free Vulnerability in the gdImageBmpPt function.
cwe0415 (memory corruption)

Might our Artificial Intelligence support you?

Check our Alexa App!