Decal Package set Remote Code Execution

entryeditHistoryDiffjsonxmlCTI

A vulnerability classified as critical has been found in Decal Package (version unknown). Applying a patch is able to eliminate this problem. The bugfix is ready for download at github.com.

Field02/04/2021 06:57 PM02/23/2021 03:11 PM
nameDecal PackageDecal Package
functionsetset
cvss3_vuldb_avNN
cvss3_vuldb_acLL
cvss3_vuldb_prNN
cvss3_vuldb_uiNN
cvss3_vuldb_sUU
cvss3_vuldb_cLL
cvss3_vuldb_iLL
cvss3_vuldb_aLL
identifierSNYK-JS-DECAL-1051007SNYK-JS-DECAL-1051007
urlhttps://snyk.io/vuln/SNYK-JS-DECAL-1051007https://snyk.io/vuln/SNYK-JS-DECAL-1051007
namePatchPatch
patch_urlhttps://github.com/gigafied/decal.js/blob/master/src/utils/set.js%23L45-L73https://github.com/gigafied/decal.js/blob/master/src/utils/set.js%23L45-L73
cveCVE-2020-28449CVE-2020-28449
date1612393200 (02/04/2021)1612393200 (02/04/2021)
cvss2_vuldb_avNN
cvss2_vuldb_acLL
cvss2_vuldb_auNN
cvss2_vuldb_ciPP
cvss2_vuldb_iiPP
cvss2_vuldb_aiPP
cvss2_vuldb_eNDND
cvss2_vuldb_rlNDND
cvss2_vuldb_rcNDND
cvss3_vuldb_eXX
cvss3_vuldb_rlXX
cvss3_vuldb_rcXX
cvss2_vuldb_basescore7.57.5
cvss2_vuldb_tempscore7.57.5
cvss3_vuldb_basescore7.37.3
cvss3_vuldb_tempscore7.37.3
cvss3_meta_basescore7.37.3
cvss3_meta_tempscore7.37.3
price_0day$0-$5k$0-$5k
cve_assigned1605135600
cve_nvd_summaryThis affects all versions of package decal. The vulnerability is in the set function.

Might our Artificial Intelligence support you?

Check our Alexa App!