Schneider Electric Easergy T300 RTU up to 2.7.1 pppd buffer overflow

A vulnerability, which was classified as critical, was found in Schneider Electric Easergy T300 RTU up to 2.7.1 (SCADA Software). Affected is some unknown processing of the component pppd. Upgrading to version 2.8 eliminates this vulnerability. Applying a patch is able to eliminate this problem. The bugfix is ready for download at github.com. The best possible mitigation is suggested to be upgrading to the latest version.

Field01/12/2022 05:43 PM01/15/2022 09:08 AM01/15/2022 09:11 AM
vendorSchneider ElectricSchneider ElectricSchneider Electric
nameEasergy T300 RTUEasergy T300 RTUEasergy T300 RTU
version<=2.7.1<=2.7.1<=2.7.1
componentpppdpppdpppd
cwe120 (memory corruption)120 (memory corruption)120 (memory corruption)
risk222
cvss3_vuldb_avAAA
cvss3_vuldb_acHHH
cvss3_vuldb_prNNN
cvss3_vuldb_uiNNN
cvss3_vuldb_sUUU
cvss3_vuldb_cHHH
cvss3_vuldb_iHHH
cvss3_vuldb_aHHH
cvss3_vuldb_rlOOO
cvss3_vuldb_rcCCC
identifierSEVD-2022-011SEVD-2022-011SEVD-2022-011
urlhttps://download.schneider-electric.com/files?p_Doc_Ref=SEVD-2022-011-02https://download.schneider-electric.com/files?p_Doc_Ref=SEVD-2022-011-02https://download.schneider-electric.com/files?p_Doc_Ref=SEVD-2022-011-02
nameUpgradeUpgradeUpgrade
upgrade_version2.82.82.8
cveCVE-2020-8597CVE-2020-8597CVE-2020-8597
date1641942000 (01/12/2022)1641942000 (01/12/2022)1641942000 (01/12/2022)
typeSCADA SoftwareSCADA SoftwareSCADA Software
cvss2_vuldb_avAAA
cvss2_vuldb_acHHH
cvss2_vuldb_auNNN
cvss2_vuldb_ciCCC
cvss2_vuldb_iiCCC
cvss2_vuldb_aiCCC
cvss2_vuldb_rcCCC
cvss2_vuldb_rlOFOFOF
cvss2_vuldb_eNDNDND
cvss3_vuldb_eXXX
cvss2_vuldb_basescore6.86.86.8
cvss2_vuldb_tempscore5.95.95.9
cvss3_vuldb_basescore7.57.57.5
cvss3_vuldb_tempscore7.27.27.2
cvss3_meta_basescore7.57.58.6
cvss3_meta_tempscore7.27.28.5
price_0day$0-$5k$0-$5k$0-$5k
confirm_urlhttps://kb.netgear.com/000061806/Security-Advisory-for-Unauthenticated-Remote-Buffer-Overflow-Attack-in-PPPD-on-WAC510-PSV-2020-0136https://kb.netgear.com/000061806/Security-Advisory-for-Unauthenticated-Remote-Buffer-Overflow-Attack-in-PPPD-on-WAC510-PSV-2020-0136
patch_urlhttps://github.com/paulusmack/ppp/commit/8d7970b8f3db727fe798b65f3377fe6787575426https://github.com/paulusmack/ppp/commit/8d7970b8f3db727fe798b65f3377fe6787575426
cve_assigned15806844001580684400
cve_nvd_summaryeap.c in pppd in ppp 2.4.2 through 2.4.8 has an rhostname buffer overflow in the eap_request and eap_response functions.eap.c in pppd in ppp 2.4.2 through 2.4.8 has an rhostname buffer overflow in the eap_request and eap_response functions.
cvss3_nvd_avN
cvss3_nvd_acL
cvss3_nvd_prN
cvss3_nvd_uiN
cvss3_nvd_sU
cvss3_nvd_cH
cvss3_nvd_iH
cvss3_nvd_aH
cvss2_nvd_avN
cvss2_nvd_acL
cvss2_nvd_auN
cvss2_nvd_ciP
cvss2_nvd_iiP
cvss2_nvd_aiP
cvss2_nvd_basescore7.5
cvss3_nvd_basescore9.8

Do you know our Splunk app?

Download it now for free!