Debian Package Builder Plugin up to 1.6.11 on Jenkins os command injection

A vulnerability was found in Debian Package Builder Plugin up to 1.6.11 on Jenkins (Jenkins Plugin). It has been declared as critical. This vulnerability affects an unknown code. There is no information about possible countermeasures known. It may be suggested to replace the affected object with an alternative product.

Field01/13/2022 06:46 AM01/15/2022 12:38 PM
nameDebian Package Builder PluginDebian Package Builder Plugin
version<=1.6.11<=1.6.11
platformJenkinsJenkins
cwe78 (privilege escalation)78 (privilege escalation)
risk22
cvss3_vuldb_acLL
cvss3_vuldb_uiNN
cvss3_vuldb_sUU
cvss3_vuldb_cLL
cvss3_vuldb_iLL
cvss3_vuldb_aLL
cvss3_vuldb_rcCC
urlhttps://www.jenkins.io/security/advisory/2022-01-12/#SECURITY-2546https://www.jenkins.io/security/advisory/2022-01-12/#SECURITY-2546
cveCVE-2022-23118CVE-2022-23118
cve_assigned16418556001641855600
date1642028400 (01/13/2022)1642028400 (01/13/2022)
typeJenkins PluginJenkins Plugin
cvss2_vuldb_acLL
cvss2_vuldb_ciPP
cvss2_vuldb_iiPP
cvss2_vuldb_aiPP
cvss2_vuldb_rcCC
cvss2_vuldb_avAA
cvss2_vuldb_auSS
cvss2_vuldb_eNDND
cvss2_vuldb_rlNDND
cvss3_vuldb_avAA
cvss3_vuldb_prLL
cvss3_vuldb_eXX
cvss3_vuldb_rlXX
cvss2_vuldb_basescore5.25.2
cvss2_vuldb_tempscore5.25.2
cvss3_vuldb_basescore5.55.5
cvss3_vuldb_tempscore5.55.5
cvss3_meta_basescore5.55.5
cvss3_meta_tempscore5.55.5
price_0day$0-$5k$0-$5k
confirm_urlhttps://www.jenkins.io/security/advisory/2022-01-12/#SECURITY-2546
cve_nvd_summaryJenkins Debian Package Builder Plugin 1.6.11 and earlier implements functionality that allows agents to invoke command-line `git` at an attacker-specified path on the controller, allowing attackers able to control agent processes to invoke arbitrary OS commands on the controller.

Do you want to use VulDB in your project?

Use the official API to access entries easily!