Zyxel USG ZyWALL CGI Program path traversal

A vulnerability classified as critical was found in Zyxel USG ZyWALL, USG FLEX 100, USG FLEX 200, USG FLEX 500, USG FLEX 700, USG FLEX 50, USG20, ATP and VPN (Firewall Software). This vulnerability affects an unknown functionality of the component CGI Program Handler. There is no information about possible countermeasures known. It may be suggested to replace the affected object with an alternative product.

Field07/19/2022 02:09 PM08/06/2022 02:31 PM
vendorZyxelZyxel
nameUSG ZyWALL/USG FLEX 100/USG FLEX 200/USG FLEX 500/USG FLEX 700/USG FLEX 50/USG20/ATP/VPNUSG ZyWALL/USG FLEX 100/USG FLEX 200/USG FLEX 500/USG FLEX 700/USG FLEX 50/USG20/ATP/VPN
componentCGI Program HandlerCGI Program Handler
cwe22 (path traversal)22 (path traversal)
risk22
cvss3_vuldb_avNN
cvss3_vuldb_acLL
cvss3_vuldb_prLL
cvss3_vuldb_uiNN
cvss3_vuldb_sUU
cvss3_vuldb_cLL
cvss3_vuldb_iNN
cvss3_vuldb_aNN
cvss3_vuldb_rcCC
urlhttps://www.zyxel.com/support/Zyxel-security-advisory-authenticated-directory-traversal-vulnerabilities-of-firewalls.shtmlhttps://www.zyxel.com/support/Zyxel-security-advisory-authenticated-directory-traversal-vulnerabilities-of-firewalls.shtml
cveCVE-2022-2030CVE-2022-2030
cve_assigned1654639200 (06/08/2022)1654639200 (06/08/2022)
cve_nvd_summaryA directory traversal vulnerability caused by specific character sequences within an improperly sanitized URL was identified in some CGI programs of Zyxel USG FLEX 100(W) firmware versions 4.50 through 5.30, USG FLEX 200 firmware versions 4.50 through 5.30, USG FLEX 500 firmware versions 4.50 through 5.30, USG FLEX 700 firmware versions 4.50 through 5.30, USG FLEX 50(W) firmware versions 4.16 through 5.30, USG20(W)-VPN firmware versions 4.16 through 5.30, ATP series firmware versions 4.32 through 5.30, VPN series firmware versions 4.30 through 5.30, USG/ZyWALL series firmware versions 4.11 through 4.72, that could allow an authenticated attacker to access some restricted files on a vulnerable device.A directory traversal vulnerability caused by specific character sequences within an improperly sanitized URL was identified in some CGI programs of Zyxel USG FLEX 100(W) firmware versions 4.50 through 5.30, USG FLEX 200 firmware versions 4.50 through 5.30, USG FLEX 500 firmware versions 4.50 through 5.30, USG FLEX 700 firmware versions 4.50 through 5.30, USG FLEX 50(W) firmware versions 4.16 through 5.30, USG20(W)-VPN firmware versions 4.16 through 5.30, ATP series firmware versions 4.32 through 5.30, VPN series firmware versions 4.30 through 5.30, USG/ZyWALL series firmware versions 4.11 through 4.72, that could allow an authenticated attacker to access some restricted files on a vulnerable device.
date1658181600 (07/19/2022)1658181600 (07/19/2022)
typeFirewall SoftwareFirewall Software
cvss2_vuldb_avNN
cvss2_vuldb_acLL
cvss2_vuldb_ciPP
cvss2_vuldb_iiNN
cvss2_vuldb_aiNN
cvss2_vuldb_rcCC
cvss2_vuldb_auSS
cvss2_vuldb_eNDND
cvss2_vuldb_rlNDND
cvss3_vuldb_eXX
cvss3_vuldb_rlXX
cvss2_vuldb_basescore4.04.0
cvss2_vuldb_tempscore4.04.0
cvss3_vuldb_basescore4.34.3
cvss3_vuldb_tempscore4.34.3
cvss3_meta_basescore4.35.4
cvss3_meta_tempscore4.35.4
price_0day$5k-$25k$5k-$25k
cvss3_cna_avN
cvss3_cna_acL
cvss3_cna_prL
cvss3_cna_uiN
cvss3_cna_sU
cvss3_cna_cH
cvss3_cna_iN
cvss3_cna_aN
cve_cnaZyxel Corporation
cvss3_cna_basescore6.5

Do you need the next level of professionalism?

Upgrade your account now!