Huawei P8 Lite/P9 Lite/P9 TrustZone Driver resource control

A vulnerability was found in Huawei P8 Lite, P9 Lite and P9. It has been classified as critical. Affected is an unknown function of the component TrustZone Driver. The manipulation leads to improper control of resource through lifetime. Using CWE to declare the problem leads to CWE-664. The bug was discovered 11/23/2016. The weakness was shared 04/02/2017 as sa-20161123-01 (Website). The advisory is shared for download at huawei.com. This vulnerability is traded as CVE-2016-8763. It is possible to launch the attack on the local host. There are no technical details available. There is no exploit available. The current price for an exploit might be approx. USD $0-$5k at the moment. It is declared as not defined. The vulnerability was handled as a non-public zero-day exploit for at least 130 days. As 0-day the estimated underground price was around $5k-$25k. It is recommended to upgrade the affected component. A possible mitigation has been published even before and not after the disclosure of the vulnerability. The vulnerability is also documented other vulnerability databases: SecurityFocus (BID 94509).

Field04/03/2017 09:04 AM08/25/2020 09:07 AM11/24/2022 02:27 PM
historic000
cvss2_vuldb_basescore6.86.86.8
cvss2_vuldb_tempscore5.95.95.9
cvss2_vuldb_avNNN
cvss2_vuldb_acMMM
cvss2_vuldb_auNNN
cvss2_vuldb_ciPPP
cvss2_vuldb_iiPPP
cvss2_vuldb_aiPPP
cvss2_nvd_avNNN
cvss2_nvd_acMMM
cvss2_nvd_auNNN
cvss2_nvd_ciCCC
cvss2_nvd_iiCCC
cvss2_nvd_aiCCC
cvss3_meta_basescore6.56.56.5
cvss3_meta_tempscore6.36.36.4
cvss3_vuldb_basescore5.35.35.3
cvss3_vuldb_tempscore5.15.15.1
cvss3_vuldb_avLLL
cvss3_vuldb_acLLL
cvss3_vuldb_prNNN
cvss3_vuldb_uiRRR
cvss3_vuldb_sUUU
cvss3_vuldb_cLLL
cvss3_vuldb_iLLL
cvss3_vuldb_aLLL
cvss3_nvd_avLLL
cvss3_nvd_acLLL
cvss3_nvd_prNNN
cvss3_nvd_uiRRR
cvss3_nvd_sUUU
cvss3_nvd_cHHH
cvss3_nvd_iHHH
cvss3_nvd_aHHH
date1491091200 (04/02/2017)1491091200 (04/02/2017)1491091200 (04/02/2017)
urlhttp://www.huawei.com/en/psirt/security-advisories/huawei-sa-20161123-01-smartphone-enhttp://www.huawei.com/en/psirt/security-advisories/huawei-sa-20161123-01-smartphone-enhttp://www.huawei.com/en/psirt/security-advisories/huawei-sa-20161123-01-smartphone-en
price_0day$5k-$25k$5k-$25k$5k-$25k
nameUpgradeUpgradeUpgrade
cveCVE-2016-8763CVE-2016-8763CVE-2016-8763
cve_assigned1476748800 (10/18/2016)1476748800 (10/18/2016)1476748800 (10/18/2016)
cve_nvd_published149109120014910912001491091200
cve_nvd_summaryThe TrustZone driver in Huawei P9 phones with software Versions earlier than EVA-AL10C00B352 and P9 Lite with software VNS-L21C185B130 and earlier versions and P8 Lite with software ALE-L02C636B150 and earlier versions has an improper resource release vulnerability, which allows attackers to cause a system restart or privilege elevation.The TrustZone driver in Huawei P9 phones with software Versions earlier than EVA-AL10C00B352 and P9 Lite with software VNS-L21C185B130 and earlier versions and P8 Lite with software ALE-L02C636B150 and earlier versions has an improper resource release vulnerability, which allows attackers to cause a system restart or privilege elevation.The TrustZone driver in Huawei P9 phones with software Versions earlier than EVA-AL10C00B352 and P9 Lite with software VNS-L21C185B130 and earlier versions and P8 Lite with software ALE-L02C636B150 and earlier versions has an improper resource release vulnerability, which allows attackers to cause a system restart or privilege elevation.
securityfocus945099450994509
securityfocus_titleMultiple Huawei Products Local Multiple Security VulnerabilitiesMultiple Huawei Products Local Multiple Security VulnerabilitiesMultiple Huawei Products Local Multiple Security Vulnerabilities
seealso99203 9920599203 9920599203 99205
locationWebsiteWebsiteWebsite
cvss2_vuldb_eNDNDND
cvss2_vuldb_rlOFOFOF
cvss2_vuldb_rcNDNDND
cvss3_vuldb_eXXX
cvss3_vuldb_rlOOO
cvss3_vuldb_rcXXX
0day_days130130130
cvss3_nvd_basescore7.87.87.8
typeSmartphone Operating SystemSmartphone Operating SystemSmartphone Operating System
vendorHuaweiHuaweiHuawei
nameP8 Lite/P9 Lite/P9P8 Lite/P9 Lite/P9P8 Lite/P9 Lite/P9
componentTrustZone DriverTrustZone DriverTrustZone Driver
cwe664 (resource control)664 (resource control)664 (resource control)
risk222
confirm_urlhttp://www.huawei.com/en/psirt/security-advisories/huawei-sa-20161123-01-smartphone-enhttp://www.huawei.com/en/psirt/security-advisories/huawei-sa-20161123-01-smartphone-en
osvdb_titleCVE-2016-8763 - Huawei - Multiple Products - Privilege Escalation IssueCVE-2016-8763 - Huawei - Multiple Products - Privilege Escalation Issue
securityfocus_date1479945600 (11/24/2016)1479945600 (11/24/2016)
securityfocus_classBoundary Condition ErrorBoundary Condition Error
discoverydate14798592001479859200
identifiersa-20161123-01
cvss2_nvd_basescore9.3

Do you want to use VulDB in your project?

Use the official API to access entries easily!