Optica up to 0.10.1 JSON oj.safe_load deserialization

A vulnerability was found in Optica up to 0.10.1. It has been classified as critical. Affected is the function oj.safe_load of the component JSON Handler. The manipulation leads to deserialization. Using CWE to declare the problem leads to CWE-502. The weakness was released 11/24/2022 as GHSA-cf87-4h6x-phh6. The advisory is shared for download at github.com. This vulnerability is traded as CVE-2022-41875. It is possible to launch the attack remotely. Technical details are available. There is no exploit available. The current price for an exploit might be approx. USD $0-$5k at the moment. It is declared as not defined. As 0-day the estimated underground price was around $0-$5k. Upgrading to version 0.10.2 is able to address this issue. It is recommended to upgrade the affected component. A possible mitigation has been published before and not just after the disclosure of the vulnerability.

Timeline

The analysis of the timeline helps to identify the required approach and handling of single vulnerabilities and vulnerability collections. This overview makes it possible to see less important slices and more severe hotspots at a glance. Initiating immediate vulnerability response and prioritizing of issues is possible.

User

131

Field

exploit_price_0day1
vulnerability_cvss3_meta_tempscore1
vulnerability_cvss3_meta_basescore1
vulnerability_cvss3_vuldb_tempscore1
vulnerability_cvss3_vuldb_basescore1

Commit Conf

90%40
50%10

Approve Conf

90%40
80%10
IDCommitedUserFieldChangeRemarksAcceptedReasonC
1330420911/24/2022VulD...price_0day$0-$5ksee exploit price documentation11/24/2022accepted
90
1330420811/24/2022VulD...cvss3_meta_tempscore8.5see CVSS documentation11/24/2022accepted
90
1330420711/24/2022VulD...cvss3_meta_basescore8.6see CVSS documentation11/24/2022accepted
90
1330420611/24/2022VulD...cvss3_vuldb_tempscore7.0see CVSS documentation11/24/2022accepted
90
1330420511/24/2022VulD...cvss3_vuldb_basescore7.3see CVSS documentation11/24/2022accepted
90
1330420411/24/2022VulD...cvss2_vuldb_tempscore6.5see CVSS documentation11/24/2022accepted
90
1330420311/24/2022VulD...cvss2_vuldb_basescore7.5see CVSS documentation11/24/2022accepted
90
1330420211/24/2022VulD...cvss3_cna_basescore10.0see CVSS documentation11/24/2022accepted
90
1330420111/24/2022VulD...cvss3_vuldb_eXderived from historical data11/24/2022accepted
80
1330420011/24/2022VulD...cvss2_vuldb_eNDderived from historical data11/24/2022accepted
80
1330419911/24/2022VulD...cvss2_vuldb_rlOFderived from vuldb v3 vector11/24/2022accepted
80
1330419811/24/2022VulD...cvss2_vuldb_rcCderived from vuldb v3 vector11/24/2022accepted
80
1330419711/24/2022VulD...cvss2_vuldb_aiPderived from vuldb v3 vector11/24/2022accepted
80
1330419611/24/2022VulD...cvss2_vuldb_iiPderived from vuldb v3 vector11/24/2022accepted
80
1330419511/24/2022VulD...cvss2_vuldb_ciPderived from vuldb v3 vector11/24/2022accepted
80
1330419411/24/2022VulD...cvss2_vuldb_auNderived from vuldb v3 vector11/24/2022accepted
80
1330419311/24/2022VulD...cvss2_vuldb_acLderived from vuldb v3 vector11/24/2022accepted
80
1330419211/24/2022VulD...cvss2_vuldb_avNderived from vuldb v3 vector11/24/2022accepted
80
1330419111/24/2022VulD...date1669244400 (11/24/2022)11/24/2022accepted
90
1330419011/24/2022VulD...cve_nvd_summaryA remote code execution (RCE) vulnerability in Optica allows unauthenticated attackers to execute arbitrary code via specially crafted JSON payloads. Specially crafted JSON payloads may lead to RCE (remote code execution) on the attacked system running Optica. The vulnerability was patched in v. 0.10.2, where the call to the function `oj.load` was changed to `oj.safe_load`.cve.org11/24/2022accepted
90

30 more entries are not shown

Might our Artificial Intelligence support you?

Check our Alexa App!