Grails Spring Security Core Plugin privileges management

A vulnerability, which was classified as critical, was found in Grails Spring Security Core Plugin. Affected is an unknown function. The manipulation leads to improper privilege management. Using CWE to declare the problem leads to CWE-269. The weakness was disclosed 11/24/2022 as GHSA-frqg-vvxg-jqqh. The advisory is available at github.com. This vulnerability is traded as CVE-2022-41923. It is possible to launch the attack remotely. There are no technical details available. There is no exploit available. The structure of the vulnerability defines a possible price range of USD $0-$5k at the moment. This vulnerability is assigned to T1068 by the MITRE ATT&CK project. It is declared as not defined. As 0-day the estimated underground price was around $0-$5k. It is recommended to upgrade the affected component. A possible mitigation has been published before and not just after the disclosure of the vulnerability.

Timeline

The analysis of the timeline helps to identify the required approach and handling of single vulnerabilities and vulnerability collections. This overview makes it possible to see less important slices and more severe hotspots at a glance. Initiating immediate vulnerability response and prioritizing of issues is possible.

User

129

Field

exploit_price_0day1
vulnerability_cvss3_meta_tempscore1
vulnerability_cvss3_meta_basescore1
vulnerability_cvss3_vuldb_tempscore1
vulnerability_cvss3_vuldb_basescore1

Commit Conf

90%38
50%10

Approve Conf

90%38
80%10
IDCommitedUserFieldChangeRemarksAcceptedReasonC
1330445711/24/2022VulD...price_0day$0-$5ksee exploit price documentation11/24/2022accepted
90
1330445611/24/2022VulD...cvss3_meta_tempscore8.0see CVSS documentation11/24/2022accepted
90
1330445511/24/2022VulD...cvss3_meta_basescore8.2see CVSS documentation11/24/2022accepted
90
1330445411/24/2022VulD...cvss3_vuldb_tempscore7.0see CVSS documentation11/24/2022accepted
90
1330445311/24/2022VulD...cvss3_vuldb_basescore7.3see CVSS documentation11/24/2022accepted
90
1330445211/24/2022VulD...cvss2_vuldb_tempscore6.5see CVSS documentation11/24/2022accepted
90
1330445111/24/2022VulD...cvss2_vuldb_basescore7.5see CVSS documentation11/24/2022accepted
90
1330445011/24/2022VulD...cvss3_cna_basescore9.1see CVSS documentation11/24/2022accepted
90
1330444911/24/2022VulD...cvss3_vuldb_eXderived from historical data11/24/2022accepted
80
1330444811/24/2022VulD...cvss2_vuldb_eNDderived from historical data11/24/2022accepted
80
1330444711/24/2022VulD...cvss2_vuldb_rlOFderived from vuldb v3 vector11/24/2022accepted
80
1330444611/24/2022VulD...cvss2_vuldb_rcCderived from vuldb v3 vector11/24/2022accepted
80
1330444511/24/2022VulD...cvss2_vuldb_aiPderived from vuldb v3 vector11/24/2022accepted
80
1330444411/24/2022VulD...cvss2_vuldb_iiPderived from vuldb v3 vector11/24/2022accepted
80
1330444311/24/2022VulD...cvss2_vuldb_ciPderived from vuldb v3 vector11/24/2022accepted
80
1330444211/24/2022VulD...cvss2_vuldb_auNderived from vuldb v3 vector11/24/2022accepted
80
1330444111/24/2022VulD...cvss2_vuldb_acLderived from vuldb v3 vector11/24/2022accepted
80
1330444011/24/2022VulD...cvss2_vuldb_avNderived from vuldb v3 vector11/24/2022accepted
80
1330443911/24/2022VulD...date1669244400 (11/24/2022)11/24/2022accepted
90
1330443811/24/2022VulD...cve_nvd_summaryGrails Spring Security Core plugin is vulnerable to privilege escalation. The vulnerability allows an attacker access to one endpoint (i.e. the targeted endpoint) using the authorization requirements of a different endpoint (i.e. the donor endpoint). In some Grails framework applications, access to the targeted endpoint will be granted based on meeting the authorization requirements of the donor endpoint, which can result in a privilege escalation attack. This vulnerability has been patched in grails-spring-security-core versions 3.3.2, 4.0.5 and 5.1.1. Impacted Applications: Grails Spring Security Core plugin versions: 1.x 2.x >=3.0.0 <3.3.2 >=4.0.0 <4.0.5 >=5.0.0 <5.1.1 We strongly suggest that all Grails framework applications using the Grails Spring Security Core plugin be updated to a patched release of the plugin. Workarounds: Users should create a subclass extending one of the following classes from the `grails.plugin.springsecurity.web.access.intercept` package, depending on their security configuration: * `AnnotationFilterInvocationDefinition` * `InterceptUrlMapFilterInvocationDefinition` * `RequestmapFilterInvocationDefinition` In each case, the subclass should override the `calculateUri` method like so: ``` @Override protected String calculateUri(HttpServletRequest request) { UrlPathHelper.defaultInstance.getRequestUri(request) } ``` This should be considered a temporary measure, as the patched versions of grails-spring-security-core deprecates the `calculateUri` method. Once upgraded to a patched version of the plugin, this workaround is no longer needed. The workaround is especially important for version 2.x, as no patch is available version 2.x of the GSSC plugin.cve.org11/24/2022accepted
90

28 more entries are not shown

Want to stay up to date on a daily basis?

Enable the mail alert feature now!