Tailscale up to 1.32.2 on Windows tailscaled cross-site request forgery

A vulnerability has been found in Tailscale up to 1.32.2 and classified as problematic. Affected by this vulnerability is an unknown functionality of the component tailscaled. The manipulation leads to cross-site request forgery. The CWE definition for the vulnerability is CWE-352. The weakness was presented 11/24/2022 as GHSA-vqp6-rc3h-83cp. It is possible to read the advisory at github.com. This vulnerability is known as CVE-2022-41924. The attack can be launched remotely. There are no technical details available. There is no exploit available. The pricing for an exploit might be around USD $0-$5k at the moment. It is declared as not defined. We expect the 0-day to have been worth approximately $0-$5k. Upgrading to version 1.32.3 is able to address this issue. It is recommended to upgrade the affected component. A possible mitigation has been published before and not just after the disclosure of the vulnerability.

Timeline

The analysis of the timeline helps to identify the required approach and handling of single vulnerabilities and vulnerability collections. This overview makes it possible to see less important slices and more severe hotspots at a glance. Initiating immediate vulnerability response and prioritizing of issues is possible.

User

132

Field

exploit_price_0day1
vulnerability_cvss3_meta_tempscore1
vulnerability_cvss3_meta_basescore1
vulnerability_cvss3_vuldb_tempscore1
vulnerability_cvss3_vuldb_basescore1

Commit Conf

90%41
50%10

Approve Conf

90%41
80%10
IDCommitedUserFieldChangeRemarksAcceptedReasonC
1330450811/24/2022VulD...price_0day$0-$5ksee exploit price documentation11/24/2022accepted
90
1330450711/24/2022VulD...cvss3_meta_tempscore6.8see CVSS documentation11/24/2022accepted
90
1330450611/24/2022VulD...cvss3_meta_basescore6.9see CVSS documentation11/24/2022accepted
90
1330450511/24/2022VulD...cvss3_vuldb_tempscore4.1see CVSS documentation11/24/2022accepted
90
1330450411/24/2022VulD...cvss3_vuldb_basescore4.3see CVSS documentation11/24/2022accepted
90
1330450311/24/2022VulD...cvss2_vuldb_tempscore4.4see CVSS documentation11/24/2022accepted
90
1330450211/24/2022VulD...cvss2_vuldb_basescore5.0see CVSS documentation11/24/2022accepted
90
1330450111/24/2022VulD...cvss3_cna_basescore9.6see CVSS documentation11/24/2022accepted
90
1330450011/24/2022VulD...cvss3_vuldb_eXderived from historical data11/24/2022accepted
80
1330449911/24/2022VulD...cvss2_vuldb_eNDderived from historical data11/24/2022accepted
80
1330449811/24/2022VulD...cvss2_vuldb_rlOFderived from vuldb v3 vector11/24/2022accepted
80
1330449711/24/2022VulD...cvss2_vuldb_rcCderived from vuldb v3 vector11/24/2022accepted
80
1330449611/24/2022VulD...cvss2_vuldb_aiNderived from vuldb v3 vector11/24/2022accepted
80
1330449511/24/2022VulD...cvss2_vuldb_iiPderived from vuldb v3 vector11/24/2022accepted
80
1330449411/24/2022VulD...cvss2_vuldb_ciNderived from vuldb v3 vector11/24/2022accepted
80
1330449311/24/2022VulD...cvss2_vuldb_auNderived from vuldb v3 vector11/24/2022accepted
80
1330449211/24/2022VulD...cvss2_vuldb_acLderived from vuldb v3 vector11/24/2022accepted
80
1330449111/24/2022VulD...cvss2_vuldb_avNderived from vuldb v3 vector11/24/2022accepted
80
1330449011/24/2022VulD...date1669244400 (11/24/2022)11/24/2022accepted
90
1330448911/24/2022VulD...cve_nvd_summaryA vulnerability identified in the Tailscale Windows client allows a malicious website to reconfigure the Tailscale daemon `tailscaled`, which can then be used to remotely execute code. In the Tailscale Windows client, the local API was bound to a local TCP socket, and communicated with the Windows client GUI in cleartext with no Host header verification. This allowed an attacker-controlled website visited by the node to rebind DNS to an attacker-controlled DNS server, and then make local API requests in the client, including changing the coordination server to an attacker-controlled coordination server. An attacker-controlled coordination server can send malicious URL responses to the client, including pushing executables or installing an SMB share. These allow the attacker to remotely execute code on the node. All Windows clients prior to version v.1.32.3 are affected. If you are running Tailscale on Windows, upgrade to v1.32.3 or later to remediate the issue.cve.org11/24/2022accepted
90

31 more entries are not shown

Are you interested in using VulDB?

Download the whitepaper to learn more about our service!