libdwarf up to 2017-03-21 dwarf_decode_s_leb128_chk out-of-bounds read

CVSS Meta Temp Score
CVSS is a standardized scoring system to determine possibilities of attacks. The Temp Score considers temporal factors like disclosure, exploit and countermeasures. The unique Meta Score calculates the average score of different sources to provide a normalized scoring system.
Current Exploit Price (≈)
Our analysts are monitoring exploit markets and are in contact with vulnerability brokers. The range indicates the observed or calculated exploit price to be seen on exploit markets. A good indicator to understand the monetary effort required for and the popularity of an attack.
CTI Interest Score
Our Cyber Threat Intelligence team is monitoring different web sites, mailing lists, exploit markets and social media networks. The CTI Interest Score identifies the interest of attackers and the security community for this specific vulnerability in real-time. A high score indicates an elevated risk to be targeted for this vulnerability.
8.5$0-$5k0.00

A vulnerability, which was classified as critical, has been found in libdwarf up to 2017-03-21 (Programming Tool Software). Affected by this issue is the function dwarf_decode_s_leb128_chk. The manipulation with an unknown input leads to a information disclosure vulnerability. Using CWE to declare the problem leads to CWE-125. Impacted is confidentiality, integrity, and availability. CVE summarizes:

An issue, also known as DW201703-002, was discovered in libdwarf 2017-03-21. In _dwarf_decode_s_leb128_chk() a byte pointer was dereferenced just before it was checked for being in bounds, leading to a heap-based buffer over-read.

The bug was discovered 03/20/2017. The weakness was presented 05/18/2017 (Website). The advisory is shared for download at prevanders.net. This vulnerability is handled as CVE-2017-9054 since 05/18/2017. The exploitation is known to be easy. The attack may be launched remotely. No form of authentication is required for exploitation. There are known technical details, but no exploit is available. The current price for an exploit might be approx. USD $0-$5k (estimation calculated on 09/30/2020).

The vulnerability was handled as a non-public zero-day exploit for at least 59 days. During that time the estimated underground price was around $0-$5k.

There is no information about possible countermeasures known. It may be suggested to replace the affected object with an alternative product.

See 101467 and 101469 for similar entries.

Productinfoedit

Type

Name

CPE 2.3infoedit

CPE 2.2infoedit

CVSSv3infoedit

VulDB Meta Base Score: 8.5
VulDB Meta Temp Score: 8.5

VulDB Base Score: 7.3
VulDB Temp Score: 7.3
VulDB Vector: 🔍
VulDB Reliability: 🔍

NVD Base Score: 9.8
NVD Vector: 🔍

CVSSv2infoedit

AVACAuCIA
🔍🔍🔍🔍🔍🔍
🔍🔍🔍🔍🔍🔍
🔍🔍🔍🔍🔍🔍
VectorComplexityAuthenticationConfidentialityIntegrityAvailability
unlockunlockunlockunlockunlockunlock
unlockunlockunlockunlockunlockunlock
unlockunlockunlockunlockunlockunlock

VulDB Base Score: 🔍
VulDB Temp Score: 🔍
VulDB Reliability: 🔍

NVD Base Score: 🔍

Exploitinginfoedit

Class: Information disclosure
CWE: CWE-125
ATT&CK: Unknown

Local: No
Remote: Yes

Availability: 🔍
Status: Not defined
Price Prediction: 🔍
Current Price Estimation: 🔍

0-Dayunlockunlockunlockunlock
Todayunlockunlockunlockunlock

Threat Intelligenceinfoedit

Interest: 🔍
Active Actors: 🔍
Active APT Groups: 🔍

Countermeasuresinfoedit

Recommended: no mitigation known
Status: 🔍

0-Day Time: 🔍

Timelineinfoedit

03/20/2017 🔍
05/18/2017 +59 days 🔍
05/18/2017 +0 days 🔍
05/18/2017 +0 days 🔍
05/18/2017 +0 days 🔍
09/30/2020 +1231 days 🔍

Sourcesinfoedit

Advisory: prevanders.net
Status: Not defined

CVE: CVE-2017-9054 (🔍)
OSVDB: - CVE-2017-9054 - Libdwarf Project - Libdwarf - High

See also: 🔍

Entryinfoedit

Created: 05/18/2017 04:41 PM
Updated: 09/30/2020 09:56 AM
Changes: (2) vulnerability_discoverydate source_osvdb_title
Complete: 🔍

Comments

No comments yet. Languages: en.

Please log in to comment.

Do you need the next level of professionalism?

Upgrade your account now!