VDB-106439 · CVE-2017-14341 · Qualys 170594

ImageMagick 7.0.6-6 coders/wpg.c ReadWPGImage Image File resource consumption

CVSS Meta Temp Score
CVSS is a standardized scoring system to determine possibilities of attacks. The Temp Score considers temporal factors like disclosure, exploit and countermeasures. The unique Meta Score calculates the average score of different sources to provide a normalized scoring system.
Current Exploit Price (≈)
Our analysts are monitoring exploit markets and are in contact with vulnerability brokers. The range indicates the observed or calculated exploit price to be seen on exploit markets. A good indicator to understand the monetary effort required for and the popularity of an attack.
CTI Interest Score
Our Cyber Threat Intelligence team is monitoring different web sites, mailing lists, exploit markets and social media networks. The CTI Interest Score identifies the interest of attackers and the security community for this specific vulnerability in real-time. A high score indicates an elevated risk to be targeted for this vulnerability.
4.7$0-$5k0.00

A vulnerability was found in ImageMagick 7.0.6-6 (Image Processing Software) and classified as problematic. This issue affects the function ReadWPGImage of the file coders/wpg.c. The manipulation as part of a Image File leads to a resource consumption vulnerability. Using CWE to declare the problem leads to CWE-400. The product does not properly control the allocation and maintenance of a limited resource, thereby enabling an actor to influence the amount of resources consumed, eventually leading to the exhaustion of available resources. Impacted is availability.

The bug was discovered 09/12/2017. The weakness was shared 09/12/2017 (GitHub Repository). It is possible to read the advisory at github.com. The identification of this vulnerability is CVE-2017-14341 since 09/12/2017. The attack may be initiated remotely. No form of authentication is needed for a successful exploitation. It demands that the victim is doing some kind of user interaction. Technical details of the vulnerability are known, but there is no available exploit.

The vulnerability scanner Nessus provides a plugin with the ID 103756 (Debian DLA-1131-1 : imagemagick security update), which helps to determine the existence of the flaw in a target environment. It is assigned to the family Debian Local Security Checks and running in the context l. The commercial vulnerability scanner Qualys is able to test this issue with plugin 170594 (OpenSUSE Security Update for GraphicsMagick (openSUSE-SU-2017:3223-1)).

Upgrading eliminates this vulnerability. A possible mitigation has been published 4 weeks after the disclosure of the vulnerability.

The vulnerability is also documented in the vulnerability database at Tenable (103756). The entries 105917, 105931, 106188 and 106189 are related to this item.

Productinfo

Type

Name

Version

License

CPE 2.3info

CPE 2.2info

CVSSv3info

VulDB Meta Base Score: 4.9
VulDB Meta Temp Score: 4.7

VulDB Base Score: 3.3
VulDB Temp Score: 2.9
VulDB Vector: 🔍
VulDB Reliability: 🔍

NVD Base Score: 6.5
NVD Vector: 🔍

CVSSv2info

AVACAuCIA
💳💳💳💳💳💳
💳💳💳💳💳💳
💳💳💳💳💳💳
VectorComplexityAuthenticationConfidentialityIntegrityAvailability
unlockunlockunlockunlockunlockunlock
unlockunlockunlockunlockunlockunlock
unlockunlockunlockunlockunlockunlock

VulDB Base Score: 🔍
VulDB Temp Score: 🔍
VulDB Reliability: 🔍

NVD Base Score: 🔍

Exploitinginfo

Class: Resource consumption
CWE: CWE-400 / CWE-404
ATT&CK: Unknown

Local: No
Remote: Yes

Availability: 🔍
Status: Not defined

EPSS Score: 🔍
EPSS Percentile: 🔍

Price Prediction: 🔍
Current Price Estimation: 🔍

0-Dayunlockunlockunlockunlock
Todayunlockunlockunlockunlock

Nessus ID: 103756
Nessus Name: Debian DLA-1131-1 : imagemagick security update
Nessus File: 🔍
Nessus Risk: 🔍
Nessus Family: 🔍
Nessus Context: 🔍

OpenVAS ID: 870971
OpenVAS Name: SuSE Update for ImageMagick openSUSE-SU-2017:3420-1 (ImageMagick)
OpenVAS File: 🔍
OpenVAS Family: 🔍

Qualys ID: 🔍
Qualys Name: 🔍

Threat Intelligenceinfo

Interest: 🔍
Active Actors: 🔍
Active APT Groups: 🔍

Countermeasuresinfo

Recommended: Upgrade
Status: 🔍

Reaction Time: 🔍
0-Day Time: 🔍
Exposure Time: 🔍

Patch: github.com

Timelineinfo

09/12/2017 🔍
09/12/2017 +0 days 🔍
09/12/2017 +0 days 🔍
09/12/2017 +0 days 🔍
09/13/2017 +1 days 🔍
10/10/2017 +27 days 🔍
10/11/2017 +1 days 🔍
12/28/2022 +1904 days 🔍

Sourcesinfo

Product: imagemagick.org

Advisory: 7d63315a64267c565d1f34b9cb523a14616fed24
Status: Not defined
Confirmation: 🔍

CVE: CVE-2017-14341 (🔍)
See also: 🔍

Entryinfo

Created: 09/13/2017 10:58 AM
Updated: 12/28/2022 01:59 PM
Changes: 09/13/2017 10:58 AM (63), 11/15/2019 09:46 AM (14), 12/28/2022 01:53 PM (5), 12/28/2022 01:59 PM (1)
Complete: 🔍

Discussion

No comments yet. Languages: en.

Please log in to comment.

Interested in the pricing of exploits?

See the underground prices here!