Yoast SEO Plugin up to 5.7.x on WordPress class-gsc-table.php cross site scripting

EntryeditHistoryDiffjsonxmlCTI
CVSS Meta Temp Score
CVSS is a standardized scoring system to determine possibilities of attacks. The Temp Score considers temporal factors like disclosure, exploit and countermeasures. The unique Meta Score calculates the average score of different sources to provide a normalized scoring system.
Current Exploit Price (≈)
Our analysts are monitoring exploit markets and are in contact with vulnerability brokers. The range indicates the observed or calculated exploit price to be seen on exploit markets. A good indicator to understand the monetary effort required for and the popularity of an attack.
CTI Interest Score
Our Cyber Threat Intelligence team is monitoring different web sites, mailing lists, exploit markets and social media networks. The CTI Interest Score identifies the interest of attackers and the security community for this specific vulnerability in real-time. A high score indicates an elevated risk to be targeted for this vulnerability.
3.4$0-$5k0.00

A vulnerability was found in Yoast SEO Plugin up to 5.7.x on WordPress (WordPress Plugin). It has been classified as problematic. Affected is some unknown functionality of the file admin/google_search_console/class-gsc-table.php. The manipulation with an unknown input leads to a cross site scripting vulnerability. CWE is classifying the issue as CWE-79. This is going to have an impact on integrity. An attacker might be able to inject arbitrary html and script code into the web site. This would alter the appearance and would make it possible to initiate further attacks against site visitors.

The bug was discovered 11/15/2017. The weakness was disclosed 11/16/2017 as 1766831 (Website). The advisory is available at packetstormsecurity.com. This vulnerability is traded as CVE-2017-16842 since 11/15/2017. It is possible to launch the attack remotely. A authentication is required for exploitation. Successful exploitation requires user interaction by the victim. Technical details are known, but there is no available exploit. This vulnerability is assigned to T1059.007 by the MITRE ATT&CK project.

Upgrading to version 5.8.0 eliminates this vulnerability.

Productinfoedit

Type

Name

CPE 2.3infoedit

CPE 2.2infoedit

CVSSv3infoedit

VulDB Meta Base Score: 3.6
VulDB Meta Temp Score: 3.4

VulDB Base Score: 2.4
VulDB Temp Score: 2.3
VulDB Vector: 🔍
VulDB Reliability: 🔍

NVD Base Score: 4.8
NVD Vector: 🔍

CVSSv2infoedit

AVACAuCIA
🔍🔍🔍🔍🔍🔍
🔍🔍🔍🔍🔍🔍
🔍🔍🔍🔍🔍🔍
VectorComplexityAuthenticationConfidentialityIntegrityAvailability
unlockunlockunlockunlockunlockunlock
unlockunlockunlockunlockunlockunlock
unlockunlockunlockunlockunlockunlock

VulDB Base Score: 🔍
VulDB Temp Score: 🔍
VulDB Reliability: 🔍

NVD Base Score: 🔍

Exploitinginfoedit

Class: Cross site scripting
CWE: CWE-79
ATT&CK: T1059.007

Local: No
Remote: Yes

Availability: 🔍
Status: Not defined

Price Prediction: 🔍
Current Price Estimation: 🔍

0-Dayunlockunlockunlockunlock
Todayunlockunlockunlockunlock

OpenVAS ID: 881279
OpenVAS Name: WordPress Yoast SEO Plugin XSS Vulnerability
OpenVAS File: 🔍
OpenVAS Family: 🔍

Threat Intelligenceinfoedit

Threat: 🔍
Adversaries: 🔍
Geopolitics: 🔍
Economy: 🔍
Predictions: 🔍
Remediation: 🔍

Countermeasuresinfoedit

Recommended: Upgrade
Status: 🔍

0-Day Time: 🔍

Upgrade: Yoast SEO Plugin 5.8.0

Timelineinfoedit

11/15/2017 🔍
11/15/2017 +0 days 🔍
11/15/2017 +0 days 🔍
11/16/2017 +1 days 🔍
11/16/2017 +0 days 🔍
01/24/2021 +1165 days 🔍

Sourcesinfoedit

Advisory: 1766831
Status: Not defined

CVE: CVE-2017-16842 (🔍)

Entryinfoedit

Created: 11/16/2017 05:47 PM
Updated: 01/24/2021 08:32 AM
Changes: (2) advisory_identifier vulnerability_cvss2_nvd_basescore
Complete: 🔍

Comments

No comments yet. Please log in to comment.

Do you want to use VulDB in your project?

Use the official API to access entries easily!