Wireshark up to 2.4.2 CIP Safety Dissector packet-cipsafety.c unusual condition

CVSS Meta Temp Score
CVSS is a standardized scoring system to determine possibilities of attacks. The Temp Score considers temporal factors like disclosure, exploit and countermeasures. The unique Meta Score calculates the average score of different sources to provide a normalized scoring system.
Current Exploit Price (≈)
Our analysts are monitoring exploit markets and are in contact with vulnerability brokers. The range indicates the observed or calculated exploit price to be seen on exploit markets. A good indicator to understand the monetary effort required for and the popularity of an attack.
CTI Interest Score
Our Cyber Threat Intelligence team is monitoring different web sites, mailing lists, exploit markets and social media networks. The CTI Interest Score identifies the interest of attackers and the security community for this specific vulnerability in real-time. A high score indicates an elevated risk to be targeted for this vulnerability.
5.7$0-$5k0.00

A vulnerability was found in Wireshark up to 2.4.2 (Packet Analyzer Software). It has been declared as problematic. Affected by this vulnerability is an unknown code of the file epan/dissectors/packet-cipsafety.c of the component CIP Safety Dissector. The manipulation with an unknown input leads to a unusual condition vulnerability. The CWE definition for the vulnerability is CWE-754. The product does not check or incorrectly checks for unusual or exceptional conditions that are not expected to occur frequently during day to day operation of the product. As an impact it is known to affect availability. The summary by CVE is:

In Wireshark 2.4.0 to 2.4.2 and 2.2.0 to 2.2.10, the CIP Safety dissector could crash. This was addressed in epan/dissectors/packet-cipsafety.c by validating the packet length.

The bug was discovered 11/30/2017. The weakness was shared 12/01/2017 as Bug 14250 as confirmed bug report (Bugzilla). The advisory is shared at bugs.wireshark.org. This vulnerability is known as CVE-2017-17085 since 12/01/2017. The attack can be launched remotely. The exploitation doesn't need any form of authentication. It demands that the victim is doing some kind of user interaction. Technical details and also a public exploit are known.

It is possible to download the exploit at exploit-db.com. It is declared as proof-of-concept. The vulnerability was handled as a non-public zero-day exploit for at least 1 days. During that time the estimated underground price was around $0-$5k. The vulnerability scanner Nessus provides a plugin with the ID 105121 (Debian DSA-4060-1 : wireshark - security update), which helps to determine the existence of the flaw in a target environment. It is assigned to the family Debian Local Security Checks and running in the context l. The commercial vulnerability scanner Qualys is able to test this issue with plugin 170588 (OpenSUSE Security Update for wireshark (openSUSE-SU-2017:3202-1)).

Upgrading eliminates this vulnerability. A possible mitigation has been published 2 weeks after the disclosure of the vulnerability.

The vulnerability is also documented in the databases at Tenable (105121) and Exploit-DB (43233). The entries 110147 and 110148 are related to this item.

Productinfo

Type

Name

Version

License

CPE 2.3info

CPE 2.2info

CVSSv4info

VulDB CVSS-B Score: 🔍
VulDB CVSS-BT Score: 🔍
VulDB Vector: 🔍
VulDB Reliability: 🔍

CVSSv3info

VulDB Meta Base Score: 5.9
VulDB Meta Temp Score: 5.7

VulDB Base Score: 4.3
VulDB Temp Score: 3.9
VulDB Vector: 🔍
VulDB Reliability: 🔍

NVD Base Score: 7.5
NVD Vector: 🔍

CVSSv2info

AVACAuCIA
💳💳💳💳💳💳
💳💳💳💳💳💳
💳💳💳💳💳💳
VectorComplexityAuthenticationConfidentialityIntegrityAvailability
unlockunlockunlockunlockunlockunlock
unlockunlockunlockunlockunlockunlock
unlockunlockunlockunlockunlockunlock

VulDB Base Score: 🔍
VulDB Temp Score: 🔍
VulDB Reliability: 🔍

NVD Base Score: 🔍

Exploitinginfo

Class: Unusual condition
CWE: CWE-754
ATT&CK: Unknown

Local: No
Remote: Yes

Availability: 🔍
Access: Public
Status: Proof-of-Concept
Download: 🔍

EPSS Score: 🔍
EPSS Percentile: 🔍

Price Prediction: 🔍
Current Price Estimation: 🔍

0-Dayunlockunlockunlockunlock
Todayunlockunlockunlockunlock

Nessus ID: 105121
Nessus Name: Debian DSA-4060-1 : wireshark - security update
Nessus File: 🔍
Nessus Risk: 🔍
Nessus Family: 🔍
Nessus Context: 🔍

OpenVAS ID: 880359
OpenVAS Name: Wireshark Security Updates (wnpa-sec-2017-49_wnpa-sec-2017-47)-MACOSX
OpenVAS File: 🔍
OpenVAS Family: 🔍

Qualys ID: 🔍
Qualys Name: 🔍

Exploit-DB: 🔍

Threat Intelligenceinfo

Interest: 🔍
Active Actors: 🔍
Active APT Groups: 🔍

Countermeasuresinfo

Recommended: Upgrade
Status: 🔍

Reaction Time: 🔍
0-Day Time: 🔍
Exposure Time: 🔍

Patch: f5939debe96e3c3953c6020818f1fbb80eb83ce8

Timelineinfo

11/30/2017 🔍
11/30/2017 +0 days 🔍
12/01/2017 +1 days 🔍
12/01/2017 +0 days 🔍
12/01/2017 +0 days 🔍
12/02/2017 +1 days 🔍
12/09/2017 +7 days 🔍
12/11/2017 +2 days 🔍
01/16/2023 +1862 days 🔍

Sourcesinfo

Product: wireshark.org

Advisory: Bug 14250
Status: Confirmed
Confirmation: 🔍

CVE: CVE-2017-17085 (🔍)
OVAL: 🔍

SecurityFocus: 102071 - Wireshark 'epan/dissectors/packet-cipsafety.c' Denial of Service Vulnerability

scip Labs: https://www.scip.ch/en/?labs.20161013
See also: 🔍

Entryinfo

Created: 12/02/2017 10:00 AM
Updated: 01/16/2023 03:33 PM
Changes: 12/02/2017 10:00 AM (79), 12/11/2019 08:06 PM (9), 01/16/2023 03:33 PM (5)
Complete: 🔍

Discussion

No comments yet. Languages: en.

Please log in to comment.

Are you interested in using VulDB?

Download the whitepaper to learn more about our service!