VDB-118461 · CVE-2018-11142 · Qualys 13151

Quest KACE System Management Appliance 8.0.318 settings_network.php POST Request improper authorization

entryeditHistoryDiffjsonxmlCTI
CVSS Meta Temp Score
CVSS is a standardized scoring system to determine possibilities of attacks. The Temp Score considers temporal factors like disclosure, exploit and countermeasures. The unique Meta Score calculates the average score of different sources to provide a normalized scoring system.
Current Exploit Price (≈)
Our analysts are monitoring exploit markets and are in contact with vulnerability brokers. The range indicates the observed or calculated exploit price to be seen on exploit markets. A good indicator to understand the monetary effort required for and the popularity of an attack.
CTI Interest Score
Our Cyber Threat Intelligence team is monitoring different web sites, mailing lists, exploit markets and social media networks. The CTI Interest Score identifies the interest of attackers and the security community for this specific vulnerability in real-time. A high score indicates an elevated risk to be targeted for this vulnerability.
5.4$0-$5k0.00

A vulnerability, which was classified as critical, was found in Quest KACE System Management Appliance 8.0.318 (Endpoint Management Software). This affects an unknown function of the file systemui/settings_network.php. The manipulation as part of a POST Request leads to a privilege escalation vulnerability. CWE is classifying the issue as CWE-285. This is going to have an impact on confidentiality, integrity, and availability. The summary by CVE is:

The 'systemui/settings_network.php' and 'systemui/settings_patching.php' scripts in the Quest KACE System Management Appliance 8.0.318 are accessible only from localhost. This restriction can be bypassed by modifying the 'Host' and 'X_Forwarded_For' HTTP headers in a POST request. An anonymous user can abuse this vulnerability to execute critical functions without authorization.

The bug was discovered 05/31/2018. The weakness was released 05/31/2018 (Website). The advisory is shared at coresecurity.com. This vulnerability is uniquely identified as CVE-2018-11142 since 05/16/2018. The exploitability is told to be easy. An attack has to be approached locally. No form of authentication is needed for exploitation. Technical details are known, but no exploit is available. MITRE ATT&CK project uses the attack technique T1548.002 for this issue.

The commercial vulnerability scanner Qualys is able to test this issue with plugin 13151 (Quest KACE System Management Appliance Multiple Vulnerabilities).

There is no information about possible countermeasures known. It may be suggested to replace the affected object with an alternative product.

Entries connected to this vulnerability are available at 118451, 118452, 118453 and 118454.

Productinfoedit

Type

Vendor

Name

CPE 2.3infoedit

CPE 2.2infoedit

CVSSv3infoedit

VulDB Meta Base Score: 5.4
VulDB Meta Temp Score: 5.4

VulDB Base Score: 5.3
VulDB Temp Score: 5.3
VulDB Vector: 🔍
VulDB Reliability: 🔍

NVD Base Score: 5.5
NVD Vector: 🔍

CVSSv2infoedit

AVACAuCIA
🔍🔍🔍🔍🔍🔍
🔍🔍🔍🔍🔍🔍
🔍🔍🔍🔍🔍🔍
VectorComplexityAuthenticationConfidentialityIntegrityAvailability
unlockunlockunlockunlockunlockunlock
unlockunlockunlockunlockunlockunlock
unlockunlockunlockunlockunlockunlock

VulDB Base Score: 🔍
VulDB Temp Score: 🔍
VulDB Reliability: 🔍

NVD Base Score: 🔍

Exploitinginfoedit

Class: Privilege escalation
CWE: CWE-285
ATT&CK: T1548.002

Local: Yes
Remote: No

Availability: 🔍
Status: Not defined

Price Prediction: 🔍
Current Price Estimation: 🔍

0-Dayunlockunlockunlockunlock
Todayunlockunlockunlockunlock

Qualys ID: 🔍
Qualys Name: 🔍

Threat Intelligenceinfoedit

Threat: 🔍
Adversaries: 🔍
Geopolitics: 🔍
Economy: 🔍
Predictions: 🔍
Remediation: 🔍

Countermeasuresinfoedit

Recommended: no mitigation known
Status: 🔍

Timelineinfoedit

05/16/2018 🔍
05/31/2018 +14 days 🔍
05/31/2018 +0 days 🔍
05/31/2018 +0 days 🔍
06/01/2018 +1 days 🔍
02/10/2020 +619 days 🔍

Sourcesinfoedit

Vendor: https://www.quest.com/

Advisory: coresecurity.com
Status: Not defined

CVE: CVE-2018-11142 (🔍)
See also: 🔍

Entryinfoedit

Created: 06/01/2018 10:23 AM
Updated: 02/10/2020 03:44 PM
Changes: (1) vulnerability_discoverydate
Complete: 🔍

Comments

No comments yet. Please log in to comment.

Want to stay up to date on a daily basis?

Enable the mail alert feature now!