Apple macOS up to 10.13.5 apache_mod_php memory corruption

entryeditHistoryDiffjsonxmlCTI
CVSS Meta Temp Score
CVSS is a standardized scoring system to determine possibilities of attacks. The Temp Score considers temporal factors like disclosure, exploit and countermeasures. The unique Meta Score calculates the average score of different sources to provide a normalized scoring system.
Current Exploit Price (≈)
Our analysts are monitoring exploit markets and are in contact with vulnerability brokers. The range indicates the observed or calculated exploit price to be seen on exploit markets. A good indicator to understand the monetary effort required for and the popularity of an attack.
CTI Interest Score
Our Cyber Threat Intelligence team is monitoring different web sites, mailing lists, exploit markets and social media networks. The CTI Interest Score identifies the interest of attackers and the security community for this specific vulnerability in real-time. A high score indicates an elevated risk to be targeted for this vulnerability.
8.8$0-$5k0.00

A vulnerability was found in Apple macOS up to 10.13.5 (Operating System). It has been classified as critical. Affected is an unknown functionality of the component apache_mod_php. The manipulation with an unknown input leads to a memory corruption vulnerability. CWE is classifying the issue as CWE-119. This is going to have an impact on confidentiality, integrity, and availability.

The bug was discovered 03/01/2018. The weakness was shared 06/01/2018 with Nanyang Technological University as HT208849 as confirmed advisory (Website). The advisory is shared for download at support.apple.com. This vulnerability is traded as CVE-2018-7584 since 03/01/2018. The exploitability is told to be easy. It is possible to launch the attack remotely. The exploitation doesn't require any form of authentication. Technical details are unknown but a public exploit is available. The advisory points out:

This issue was addressed by updating to php version 7.1.16.

It is declared as proof-of-concept. The exploit is shared for download at exploit-db.com. As 0-day the estimated underground price was around $25k-$100k. The vulnerability scanner Nessus provides a plugin with the ID 107218 (PHP 7.1.x < 7.1.15 Stack Buffer Overflow), which helps to determine the existence of the flaw in a target environment. It is assigned to the family CGI abuses and running in the context remote. The commercial vulnerability scanner Qualys is able to test this issue with plugin 197084 (Ubuntu Security Notification for Php5, Php7.0, Php7.1 Vulnerabilities (USN-3600-1)).

Upgrading to version 10.13.5 2018-003 eliminates this vulnerability. A possible mitigation has been published immediately after the disclosure of the vulnerability.

The vulnerability is also documented in the databases at SecurityFocus (BID 103204) and Tenable (107218). The entries 80326, 80327, 83183 and 83184 are related to this item.

Productinfoedit

Type

Vendor

Name

CPE 2.3infoedit

CPE 2.2infoedit

CVSSv3infoedit

VulDB Meta Base Score: 9.8
VulDB Meta Temp Score: 8.8

VulDB Base Score: 9.8
VulDB Temp Score: 8.8
VulDB Vector: 🔍
VulDB Reliability: 🔍

NVD Base Score: 9.8
NVD Vector: 🔍

CVSSv2infoedit

AVACAuCIA
🔍🔍🔍🔍🔍🔍
🔍🔍🔍🔍🔍🔍
🔍🔍🔍🔍🔍🔍
VectorComplexityAuthenticationConfidentialityIntegrityAvailability
unlockunlockunlockunlockunlockunlock
unlockunlockunlockunlockunlockunlock
unlockunlockunlockunlockunlockunlock

VulDB Base Score: 🔍
VulDB Temp Score: 🔍
VulDB Reliability: 🔍

NVD Base Score: 🔍

Exploitinginfoedit

Class: Memory corruption
CWE: CWE-119
ATT&CK: Unknown

Local: No
Remote: Yes

Availability: 🔍
Access: Public
Status: Proof-of-Concept
Download: 🔍

Price Prediction: 🔍
Current Price Estimation: 🔍

0-Dayunlockunlockunlockunlock
Todayunlockunlockunlockunlock

Nessus ID: 107218
Nessus Name: PHP 7.1.x < 7.1.15 Stack Buffer Overflow
Nessus File: 🔍
Nessus Risk: 🔍
Nessus Family: 🔍
Nessus Context: 🔍

OpenVAS ID: 867216
OpenVAS Name: Fedora Update for php FEDORA-2018-e8bc8d2784
OpenVAS File: 🔍
OpenVAS Family: 🔍

Qualys ID: 🔍
Qualys Name: 🔍

Exploit-DB: 🔍

Threat Intelligenceinfoedit

Threat: 🔍
Adversaries: 🔍
Geopolitics: 🔍
Economy: 🔍
Predictions: 🔍
Remediation: 🔍

Countermeasuresinfoedit

Recommended: Upgrade
Status: 🔍

Reaction Time: 🔍
0-Day Time: 🔍
Exposure Time: 🔍

Upgrade: macOS 10.13.5 2018-003

Timelineinfoedit

03/01/2018 🔍
03/01/2018 +0 days 🔍
03/01/2018 +0 days 🔍
03/01/2018 +0 days 🔍
03/08/2018 +7 days 🔍
06/01/2018 +85 days 🔍
06/01/2018 +0 days 🔍
06/03/2018 +2 days 🔍
02/11/2020 +618 days 🔍

Sourcesinfoedit

Vendor: https://www.apple.com/

Advisory: HT208849
Organization: Nanyang Technological University
Status: Confirmed
Confirmation: 🔍

CVE: CVE-2018-7584 (🔍)
OVAL: 🔍

SecurityFocus: 103204 - PHP CVE-2018-7584 Stack Buffer Overflow Vulnerability

scip Labs: https://www.scip.ch/en/?labs.20180712
See also: 🔍

Entryinfoedit

Created: 06/03/2018 02:13 PM
Updated: 02/11/2020 09:47 PM
Changes: (9) vulnerability_discoverydate advisory_confirm_url exploit_availability exploit_publicity exploit_url source_cve_assigned source_oval_id source_securityfocus_date source_securityfocus_class
Complete: 🔍

Comments

No comments yet. Please log in to comment.

Are you interested in using VulDB?

Download the whitepaper to learn more about our service!