Adobe Acrobat Reader out-of-bounds write

CVSS Meta Temp Score
CVSS is a standardized scoring system to determine possibilities of attacks. The Temp Score considers temporal factors like disclosure, exploit and countermeasures. The unique Meta Score calculates the average score of different sources to provide a normalized scoring system.
Current Exploit Price (≈)
Our analysts are monitoring exploit markets and are in contact with vulnerability brokers. The range indicates the observed or calculated exploit price to be seen on exploit markets. A good indicator to understand the monetary effort required for and the popularity of an attack.
CTI Interest Score
Our Cyber Threat Intelligence team is monitoring different web sites, mailing lists, exploit markets and social media networks. The CTI Interest Score identifies the interest of attackers and the security community for this specific vulnerability in real-time. A high score indicates an elevated risk to be targeted for this vulnerability.
7.9$0-$5k0.00

A vulnerability, which was classified as critical, has been found in Adobe Acrobat Reader up to 2015.006.30418/2017.011.30080/2018.011.20040 (Document Reader Software). Affected by this issue is an unknown part. The manipulation with an unknown input leads to a out-of-bounds write vulnerability. Using CWE to declare the problem leads to CWE-787. The product writes data past the end, or before the beginning, of the intended buffer. Impacted is confidentiality, integrity, and availability.

The bug was discovered 07/10/2018. The weakness was published 07/10/2018 by Aleksandar Nikolic with Zero Day Initiative as APSB18-21 as confirmed security bulletin (Website). The advisory is available at helpx.adobe.com. This vulnerability is handled as CVE-2018-12787 since 06/25/2018. The attack may be launched remotely. No form of authentication is required for exploitation. Successful exploitation requires user interaction by the victim. The technical details are unknown and an exploit is not available. The structure of the vulnerability defines a possible price range of USD $0-$5k at the moment (estimation calculated on 04/06/2023).

The vulnerability scanner Nessus provides a plugin with the ID 111009 (Adobe Acrobat < 15.006.30434 / 17.011.30096 / 18.011.20055 Multiple Vulnerabilities (APSB18-21) (macOS)), which helps to determine the existence of the flaw in a target environment. It is assigned to the family MacOS X Local Security Checks and running in the context l.

Upgrading to version 2015.006.30434, 2017.011.30096 or 2018.011.20055 eliminates this vulnerability. A possible mitigation has been published immediately after the disclosure of the vulnerability.

The vulnerability is also documented in the vulnerability database at Tenable (111009). zdnet.com is providing further details. Similar entries are available at 121210, 121211, 121212 and 121213.

Productinfo

Type

Vendor

Name

Version

License

CPE 2.3info

CPE 2.2info

CVSSv3info

VulDB Meta Base Score: 8.0
VulDB Meta Temp Score: 7.9

VulDB Base Score: 6.3
VulDB Temp Score: 6.0
VulDB Vector: 🔍
VulDB Reliability: 🔍

NVD Base Score: 9.8
NVD Vector: 🔍

CVSSv2info

AVACAuCIA
💳💳💳💳💳💳
💳💳💳💳💳💳
💳💳💳💳💳💳
VectorComplexityAuthenticationConfidentialityIntegrityAvailability
unlockunlockunlockunlockunlockunlock
unlockunlockunlockunlockunlockunlock
unlockunlockunlockunlockunlockunlock

VulDB Base Score: 🔍
VulDB Temp Score: 🔍
VulDB Reliability: 🔍

NVD Base Score: 🔍

Exploitinginfo

Class: Out-of-bounds write
CWE: CWE-787 / CWE-119
ATT&CK: Unknown

Local: No
Remote: Yes

Availability: 🔍
Status: Not defined

EPSS Score: 🔍
EPSS Percentile: 🔍

Price Prediction: 🔍
Current Price Estimation: 🔍

0-Dayunlockunlockunlockunlock
Todayunlockunlockunlockunlock

Nessus ID: 111009
Nessus Name: Adobe Acrobat < 15.006.30434 / 17.011.30096 / 18.011.20055 Multiple Vulnerabilities (APSB18-21) (macOS)
Nessus File: 🔍
Nessus Risk: 🔍
Nessus Family: 🔍
Nessus Context: 🔍

Threat Intelligenceinfo

Interest: 🔍
Active Actors: 🔍
Active APT Groups: 🔍

Countermeasuresinfo

Recommended: Upgrade
Status: 🔍

Reaction Time: 🔍
0-Day Time: 🔍
Exposure Time: 🔍

Upgrade: Acrobat Reader 2015.006.30434/2017.011.30096/2018.011.20055

Timelineinfo

06/25/2018 🔍
07/10/2018 +15 days 🔍
07/10/2018 +0 days 🔍
07/10/2018 +0 days 🔍
07/10/2018 +0 days 🔍
07/10/2018 +0 days 🔍
07/11/2018 +1 days 🔍
07/12/2018 +1 days 🔍
07/20/2018 +7 days 🔍
04/06/2023 +1721 days 🔍

Sourcesinfo

Vendor: adobe.com

Advisory: APSB18-21
Researcher: Aleksandar Nikolic
Organization: Zero Day Initiative
Status: Confirmed
Confirmation: 🔍

CVE: CVE-2018-12787 (🔍)
OVAL: 🔍

SecurityTracker: 1041250
SecurityFocus: 104701 - Adobe Acrobat and Reader APSB18-21 Multiple Arbitrary Code Execution Vulnerabilities

Misc.: 🔍
See also: 🔍

Entryinfo

Created: 07/11/2018 04:25 PM
Updated: 04/06/2023 02:56 PM
Changes: 07/11/2018 04:25 PM (78), 03/02/2020 04:55 PM (7), 04/06/2023 02:56 PM (4)
Complete: 🔍

Discussion

No comments yet. Languages: en.

Please log in to comment.

Are you interested in using VulDB?

Download the whitepaper to learn more about our service!