PHP up to 5.6.36/7.0.30/7.1.19/7.2.7 JPEG File ext/exif/exif.c exif_process_IFD_in_MAKERNOTE out-of-bounds read

EntryeditHistoryDiffjsonxmlCTI
CVSS Meta Temp Score
CVSS is a standardized scoring system to determine possibilities of attacks. The Temp Score considers temporal factors like disclosure, exploit and countermeasures. The unique Meta Score calculates the average score of different sources to provide a normalized scoring system.
Current Exploit Price (≈)
Our analysts are monitoring exploit markets and are in contact with vulnerability brokers. The range indicates the observed or calculated exploit price to be seen on exploit markets. A good indicator to understand the monetary effort required for and the popularity of an attack.
CTI Interest Score
Our Cyber Threat Intelligence team is monitoring different web sites, mailing lists, exploit markets and social media networks. The CTI Interest Score identifies the interest of attackers and the security community for this specific vulnerability in real-time. A high score indicates an elevated risk to be targeted for this vulnerability.
6.2$0-$5k0.00

A vulnerability was found in PHP up to 5.6.36/7.0.30/7.1.19/7.2.7 (Programming Language Software) and classified as critical. Affected by this issue is the function exif_process_IFD_in_MAKERNOTE of the file ext/exif/exif.c of the component JPEG File Handler. The manipulation with an unknown input leads to a information disclosure vulnerability. Using CWE to declare the problem leads to CWE-125. Impacted is confidentiality, integrity, and availability.

The bug was discovered 07/19/2018. The weakness was presented 08/02/2018 (Website). The advisory is available at php.net. This vulnerability is handled as CVE-2018-14851 since 08/02/2018. The attack may be launched remotely. No form of authentication is required for exploitation. Technical details are known, but there is no available exploit. The structure of the vulnerability defines a possible price range of USD $0-$5k at the moment (estimation calculated on 03/12/2020).

The vulnerability was handled as a non-public zero-day exploit for at least 14 days. During that time the estimated underground price was around $5k-$25k. The vulnerability scanner Nessus provides a plugin with the ID 112093 (Amazon Linux AMI : php56 / php70,php71 (ALAS-2018-1066)), which helps to determine the existence of the flaw in a target environment. It is assigned to the family Amazon Linux Local Security Checks and running in the context local. The commercial vulnerability scanner Qualys is able to test this issue with plugin 171447 (SUSE Enterprise Linux Security Update for php7 (SUSE-SU-2018:2333-1)).

Upgrading to version 5.6.37, 7.0.31, 7.1.20 or 7.2.8 eliminates this vulnerability. A possible mitigation has been published 4 weeks after the disclosure of the vulnerability.

The vulnerability is also documented in the databases at SecurityFocus (BID 104871) and Tenable (112093). See 67740, 90573, 90611 and 90612 for similar entries.

Productinfoedit

Type

Name

CPE 2.3infoedit

CPE 2.2infoedit

CVSSv3infoedit

VulDB Meta Base Score: 6.4
VulDB Meta Temp Score: 6.2

VulDB Base Score: 7.3
VulDB Temp Score: 7.0
VulDB Vector: 🔍
VulDB Reliability: 🔍

NVD Base Score: 5.5
NVD Vector: 🔍

CVSSv2infoedit

AVACAuCIA
🔍🔍🔍🔍🔍🔍
🔍🔍🔍🔍🔍🔍
🔍🔍🔍🔍🔍🔍
VectorComplexityAuthenticationConfidentialityIntegrityAvailability
unlockunlockunlockunlockunlockunlock
unlockunlockunlockunlockunlockunlock
unlockunlockunlockunlockunlockunlock

VulDB Base Score: 🔍
VulDB Temp Score: 🔍
VulDB Reliability: 🔍

NVD Base Score: 🔍

Exploitinginfoedit

Class: Information disclosure
CWE: CWE-125
ATT&CK: Unknown

Local: No
Remote: Yes

Availability: 🔍
Status: Not defined

Price Prediction: 🔍
Current Price Estimation: 🔍

0-Dayunlockunlockunlockunlock
Todayunlockunlockunlockunlock

Nessus ID: 112093
Nessus Name: Amazon Linux AMI : php56 / php70,php71 (ALAS-2018-1066)
Nessus File: 🔍
Nessus Risk: 🔍
Nessus Family: 🔍
Nessus Context: 🔍

Qualys ID: 🔍
Qualys Name: 🔍

Threat Intelligenceinfoedit

Threat: 🔍
Adversaries: 🔍
Geopolitics: 🔍
Economy: 🔍
Predictions: 🔍
Remediation: 🔍

Countermeasuresinfoedit

Recommended: Upgrade
Status: 🔍

Reaction Time: 🔍
0-Day Time: 🔍
Exposure Time: 🔍

Upgrade: PHP 5.6.37/7.0.31/7.1.20/7.2.8

Timelineinfoedit

07/19/2018 🔍
07/19/2018 +0 days 🔍
08/02/2018 +13 days 🔍
08/02/2018 +0 days 🔍
08/02/2018 +0 days 🔍
08/03/2018 +1 days 🔍
08/23/2018 +20 days 🔍
08/24/2018 +1 days 🔍
03/12/2020 +566 days 🔍

Sourcesinfoedit

Product: https://www.php.org/

Advisory: php.net
Status: Confirmed
Confirmation: 🔍

CVE: CVE-2018-14851 (🔍)
OVAL: 🔍

SecurityFocus: 104871 - PHP Multiple Heap Buffer Overflow Vulnerabilities

See also: 🔍

Entryinfoedit

Created: 08/03/2018 07:21 AM
Updated: 03/12/2020 09:16 PM
Changes: (5) vulnerability_discoverydate advisory_confirm_url countermeasure_date source_securityfocus_date source_securityfocus_class
Complete: 🔍

Comments

No comments yet. Please log in to comment.

Are you interested in using VulDB?

Download the whitepaper to learn more about our service!