Fabrice Bellard QEMU qcow2_open null pointer dereference

CVSS Meta Temp Score
CVSS is a standardized scoring system to determine possibilities of attacks. The Temp Score considers temporal factors like disclosure, exploit and countermeasures. The unique Meta Score calculates the average score of different sources to provide a normalized scoring system.
Current Exploit Price (≈)
Our analysts are monitoring exploit markets and are in contact with vulnerability brokers. The range indicates the observed or calculated exploit price to be seen on exploit markets. A good indicator to understand the monetary effort required for and the popularity of an attack.
CTI Interest Score
Our Cyber Threat Intelligence team is monitoring different web sites, mailing lists, exploit markets and social media networks. The CTI Interest Score identifies the interest of attackers and the security community for this specific vulnerability in real-time. A high score indicates an elevated risk to be targeted for this vulnerability.
4.1$0-$5k0.00

A vulnerability classified as problematic was found in Fabrice Bellard QEMU (Virtualization Software) (the affected version unknown). This vulnerability affects the function qcow2_open. The manipulation with an unknown input leads to a null pointer dereference vulnerability. The CWE definition for the vulnerability is CWE-476. A NULL pointer dereference occurs when the application dereferences a pointer that it expects to be valid, but is NULL, typically causing a crash or exit. As an impact it is known to affect availability.

The weakness was released 03/26/2014 by Kevin Wolf with Red Hat as [Qemu-devel] [PATCH for-2.0 00/47] block: image format input validation as confirmed posting (Mailing List). The advisory is shared for download at lists.gnu.org. This vulnerability was named CVE-2014-0146 since 12/03/2013. The exploitation appears to be easy. The attack needs to be approached locally. No form of authentication is required for a successful exploitation. There are known technical details, but no exploit is available.

The vulnerability scanner Nessus provides a plugin with the ID 73656 (CentOS 6 : qemu-kvm (CESA-2014:0420)), which helps to determine the existence of the flaw in a target environment. It is assigned to the family CentOS Local Security Checks. The commercial vulnerability scanner Qualys is able to test this issue with plugin 166916 (SUSE Enterprise Linux Security Update for kvm (SUSE-SU-2014:0623-1)).

Applying a patch is able to eliminate this problem. The bugfix is ready for download at lists.gnu.org. A possible mitigation has been published immediately after the disclosure of the vulnerability.

The vulnerability is also documented in the databases at X-Force (92142) and Tenable (73656).

Productinfo

Type

Vendor

Name

License

CPE 2.3info

CPE 2.2info

CVSSv4info

VulDB CVSS-B Score: 🔍
VulDB CVSS-BT Score: 🔍
VulDB Vector: 🔍
VulDB Reliability: 🔍

CVSSv3info

VulDB Meta Base Score: 4.7
VulDB Meta Temp Score: 4.5

VulDB Base Score: 4.0
VulDB Temp Score: 3.5
VulDB Vector: 🔍
VulDB Reliability: 🔍

NVD Base Score: 5.5
NVD Vector: 🔍

CVSSv2info

AVACAuCIA
💳💳💳💳💳💳
💳💳💳💳💳💳
💳💳💳💳💳💳
VectorComplexityAuthenticationConfidentialityIntegrityAvailability
unlockunlockunlockunlockunlockunlock
unlockunlockunlockunlockunlockunlock
unlockunlockunlockunlockunlockunlock

VulDB Base Score: 🔍
VulDB Temp Score: 🔍
VulDB Reliability: 🔍

NVD Base Score: 🔍

Exploitinginfo

Class: Null pointer dereference
CWE: CWE-476 / CWE-404
CAPEC: 🔍
ATT&CK: 🔍

Local: Yes
Remote: No

Availability: 🔍
Status: Unproven

EPSS Score: 🔍
EPSS Percentile: 🔍

Price Prediction: 🔍
Current Price Estimation: 🔍

0-Dayunlockunlockunlockunlock
Todayunlockunlockunlockunlock

Nessus ID: 73656
Nessus Name: CentOS 6 : qemu-kvm (CESA-2014:0420)
Nessus File: 🔍
Nessus Risk: 🔍
Nessus Family: 🔍

OpenVAS ID: 881925
OpenVAS Name: CentOS Update for qemu-guest-agent CESA-2014:0420 centos6
OpenVAS File: 🔍
OpenVAS Family: 🔍

Qualys ID: 🔍
Qualys Name: 🔍

Threat Intelligenceinfo

Interest: 🔍
Active Actors: 🔍
Active APT Groups: 🔍

Countermeasuresinfo

Recommended: Patch
Status: 🔍

Reaction Time: 🔍
0-Day Time: 🔍
Exposure Time: 🔍

Patch: lists.gnu.org

Timelineinfo

12/03/2013 🔍
03/26/2014 +113 days 🔍
03/26/2014 +0 days 🔍
03/26/2014 +0 days 🔍
03/26/2014 +0 days 🔍
04/01/2014 +6 days 🔍
04/15/2014 +14 days 🔍
06/05/2014 +51 days 🔍
08/10/2017 +1162 days 🔍
06/16/2021 +1406 days 🔍

Sourcesinfo

Vendor: bellard.org

Advisory: [Qemu-devel] [PATCH for-2.0 00/47] block: image format input validation
Researcher: Kevin Wolf
Organization: Red Hat
Status: Confirmed
Confirmation: 🔍

CVE: CVE-2014-0146 (🔍)
OVAL: 🔍

X-Force: 92142 - QEMU qcow2_open() denial of service, Low Risk
Vulnerability Center: 44771 - QEMU <2.0 Local DoS due to Null Dereference in qcow2_open(), Low
SecurityFocus: 66472 - QEMU CVE-2014-0146 NULL Pointer Dereference Local Denial of Service Vulnerability
Secunia: 57878 - Qemu virtio-net "virtio_net_handle_mac()" Integer Overflow Vulnerability, Not Critical

Entryinfo

Created: 04/01/2014 02:34 PM
Updated: 06/16/2021 12:26 PM
Changes: 04/01/2014 02:34 PM (81), 05/29/2017 11:56 AM (1), 06/16/2021 12:11 PM (4), 06/16/2021 12:18 PM (11), 06/16/2021 12:26 PM (1)
Complete: 🔍
Cache ID: 44:993:40

Discussion

No comments yet. Languages: en.

Please log in to comment.

Might our Artificial Intelligence support you?

Check our Alexa App!