Adobe Acrobat Reader up to 2019.008.20081 memory corruption

CVSS Meta Temp Score
CVSS is a standardized scoring system to determine possibilities of attacks. The Temp Score considers temporal factors like disclosure, exploit and countermeasures. The unique Meta Score calculates the average score of different sources to provide a normalized scoring system.
Current Exploit Price (≈)
Our analysts are monitoring exploit markets and are in contact with vulnerability brokers. The range indicates the observed or calculated exploit price to be seen on exploit markets. A good indicator to understand the monetary effort required for and the popularity of an attack.
CTI Interest Score
Our Cyber Threat Intelligence team is monitoring different web sites, mailing lists, exploit markets and social media networks. The CTI Interest Score identifies the interest of attackers and the security community for this specific vulnerability in real-time. A high score indicates an elevated risk to be targeted for this vulnerability.
6.9$0-$5k0.00

A vulnerability classified as critical has been found in Adobe Acrobat Reader up to 2019.008.20081 (Document Reader Software). Affected is some unknown functionality. The manipulation with an unknown input leads to a memory corruption vulnerability. CWE is classifying the issue as CWE-119. The product performs operations on a memory buffer, but it can read from or write to a memory location that is outside of the intended boundary of the buffer. This is going to have an impact on confidentiality, integrity, and availability.

The bug was discovered 12/11/2018. The weakness was disclosed 12/11/2018 as APSB18-41 as confirmed security bulletin (Website). The advisory is shared for download at helpx.adobe.com. This vulnerability is traded as CVE-2018-15987 since 08/28/2018. It is possible to launch the attack remotely. The exploitation doesn't require any form of authentication. Successful exploitation requires user interaction by the victim. There are neither technical details nor an exploit publicly available. The current price for an exploit might be approx. USD $0-$5k (estimation calculated on 07/01/2023).

The vulnerability scanner Nessus provides a plugin with the ID 119674 (Adobe Reader <= 15.006.30456 / 17.011.30105 / 19.008.20080 Multiple Vulnerabilities (APSB18-41) (macOS)), which helps to determine the existence of the flaw in a target environment. It is assigned to the family MacOS X Local Security Checks and running in the context l. The commercial vulnerability scanner Qualys is able to test this issue with plugin 371372 (Adobe Reader and Acrobat Multiple Security Vulnerabilities (APSB18-41)).

Upgrading to version 2015.006.30461, 2017.011.30110 or 2019.010.20064 eliminates this vulnerability. A possible mitigation has been published immediately after the disclosure of the vulnerability.

The vulnerability is also documented in the databases at Tenable (119674) and SecurityFocus (BID 106163†).

Productinfo

Type

Vendor

Name

Version

License

CPE 2.3info

CPE 2.2info

CVSSv4info

VulDB CVSS-B Score: 🔍
VulDB CVSS-BT Score: 🔍
VulDB Vector: 🔍
VulDB Reliability: 🔍

CVSSv3info

VulDB Meta Base Score: 7.0
VulDB Meta Temp Score: 6.9

VulDB Base Score: 6.3
VulDB Temp Score: 6.0
VulDB Vector: 🔍
VulDB Reliability: 🔍

NVD Base Score: 7.8
NVD Vector: 🔍

CVSSv2info

AVACAuCIA
💳💳💳💳💳💳
💳💳💳💳💳💳
💳💳💳💳💳💳
VectorComplexityAuthenticationConfidentialityIntegrityAvailability
unlockunlockunlockunlockunlockunlock
unlockunlockunlockunlockunlockunlock
unlockunlockunlockunlockunlockunlock

VulDB Base Score: 🔍
VulDB Temp Score: 🔍
VulDB Reliability: 🔍

NVD Base Score: 🔍

Exploitinginfo

Class: Memory corruption
CWE: CWE-119
CAPEC: 🔍
ATT&CK: 🔍

Local: No
Remote: Yes

Availability: 🔍
Status: Not defined

EPSS Score: 🔍
EPSS Percentile: 🔍

Price Prediction: 🔍
Current Price Estimation: 🔍

0-Dayunlockunlockunlockunlock
Todayunlockunlockunlockunlock

Nessus ID: 119674
Nessus Name: Adobe Reader <= 15.006.30456 / 17.011.30105 / 19.008.20080 Multiple Vulnerabilities (APSB18-41) (macOS)
Nessus File: 🔍
Nessus Risk: 🔍
Nessus Family: 🔍
Nessus Context: 🔍

Qualys ID: 🔍
Qualys Name: 🔍

Threat Intelligenceinfo

Interest: 🔍
Active Actors: 🔍
Active APT Groups: 🔍

Countermeasuresinfo

Recommended: Upgrade
Status: 🔍

Reaction Time: 🔍
0-Day Time: 🔍
Exposure Time: 🔍

Upgrade: Acrobat Reader 2015.006.30461/2017.011.30110/2019.010.20064

Timelineinfo

08/28/2018 🔍
12/11/2018 +105 days 🔍
12/11/2018 +0 days 🔍
12/11/2018 +0 days 🔍
12/11/2018 +0 days 🔍
12/14/2018 +3 days 🔍
01/18/2019 +35 days 🔍
01/19/2019 +1 days 🔍
07/01/2023 +1624 days 🔍

Sourcesinfo

Vendor: adobe.com

Advisory: APSB18-41
Status: Confirmed
Confirmation: 🔍

CVE: CVE-2018-15987 (🔍)
SecurityFocus: 106163 - Adobe Acrobat and Reader APSB18-41 Multiple Stack Buffer Overflow Vulnerabilities

Entryinfo

Created: 01/19/2019 11:11 AM
Updated: 07/01/2023 02:15 PM
Changes: 01/19/2019 11:11 AM (75), 05/02/2020 11:37 AM (5), 07/01/2023 02:15 PM (4)
Complete: 🔍
Cache ID: 3:232:40

Discussion

No comments yet. Languages: en.

Please log in to comment.

Are you interested in using VulDB?

Download the whitepaper to learn more about our service!