GNU Libextractor up to 1.9 plugins/dvi_extractor.c EXTRACTOR_dvi_extract_method out-of-bounds read

EntryeditHistoryDiffjsonxmlCTI
CVSS Meta Temp Score
CVSS is a standardized scoring system to determine possibilities of attacks. The Temp Score considers temporal factors like disclosure, exploit and countermeasures. The unique Meta Score calculates the average score of different sources to provide a normalized scoring system.
Current Exploit Price (≈)
Our analysts are monitoring exploit markets and are in contact with vulnerability brokers. The range indicates the observed or calculated exploit price to be seen on exploit markets. A good indicator to understand the monetary effort required for and the popularity of an attack.
CTI Interest Score
Our Cyber Threat Intelligence team is monitoring different web sites, mailing lists, exploit markets and social media networks. The CTI Interest Score identifies the interest of attackers and the security community for this specific vulnerability in real-time. A high score indicates an elevated risk to be targeted for this vulnerability.
6.4$0-$5k0.00

A vulnerability has been found in GNU Libextractor up to 1.9 and classified as critical. This vulnerability affects the function EXTRACTOR_dvi_extract_method of the file plugins/dvi_extractor.c. The manipulation with an unknown input leads to a information disclosure vulnerability. The CWE definition for the vulnerability is CWE-125. As an impact it is known to affect confidentiality, integrity, and availability. CVE summarizes:

GNU Libextractor through 1.9 has a heap-based buffer over-read in the function EXTRACTOR_dvi_extract_method in plugins/dvi_extractor.c.

The weakness was released 08/23/2019 (Website). The advisory is available at lists.fedoraproject.org. This vulnerability was named CVE-2019-15531 since 08/23/2019. The attack can be initiated remotely. No form of authentication is required for a successful exploitation. Successful exploitation requires user interaction by the victim. Technical details are known, but there is no available exploit.

There is no information about possible countermeasures known. It may be suggested to replace the affected object with an alternative product.

Productinfoedit

Vendor

Name

CPE 2.3infoedit

CPE 2.2infoedit

CVSSv3infoedit

VulDB Meta Base Score: 6.4
VulDB Meta Temp Score: 6.4

VulDB Base Score: 6.3
VulDB Temp Score: 6.3
VulDB Vector: 🔍
VulDB Reliability: 🔍

NVD Base Score: 6.5
NVD Vector: 🔍

CVSSv2infoedit

AVACAuCIA
🔍🔍🔍🔍🔍🔍
🔍🔍🔍🔍🔍🔍
🔍🔍🔍🔍🔍🔍
VectorComplexityAuthenticationConfidentialityIntegrityAvailability
unlockunlockunlockunlockunlockunlock
unlockunlockunlockunlockunlockunlock
unlockunlockunlockunlockunlockunlock

VulDB Base Score: 🔍
VulDB Temp Score: 🔍
VulDB Reliability: 🔍

NVD Base Score: 🔍

Exploitinginfoedit

Class: Information disclosure
CWE: CWE-125
ATT&CK: Unknown

Local: No
Remote: Yes

Availability: 🔍
Status: Not defined

Price Prediction: 🔍
Current Price Estimation: 🔍

0-Dayunlockunlockunlockunlock
Todayunlockunlockunlockunlock

Threat Intelligenceinfoedit

Threat: 🔍
Adversaries: 🔍
Geopolitics: 🔍
Economy: 🔍
Predictions: 🔍
Remediation: 🔍

Countermeasuresinfoedit

Recommended: no mitigation known
Status: 🔍

0-Day Time: 🔍

Timelineinfoedit

08/23/2019 🔍
08/23/2019 +0 days 🔍
08/24/2019 +1 days 🔍
08/04/2020 +346 days 🔍

Sourcesinfoedit

Vendor: https://www.gnu.org/

Advisory: lists.fedoraproject.org
Status: Not defined

CVE: CVE-2019-15531 (🔍)

Entryinfoedit

Created: 08/24/2019 11:06 AM
Updated: 08/04/2020 04:55 PM
Changes: (1) advisory_url
Complete: 🔍

Comments

No comments yet. Please log in to comment.

Interested in the pricing of exploits?

See the underground prices here!