MongoDB up to 3.4.21/3.6.13/4.0.10 SysV Init Script Kill input validation

entryeditHistoryDiffjsonxmlCTI
CVSS Meta Temp Score
CVSS is a standardized scoring system to determine possibilities of attacks. The Temp Score considers temporal factors like disclosure, exploit and countermeasures. The unique Meta Score calculates the average score of different sources to provide a normalized scoring system.
Current Exploit Price (≈)
Our analysts are monitoring exploit markets and are in contact with vulnerability brokers. The range indicates the observed or calculated exploit price to be seen on exploit markets. A good indicator to understand the monetary effort required for and the popularity of an attack.
CTI Interest Score
Our Cyber Threat Intelligence team is monitoring different web sites, mailing lists, exploit markets and social media networks. The CTI Interest Score identifies the interest of attackers and the security community for this specific vulnerability in real-time. A high score indicates an elevated risk to be targeted for this vulnerability.
3.5$0-$5k0.00

A vulnerability has been found in MongoDB up to 3.4.21/3.6.13/4.0.10 (Database Software) and classified as problematic. Affected by this vulnerability is an unknown code of the component SysV Init Script. The manipulation with an unknown input leads to a privilege escalation vulnerability (Kill). The CWE definition for the vulnerability is CWE-20. As an impact it is known to affect availability. The summary by CVE is:

Incorrect scoping of kill operations in MongoDB Server's packaged SysV init scripts allow users with write access to the PID file to insert arbitrary PIDs to be killed when the root user stops the MongoDB process via SysV init. This issue affects: MongoDB Inc. MongoDB Server v4.0 versions prior to 4.0.11; v3.6 versions prior to 3.6.14; v3.4 versions prior to 3.4.22.

The weakness was disclosed 08/30/2019 (Website). It is possible to read the advisory at jira.mongodb.org. This vulnerability is known as CVE-2019-2389 since 12/10/2018. Attacking locally is a requirement. The exploitation doesn't need any form of authentication. It demands that the victim is doing some kind of user interaction. The technical details are unknown and an exploit is not publicly available.

Upgrading to version 3.4.22, 3.6.14 or 4.0.11 eliminates this vulnerability.

The entry 141188 is pretty similar.

Productinfoedit

Type

Name

CPE 2.3infoedit

CPE 2.2infoedit

CVSSv3infoedit

VulDB Meta Base Score: 3.7
VulDB Meta Temp Score: 3.5

VulDB Base Score: 3.2
VulDB Temp Score: 3.1
VulDB Vector: 🔍
VulDB Reliability: 🔍

NVD Base Score: 4.2
NVD Vector: 🔍

CVSSv2infoedit

AVACAuCIA
🔍🔍🔍🔍🔍🔍
🔍🔍🔍🔍🔍🔍
🔍🔍🔍🔍🔍🔍
VectorComplexityAuthenticationConfidentialityIntegrityAvailability
unlockunlockunlockunlockunlockunlock
unlockunlockunlockunlockunlockunlock
unlockunlockunlockunlockunlockunlock

VulDB Base Score: 🔍
VulDB Temp Score: 🔍
VulDB Reliability: 🔍

NVD Base Score: 🔍

Exploitinginfoedit

Name: Kill
Class: Privilege escalation / Kill
CWE: CWE-20
ATT&CK: Unknown

Local: Yes
Remote: No

Availability: 🔍
Status: Not defined

Price Prediction: 🔍
Current Price Estimation: 🔍

0-Dayunlockunlockunlockunlock
Todayunlockunlockunlockunlock

Threat Intelligenceinfoedit

Threat: 🔍
Adversaries: 🔍
Geopolitics: 🔍
Economy: 🔍
Predictions: 🔍
Remediation: 🔍

Countermeasuresinfoedit

Recommended: Upgrade
Status: 🔍

0-Day Time: 🔍

Upgrade: MongoDB 3.4.22/3.6.14/4.0.11

Timelineinfoedit

12/10/2018 🔍
08/30/2019 +263 days 🔍
08/31/2019 +1 days 🔍
08/10/2020 +345 days 🔍

Sourcesinfoedit

Advisory: jira.mongodb.org
Status: Not defined
Confirmation: 🔍

CVE: CVE-2019-2389 (🔍)
See also: 🔍

Entryinfoedit

Created: 08/31/2019 07:52 AM
Updated: 08/10/2020 06:31 PM
Changes: (1) advisory_confirm_url
Complete: 🔍

Comments

No comments yet. Please log in to comment.

Might our Artificial Intelligence support you?

Check our Alexa App!