wp-invoice Plugin up to 4.1.0 on WordPress Access Control wpi_paypal payer exposure of resource

CVSS Meta Temp Score
CVSS is a standardized scoring system to determine possibilities of attacks. The Temp Score considers temporal factors like disclosure, exploit and countermeasures. The unique Meta Score calculates the average score of different sources to provide a normalized scoring system.
Current Exploit Price (≈)
Our analysts are monitoring exploit markets and are in contact with vulnerability brokers. The range indicates the observed or calculated exploit price to be seen on exploit markets. A good indicator to understand the monetary effort required for and the popularity of an attack.
CTI Interest Score
Our Cyber Threat Intelligence team is monitoring different web sites, mailing lists, exploit markets and social media networks. The CTI Interest Score identifies the interest of attackers and the security community for this specific vulnerability in real-time. A high score indicates an elevated risk to be targeted for this vulnerability.
6.2$0-$5k0.00

A vulnerability was found in wp-invoice Plugin up to 4.1.0 on WordPress (WordPress Plugin) and classified as critical. Affected by this issue is an unknown code of the component Access Control. The manipulation of the argument wpi_paypal payer with an unknown input leads to a exposure of resource vulnerability. Using CWE to declare the problem leads to CWE-668. The product exposes a resource to the wrong control sphere, providing unintended actors with inappropriate access to the resource. Impacted is confidentiality, integrity, and availability. CVE summarizes:

The wp-invoice plugin before 4.1.1 for WordPress has incorrect access control over wpi_paypal payer metadata updates.

The weakness was shared 09/20/2019. This vulnerability is handled as CVE-2016-11008 since 09/20/2019. The exploitation is known to be easy. The attack may be launched remotely. No form of authentication is required for exploitation. Technical details are known, but there is no available exploit.

Upgrading to version 4.1.1 eliminates this vulnerability.

The entries 142037, 142036, 142035 and 142033 are related to this item.

Productinfo

Type

Name

Version

CPE 2.3info

CPE 2.2info

CVSSv4info

VulDB CVSS-B Score: 🔍
VulDB CVSS-BT Score: 🔍
VulDB Vector: 🔍
VulDB Reliability: 🔍

CVSSv3info

VulDB Meta Base Score: 6.3
VulDB Meta Temp Score: 6.2

VulDB Base Score: 7.3
VulDB Temp Score: 7.0
VulDB Vector: 🔍
VulDB Reliability: 🔍

NVD Base Score: 5.3
NVD Vector: 🔍

CVSSv2info

AVACAuCIA
💳💳💳💳💳💳
💳💳💳💳💳💳
💳💳💳💳💳💳
VectorComplexityAuthenticationConfidentialityIntegrityAvailability
unlockunlockunlockunlockunlockunlock
unlockunlockunlockunlockunlockunlock
unlockunlockunlockunlockunlockunlock

VulDB Base Score: 🔍
VulDB Temp Score: 🔍
VulDB Reliability: 🔍

NVD Base Score: 🔍

Exploitinginfo

Class: Exposure of resource
CWE: CWE-668 / CWE-200 / CWE-284
ATT&CK: Unknown

Local: No
Remote: Yes

Availability: 🔍
Status: Not defined

EPSS Score: 🔍
EPSS Percentile: 🔍

Price Prediction: 🔍
Current Price Estimation: 🔍

0-Dayunlockunlockunlockunlock
Todayunlockunlockunlockunlock

Threat Intelligenceinfo

Interest: 🔍
Active Actors: 🔍
Active APT Groups: 🔍

Countermeasuresinfo

Recommended: Upgrade
Status: 🔍

0-Day Time: 🔍

Upgrade: wp-invoice Plugin 4.1.1

Timelineinfo

09/20/2019 🔍
09/20/2019 +0 days 🔍
09/21/2019 +1 days 🔍
12/26/2023 +1557 days 🔍

Sourcesinfo

Advisory: pritect.net
Status: Not defined

CVE: CVE-2016-11008 (🔍)
See also: 🔍

Entryinfo

Created: 09/21/2019 07:40 AM
Updated: 12/26/2023 04:25 PM
Changes: 09/21/2019 07:40 AM (39), 09/01/2020 11:05 AM (18), 12/26/2023 04:25 PM (4)
Complete: 🔍

Discussion

No comments yet. Languages: en.

Please log in to comment.

Do you know our Splunk app?

Download it now for free!