AnalogX SimpleServer:WWW 1.0.1 HTTP GET memory corruption

entryeditHistoryDiffjsonxmlCTI
CVSS Meta Temp Score
CVSS is a standardized scoring system to determine possibilities of attacks. The Temp Score considers temporal factors like disclosure, exploit and countermeasures. The unique Meta Score calculates the average score of different sources to provide a normalized scoring system.
Current Exploit Price (≈)
Our analysts are monitoring exploit markets and are in contact with vulnerability brokers. The range indicates the observed or calculated exploit price to be seen on exploit markets. A good indicator to understand the monetary effort required for and the popularity of an attack.
CTI Interest Score
Our Cyber Threat Intelligence team is monitoring different web sites, mailing lists, exploit markets and social media networks. The CTI Interest Score identifies the interest of attackers and the security community for this specific vulnerability in real-time. A high score indicates an elevated risk to be targeted for this vulnerability.
7.0$0-$5k0.00

A vulnerability was found in AnalogX SimpleServer:WWW 1.0.1. It has been declared as critical. This vulnerability affects an unknown code of the component HTTP GET Handler. The manipulation with an unknown input leads to a memory corruption vulnerability. The CWE definition for the vulnerability is CWE-119. As an impact it is known to affect confidentiality, integrity, and availability. CVE summarizes:

Buffer overflow in AnalogX SimpleServer:WWW HTTP server allows remote attackers to execute commands via a long GET request.

The weakness was presented 12/31/1999 by Ussr Labs as not defined advisory (Website). The advisory is shared for download at analogx.com. This vulnerability was named CVE-2000-0011. The exploitation appears to be easy. The attack can be initiated remotely. No form of authentication is required for a successful exploitation. There are neither technical details nor an exploit publicly available.

After immediately, there has been an exploit disclosed.

Upgrading eliminates this vulnerability.

The vulnerability is also documented in the databases at SecurityFocus (BID 906), X-Force (4297) and Vulnerability Center (SBV-3298).

Productinfoedit

Vendor

Name

CPE 2.3infoedit

CPE 2.2infoedit

CVSSv3infoedit

VulDB Meta Base Score: 7.3
VulDB Meta Temp Score: 7.0

VulDB Base Score: 7.3
VulDB Temp Score: 7.0
VulDB Vector: 🔍
VulDB Reliability: 🔍

CVSSv2infoedit

AVACAuCIA
🔍🔍🔍🔍🔍🔍
🔍🔍🔍🔍🔍🔍
🔍🔍🔍🔍🔍🔍
VectorComplexityAuthenticationConfidentialityIntegrityAvailability
unlockunlockunlockunlockunlockunlock
unlockunlockunlockunlockunlockunlock
unlockunlockunlockunlockunlockunlock

VulDB Base Score: 🔍
VulDB Temp Score: 🔍
VulDB Reliability: 🔍

NVD Base Score: 🔍

Exploitinginfoedit

Class: Memory corruption
CWE: CWE-119
ATT&CK: Unknown

Local: No
Remote: Yes

Availability: 🔍
Status: Not defined

Price Prediction: 🔍
Current Price Estimation: 🔍

0-Dayunlockunlockunlockunlock
Todayunlockunlockunlockunlock

Threat Intelligenceinfoedit

Threat: 🔍
Adversaries: 🔍
Geopolitics: 🔍
Economy: 🔍
Predictions: 🔍
Remediation: 🔍

Countermeasuresinfoedit

Recommended: Upgrade
Status: 🔍

0-Day Time: 🔍
Exploit Delay Time: 🔍

Timelineinfoedit

12/31/1999 🔍
12/31/1999 +0 days 🔍
12/31/1999 +0 days 🔍
12/31/1999 +0 days 🔍
12/31/1999 +0 days 🔍
02/21/2003 +1148 days 🔍
12/28/2003 +309 days 🔍
06/23/2014 +3830 days 🔍
08/11/2017 +1145 days 🔍
05/18/2019 +645 days 🔍

Sourcesinfoedit

Advisory: analogx.com
Researcher: Ussr Labs
Status: Not defined

CVE: CVE-2000-0011 (🔍)
SecurityFocus: 906 - AnalogX SimpleServer:WWW GET Buffer Overflow Vulnerability
X-Force: 4297
Vulnerability Center: 3298 - Buffer Overflow in AnalogX SimpleServer, High
OSVDB: 1184 - AnalogX SimpleServer:WWW GET Overflow

Entryinfoedit

Created: 06/23/2014 01:19 PM
Updated: 05/18/2019 09:17 PM
Changes: (1) advisory_person_name
Complete: 🔍

Comments

No comments yet. Please log in to comment.

Are you interested in using VulDB?

Download the whitepaper to learn more about our service!