Ansible Engine/Ansible Tower ldap_attr/ldap_entry bind_pw Credentials information disclosure

entryeditHistoryDiffjsonxmlCTI
CVSS Meta Temp Score
CVSS is a standardized scoring system to determine possibilities of attacks. The Temp Score considers temporal factors like disclosure, exploit and countermeasures. The unique Meta Score calculates the average score of different sources to provide a normalized scoring system.
Current Exploit Price (≈)
Our analysts are monitoring exploit markets and are in contact with vulnerability brokers. The range indicates the observed or calculated exploit price to be seen on exploit markets. A good indicator to understand the monetary effort required for and the popularity of an attack.
CTI Interest Score
Our Cyber Threat Intelligence team is monitoring different web sites, mailing lists, exploit markets and social media networks. The CTI Interest Score identifies the interest of attackers and the security community for this specific vulnerability in real-time. A high score indicates an elevated risk to be targeted for this vulnerability.
3.7$0-$5k0.00

A vulnerability was found in Ansible Engine and Ansible Tower (unknown version). It has been rated as problematic. This issue affects an unknown code of the component ldap_attr/ldap_entry. The manipulation of the argument bind_pw as part of a Parameter leads to a information disclosure vulnerability (Credentials). Using CWE to declare the problem leads to CWE-200. Impacted is confidentiality. The summary by CVE is:

A flaw was found in the Ansible Engine affecting Ansible Engine versions 2.7.x before 2.7.17 and 2.8.x before 2.8.11 and 2.9.x before 2.9.7 as well as Ansible Tower before and including versions 3.4.5 and 3.5.5 and 3.6.3 when the ldap_attr and ldap_entry community modules are used. The issue discloses the LDAP bind password to stdout or a log file if a playbook task is written using the bind_pw in the parameters field. The highest threat from this vulnerability is data confidentiality.

The weakness was presented 05/12/2020 as not defined bug report (Bugzilla). The advisory is shared at bugzilla.redhat.com. The identification of this vulnerability is CVE-2020-1746 since 11/27/2019. An attack has to be approached locally. A simple authentication is needed for exploitation. It demands that the victim is doing some kind of user interaction. Technical details are known, but no exploit is available.

Upgrading eliminates this vulnerability.

Productinfoedit

Name

CPE 2.3infoedit

CPE 2.2infoedit

CVSSv3infoedit

VulDB Meta Base Score: 3.9
VulDB Meta Temp Score: 3.7

VulDB Base Score: 2.8
VulDB Temp Score: 2.7
VulDB Vector: 🔒
VulDB Reliability: 🔍

NVD Base Score: 5.0
NVD Vector: 🔒

CVSSv2infoedit

AVACAuCIA
🔍🔍🔍🔍🔍🔍
🔍🔍🔍🔍🔍🔍
🔍🔍🔍🔍🔍🔍
VectorComplexityAuthenticationConfidentialityIntegrityAvailability
unlockunlockunlockunlockunlockunlock
unlockunlockunlockunlockunlockunlock
unlockunlockunlockunlockunlockunlock

VulDB Base Score: 🔒
VulDB Temp Score: 🔒
VulDB Reliability: 🔍

Exploitinginfoedit

Name: Credentials
Class: Information disclosure / Credentials
CWE: CWE-200
ATT&CK: Unknown

Local: Yes
Remote: No

Availability: 🔒
Status: Not defined

Price Prediction: 🔍
Current Price Estimation: 🔒

0-Dayunlockunlockunlockunlock
Todayunlockunlockunlockunlock

Threat Intelligenceinfoedit

Threat: 🔍
Adversaries: 🔍
Geopolitics: 🔍
Economy: 🔍
Predictions: 🔍
Remediation: 🔍

Countermeasuresinfoedit

Recommended: Upgrade
Status: 🔍

0-Day Time: 🔒

Timelineinfoedit

11/27/2019 CVE assigned
05/12/2020 +167 days Advisory disclosed
05/13/2020 +1 days VulDB entry created
10/16/2020 +156 days VulDB last update

Sourcesinfoedit

Advisory: bugzilla.redhat.com
Status: Not defined
Confirmation: 🔒

CVE: CVE-2020-1746 (🔒)

Entryinfoedit

Created: 05/13/2020 07:11 AM
Updated: 10/16/2020 05:39 PM
Changes: (1) source_cve_cna
Complete: 🔍

Comments

No comments yet. Please log in to comment.

Interested in the pricing of exploits?

See the underground prices here!