Apple tvOS up to 13.4.7 WebKit Web Inspector command injection

entryeditHistoryDiffjsonxmlCTI
CVSS Meta Temp Score
CVSS is a standardized scoring system to determine possibilities of attacks. The Temp Score considers temporal factors like disclosure, exploit and countermeasures. The unique Meta Score calculates the average score of different sources to provide a normalized scoring system.
Current Exploit Price (≈)
Our analysts are monitoring exploit markets and are in contact with vulnerability brokers. The range indicates the observed or calculated exploit price to be seen on exploit markets. A good indicator to understand the monetary effort required for and the popularity of an attack.
CTI Interest Score
Our Cyber Threat Intelligence team is monitoring different web sites, mailing lists, exploit markets and social media networks. The CTI Interest Score identifies the interest of attackers and the security community for this specific vulnerability in real-time. A high score indicates an elevated risk to be targeted for this vulnerability.
4.6$0-$5k0.00

A vulnerability classified as critical has been found in Apple tvOS up to 13.4.7 (Digital Media Player). This affects some unknown functionality of the component WebKit Web Inspector. The manipulation with an unknown input leads to a privilege escalation vulnerability. CWE is classifying the issue as CWE-77. This is going to have an impact on confidentiality, integrity, and availability. The summary by CVE is:

A command injection issue existed in Web Inspector. This issue was addressed with improved escaping. This issue is fixed in iOS 13.6 and iPadOS 13.6, tvOS 13.4.8, watchOS 6.2.8, Safari 13.1.2, iTunes 12.10.8 for Windows, iCloud for Windows 11.3, iCloud for Windows 7.20. Copying a URL from Web Inspector may lead to command injection.

The weakness was presented 07/15/2020 by Ophir Lojkine as HT211290 as confirmed advisory (Website). It is possible to read the advisory at support.apple.com. This vulnerability is uniquely identified as CVE-2020-9862 since 03/02/2020. Attacking locally is a requirement. A authentication is required for exploitation. It demands that the victim is doing some kind of user interaction. The technical details are unknown and an exploit is not publicly available. The advisory points out:

A command injection issue existed in Web Inspector. This issue was addressed with improved escaping.

Upgrading to version 13.4.8 eliminates this vulnerability. A possible mitigation has been published immediately after the disclosure of the vulnerability.

See 158603, 158623, 158625 and 158626 for similar entries.

Productinfoedit

Type

Vendor

Name

CPE 2.3infoedit

CPE 2.2infoedit

CVSSv3infoedit

VulDB Meta Base Score: 6.3
VulDB Meta Temp Score: 6.0

VulDB Base Score: 4.8
VulDB Temp Score: 4.6
VulDB Vector: 🔒
VulDB Reliability: 🔍

NVD Base Score: 7.8
NVD Vector: 🔒

CVSSv2infoedit

AVACAuCIA
🔍🔍🔍🔍🔍🔍
🔍🔍🔍🔍🔍🔍
🔍🔍🔍🔍🔍🔍
VectorComplexityAuthenticationConfidentialityIntegrityAvailability
unlockunlockunlockunlockunlockunlock
unlockunlockunlockunlockunlockunlock
unlockunlockunlockunlockunlockunlock

VulDB Base Score: 🔒
VulDB Temp Score: 🔒
VulDB Reliability: 🔍

Exploitinginfoedit

Class: Privilege escalation
CWE: CWE-77
ATT&CK: Unknown

Local: Yes
Remote: No

Availability: 🔒
Status: Not defined

Price Prediction: 🔍
Current Price Estimation: 🔒

0-Dayunlockunlockunlockunlock
Todayunlockunlockunlockunlock

Threat Intelligenceinfoedit

Threat: 🔍
Adversaries: 🔍
Geopolitics: 🔍
Economy: 🔍
Predictions: 🔍
Remediation: 🔍

Countermeasuresinfoedit

Recommended: Upgrade
Status: 🔍

Reaction Time: 🔒
0-Day Time: 🔒
Exposure Time: 🔒

Upgrade: tvOS 13.4.8

Timelineinfoedit

03/02/2020 CVE assigned
07/15/2020 +135 days Advisory disclosed
07/15/2020 +0 days Countermeasure disclosed
07/16/2020 +1 days VulDB entry created
11/03/2020 +110 days VulDB last update

Sourcesinfoedit

Vendor: https://www.apple.com/

Advisory: HT211290
Researcher: Ophir Lojkine
Status: Confirmed

CVE: CVE-2020-9862 (🔒)
See also: 🔒

Entryinfoedit

Created: 07/16/2020 08:30 PM
Updated: 11/03/2020 08:05 PM
Changes: (8) vulnerability_cvss3_nvd_av vulnerability_cvss3_nvd_ac vulnerability_cvss3_nvd_pr vulnerability_cvss3_nvd_ui vulnerability_cvss3_nvd_s vulnerability_cvss3_nvd_c vulnerability_cvss3_nvd_i vulnerability_cvss3_nvd_a
Complete: 🔍

Comments

No comments yet. Please log in to comment.

Interested in the pricing of exploits?

See the underground prices here!