PHP up to 7.3.30/7.4.23/8.0.10 on Windows ZipArchive::extractTo path traversal

CVSS Meta Temp Score
CVSS is a standardized scoring system to determine possibilities of attacks. The Temp Score considers temporal factors like disclosure, exploit and countermeasures. The unique Meta Score calculates the average score of different sources to provide a normalized scoring system.
Current Exploit Price (≈)
Our analysts are monitoring exploit markets and are in contact with vulnerability brokers. The range indicates the observed or calculated exploit price to be seen on exploit markets. A good indicator to understand the monetary effort required for and the popularity of an attack.
CTI Interest Score
Our Cyber Threat Intelligence team is monitoring different web sites, mailing lists, exploit markets and social media networks. The CTI Interest Score identifies the interest of attackers and the security community for this specific vulnerability in real-time. A high score indicates an elevated risk to be targeted for this vulnerability.
4.9$0-$5k0.12

A vulnerability was found in PHP up to 7.3.30/7.4.23/8.0.10 on Windows (Programming Language Software). It has been declared as critical. This vulnerability affects the function ZipArchive::extractTo. The manipulation with an unknown input leads to a path traversal vulnerability. The CWE definition for the vulnerability is CWE-23. The software uses external input to construct a pathname that should be within a restricted directory, but it does not properly neutralize sequences such as ".." that can resolve to a location that is outside of that directory. As an impact it is known to affect integrity, and availability.

The weakness was disclosed 10/04/2021 as 81420. The advisory is available at bugs.php.net. This vulnerability was named CVE-2021-21706 since 01/04/2021. Technical details are known, but there is no available exploit. The structure of the vulnerability defines a possible price range of USD $0-$5k at the moment (estimation calculated on 10/04/2021). This vulnerability is assigned to T1006 by the MITRE ATT&CK project.

Upgrading to version 7.3.31, 7.4.24 or 8.0.11 eliminates this vulnerability.

Productinfo

Type

Name

License

  • open-source

CPE 2.3info

CPE 2.2info

CVSSv3info

VulDB Meta Base Score: 5.0
VulDB Meta Temp Score: 4.9

VulDB Base Score: 4.8
VulDB Temp Score: 4.6
VulDB Vector: 🔍
VulDB Reliability: 🔍

CNA Base Score: 5.3
CNA Vector (PHP Group): 🔍

CVSSv2info

AVACAuCIA
🔍🔍🔍🔍🔍🔍
🔍🔍🔍🔍🔍🔍
🔍🔍🔍🔍🔍🔍
VectorComplexityAuthenticationConfidentialityIntegrityAvailability
unlockunlockunlockunlockunlockunlock
unlockunlockunlockunlockunlockunlock
unlockunlockunlockunlockunlockunlock

VulDB Base Score: 🔍
VulDB Temp Score: 🔍
VulDB Reliability: 🔍

Exploitinginfo

Class: Path traversal
CWE: CWE-23 / CWE-22
ATT&CK: T1006

Local: No
Remote: Yes

Availability: 🔍
Status: Not defined

EPSS Score: 🔍
EPSS Percentile: 🔍

Price Prediction: 🔍
Current Price Estimation: 🔍

0-Dayunlockunlockunlockunlock
Todayunlockunlockunlockunlock

Threat Intelligenceinfo

Interest: 🔍
Active Actors: 🔍
Active APT Groups: 🔍

Countermeasuresinfo

Recommended: Upgrade
Status: 🔍

0-Day Time: 🔍

Upgrade: PHP 7.3.31/7.4.24/8.0.11

Timelineinfo

01/04/2021 🔍
10/04/2021 +272 days 🔍
10/04/2021 +0 days 🔍
10/08/2021 +4 days 🔍

Sourcesinfo

Product: php.org

Advisory: 81420
Status: Confirmed

CVE: CVE-2021-21706 (🔍)

Entryinfo

Created: 10/04/2021 07:46 AM
Updated: 10/08/2021 02:22 PM
Changes: 10/04/2021 07:46 AM (51), 10/08/2021 02:22 PM (1)
Complete: 🔍

Discussion

No comments yet. Languages: en.

Please log in to comment.

Do you know our Splunk app?

Download it now for free!