Barcode up to 2.6.0 on GLPI front/send.php path traversal

CVSS Meta Temp Score
CVSS is a standardized scoring system to determine possibilities of attacks. The Temp Score considers temporal factors like disclosure, exploit and countermeasures. The unique Meta Score calculates the average score of different sources to provide a normalized scoring system.
Current Exploit Price (≈)
Our analysts are monitoring exploit markets and are in contact with vulnerability brokers. The range indicates the observed or calculated exploit price to be seen on exploit markets. A good indicator to understand the monetary effort required for and the popularity of an attack.
CTI Interest Score
Our Cyber Threat Intelligence team is monitoring different web sites, mailing lists, exploit markets and social media networks. The CTI Interest Score identifies the interest of attackers and the security community for this specific vulnerability in real-time. A high score indicates an elevated risk to be targeted for this vulnerability.
7.1$0-$5k0.00

A vulnerability was found in Barcode up to 2.6.0 on GLPI and classified as critical. Affected by this issue is an unknown function of the file front/send.php. The manipulation with an unknown input leads to a directory traversal vulnerability. Using CWE to declare the problem leads to CWE-22. Impacted is confidentiality. CVE summarizes:

Barcode is a GLPI plugin for printing barcodes and QR codes. GLPI instances version 2.x prior to version 2.6.1 with the barcode plugin installed are vulnerable to a path traversal vulnerability. This issue was patched in version 2.6.1. As a workaround, delete the `front/send.php` file.

The weakness was published 11/25/2021 as GHSA-2pjh-h828-wcw9. The advisory is available at github.com. This vulnerability is handled as CVE-2021-43778 since 11/16/2021. The exploitation is known to be easy. The attack may be launched remotely. No form of authentication is required for exploitation. Technical details are known, but there is no available exploit.

Upgrading to version 2.6.1 eliminates this vulnerability. The upgrade is hosted for download at github.com. Applying the patch 428c3d9adfb446e8492b1c2b7affb3d34072ff46 is able to eliminate this problem. The bugfix is ready for download at github.com. The best possible mitigation is suggested to be upgrading to the latest version.

Productinfoedit

Name

CPE 2.3infoedit

CPE 2.2infoedit

CVSSv3infoedit

VulDB Meta Base Score: 7.2
VulDB Meta Temp Score: 7.1

VulDB Base Score: 5.3
VulDB Temp Score: 5.1
VulDB Vector: 🔒
VulDB Reliability: 🔍

CNA Base Score: 9.1
CNA Vector (GitHub, Inc.): 🔒

CVSSv2infoedit

AVACAuCIA
🔍🔍🔍🔍🔍🔍
🔍🔍🔍🔍🔍🔍
🔍🔍🔍🔍🔍🔍
VectorComplexityAuthenticationConfidentialityIntegrityAvailability
unlockunlockunlockunlockunlockunlock
unlockunlockunlockunlockunlockunlock
unlockunlockunlockunlockunlockunlock

VulDB Base Score: 🔒
VulDB Temp Score: 🔒
VulDB Reliability: 🔍

Exploitinginfoedit

Class: Directory traversal
CWE: CWE-22
ATT&CK: Unknown

Local: No
Remote: Yes

Availability: 🔒
Status: Not defined
Price Prediction: 🔍
Current Price Estimation: 🔒

0-Dayunlockunlockunlockunlock
Todayunlockunlockunlockunlock

Threat Intelligenceinfoedit

Interest: 🔍
Active Actors: 🔍
Active APT Groups: 🔍

Countermeasuresinfoedit

Recommended: Upgrade
Status: 🔍

0-Day Time: 🔒

Upgrade: Barcode 2.6.1
Patch: 428c3d9adfb446e8492b1c2b7affb3d34072ff46

Timelineinfoedit

11/16/2021 CVE assigned
11/25/2021 +9 days Advisory disclosed
11/25/2021 +0 days VulDB entry created
11/27/2021 +2 days VulDB last update

Sourcesinfoedit

Advisory: GHSA-2pjh-h828-wcw9
Status: Confirmed
Confirmation: 🔒

CVE: CVE-2021-43778 (🔒)

Entryinfoedit

Created: 11/25/2021 07:30 AM
Updated: 11/27/2021 08:45 PM
Changes: (2) advisory_confirm_url source_cve_nvd_summary
Complete: 🔍

Comments

No comments yet. Languages: en.

Please log in to comment.

Interested in the pricing of exploits?

See the underground prices here!