Parity Frontier Debug Build integer underflow

CVSS Meta Temp Score
CVSS is a standardized scoring system to determine possibilities of attacks. The Temp Score considers temporal factors like disclosure, exploit and countermeasures. The unique Meta Score calculates the average score of different sources to provide a normalized scoring system.
Current Exploit Price (≈)
Our analysts are monitoring exploit markets and are in contact with vulnerability brokers. The range indicates the observed or calculated exploit price to be seen on exploit markets. A good indicator to understand the monetary effort required for and the popularity of an attack.
CTI Interest Score
Our Cyber Threat Intelligence team is monitoring different web sites, mailing lists, exploit markets and social media networks. The CTI Interest Score identifies the interest of attackers and the security community for this specific vulnerability in real-time. A high score indicates an elevated risk to be targeted for this vulnerability.
5.3$0-$5k0.00

A vulnerability classified as critical was found in Parity Frontier (affected version unknown). Affected by this vulnerability is an unknown part of the component Debug Build Handler. The manipulation with an unknown input leads to a memory corruption vulnerability. The CWE definition for the vulnerability is CWE-191. As an impact it is known to affect availability. The summary by CVE is:

Frontier is Substrate's Ethereum compatibility layer. Prior to commit number `8a93fdc6c9f4eb1d2f2a11b7ff1d12d70bf5a664`, a bug in Frontier's MODEXP precompile implementation can cause an integer underflow in certain conditions. This will cause a node crash for debug builds. For release builds (and production WebAssembly binaries), the impact is limited as it can only cause a normal EVM out-of-gas. Users who do not use MODEXP precompile in their runtime are not impacted. A patch is available in pull request #549.

The weakness was shared 01/14/2022 as GHSA-cjg2-2fjg-fph4. It is possible to read the advisory at github.com. This vulnerability is known as CVE-2022-21685 since 11/16/2021. The exploitation appears to be easy. The attack can be launched remotely. A single authentication is necessary for exploitation. The technical details are unknown and an exploit is not publicly available.

Applying the patch 8a93fdc6c9f4eb1d2f2a11b7ff1d12d70bf5a664 is able to eliminate this problem. The bugfix is ready for download at github.com.

Productinfoedit

Vendor

Name

CPE 2.3infoedit

CPE 2.2infoedit

CVSSv3infoedit

VulDB Meta Base Score: 5.4
VulDB Meta Temp Score: 5.3

VulDB Base Score: 4.3
VulDB Temp Score: 4.1
VulDB Vector: 🔒
VulDB Reliability: 🔍

CNA Base Score: 6.5
CNA Vector (GitHub, Inc.): 🔒

CVSSv2infoedit

AVACAuCIA
🔍🔍🔍🔍🔍🔍
🔍🔍🔍🔍🔍🔍
🔍🔍🔍🔍🔍🔍
VectorComplexityAuthenticationConfidentialityIntegrityAvailability
unlockunlockunlockunlockunlockunlock
unlockunlockunlockunlockunlockunlock
unlockunlockunlockunlockunlockunlock

VulDB Base Score: 🔒
VulDB Temp Score: 🔒
VulDB Reliability: 🔍

Exploitinginfoedit

Class: Memory corruption
CWE: CWE-191
ATT&CK: Unknown

Local: No
Remote: Yes

Availability: 🔒
Status: Not defined
Price Prediction: 🔍
Current Price Estimation: 🔒

0-Dayunlockunlockunlockunlock
Todayunlockunlockunlockunlock

Threat Intelligenceinfoedit

Interest: 🔍
Active Actors: 🔍
Active APT Groups: 🔍

Countermeasuresinfoedit

Recommended: Patch
Status: 🔍

0-Day Time: 🔒

Patch: 8a93fdc6c9f4eb1d2f2a11b7ff1d12d70bf5a664

Timelineinfoedit

11/16/2021 CVE assigned
01/14/2022 +59 days Advisory disclosed
01/14/2022 +0 days VulDB entry created
01/17/2022 +3 days VulDB last update

Sourcesinfoedit

Advisory: GHSA-cjg2-2fjg-fph4
Status: Confirmed
Confirmation: 🔒

CVE: CVE-2022-21685 (🔒)

Entryinfoedit

Created: 01/14/2022 08:54 PM
Updated: 01/17/2022 09:46 PM
Changes: (1) source_cve_nvd_summary
Complete: 🔍

Comments

No comments yet. Languages: en.

Please log in to comment.

Might our Artificial Intelligence support you?

Check our Alexa App!