Connman up to 1.40 DNS Proxy infinite loop

CVSS Meta Temp Score
CVSS is a standardized scoring system to determine possibilities of attacks. The Temp Score considers temporal factors like disclosure, exploit and countermeasures. The unique Meta Score calculates the average score of different sources to provide a normalized scoring system.
Current Exploit Price (≈)
Our analysts are monitoring exploit markets and are in contact with vulnerability brokers. The range indicates the observed or calculated exploit price to be seen on exploit markets. A good indicator to understand the monetary effort required for and the popularity of an attack.
CTI Interest Score
Our Cyber Threat Intelligence team is monitoring different web sites, mailing lists, exploit markets and social media networks. The CTI Interest Score identifies the interest of attackers and the security community for this specific vulnerability in real-time. A high score indicates an elevated risk to be targeted for this vulnerability.
3.4$0-$5k0.00

A vulnerability, which was classified as problematic, was found in Connman up to 1.40. This affects an unknown code block of the component DNS Proxy. The manipulation with an unknown input leads to a denial of service vulnerability. CWE is classifying the issue as CWE-835. This is going to have an impact on availability. The summary by CVE is:

An issue was discovered in the DNS proxy in Connman through 1.40. The TCP server reply implementation has an infinite loop if no data is received.

The weakness was disclosed 01/28/2022. It is possible to read the advisory at git.kernel.org. This vulnerability is uniquely identified as CVE-2022-23098 since 01/11/2022. The exploitability is told to be easy. Access to the local network is required for this attack. The requirement for exploitation is a authentication. The technical details are unknown and an exploit is not publicly available.

Applying a patch is able to eliminate this problem. The bugfix is ready for download at git.kernel.org.

Productinfoedit

Name

CPE 2.3infoedit

CPE 2.2infoedit

CVSSv3infoedit

VulDB Meta Base Score: 3.5
VulDB Meta Temp Score: 3.4

VulDB Base Score: 3.5
VulDB Temp Score: 3.4
VulDB Vector: 🔒
VulDB Reliability: 🔍

CVSSv2infoedit

AVACAuCIA
🔍🔍🔍🔍🔍🔍
🔍🔍🔍🔍🔍🔍
🔍🔍🔍🔍🔍🔍
VectorComplexityAuthenticationConfidentialityIntegrityAvailability
unlockunlockunlockunlockunlockunlock
unlockunlockunlockunlockunlockunlock
unlockunlockunlockunlockunlockunlock

VulDB Base Score: 🔒
VulDB Temp Score: 🔒
VulDB Reliability: 🔍

Exploitinginfoedit

Class: Denial of service
CWE: CWE-835
ATT&CK: Unknown

Local: No
Remote: Partially

Availability: 🔒
Status: Not defined
Price Prediction: 🔍
Current Price Estimation: 🔒

0-Dayunlockunlockunlockunlock
Todayunlockunlockunlockunlock

Threat Intelligenceinfoedit

Interest: 🔍
Active Actors: 🔍
Active APT Groups: 🔍

Countermeasuresinfoedit

Recommended: Patch
Status: 🔍

0-Day Time: 🔒

Patch: git.kernel.org

Timelineinfoedit

01/11/2022 CVE reserved
01/28/2022 +17 days Advisory disclosed
01/28/2022 +0 days VulDB entry created
01/30/2022 +2 days VulDB last update

Sourcesinfoedit

Advisory: git.kernel.org
Status: Confirmed

CVE: CVE-2022-23098 (🔒)

Entryinfoedit

Created: 01/28/2022 07:02 PM
Updated: 01/30/2022 01:49 PM
Changes: (1) source_cve_nvd_summary
Complete: 🔍

Comments

No comments yet. Languages: en.

Please log in to comment.

Might our Artificial Intelligence support you?

Check our Alexa App!