wger up to 2.1 excessive authentication

CVSS Meta Temp Score
CVSS is a standardized scoring system to determine possibilities of attacks. The Temp Score considers temporal factors like disclosure, exploit and countermeasures. The unique Meta Score calculates the average score of different sources to provide a normalized scoring system.
Current Exploit Price (≈)
Our analysts are monitoring exploit markets and are in contact with vulnerability brokers. The range indicates the observed or calculated exploit price to be seen on exploit markets. A good indicator to understand the monetary effort required for and the popularity of an attack.
CTI Interest Score
Our Cyber Threat Intelligence team is monitoring different web sites, mailing lists, exploit markets and social media networks. The CTI Interest Score identifies the interest of attackers and the security community for this specific vulnerability in real-time. A high score indicates an elevated risk to be targeted for this vulnerability.
6.0$0-$5k0.73

A vulnerability classified as problematic was found in wger up to 2.1. Affected by this vulnerability is an unknown code block. The manipulation with an unknown input leads to a excessive authentication vulnerability. The CWE definition for the vulnerability is CWE-307. The software does not implement sufficient measures to prevent multiple failed authentication attempts within in a short time frame, making it more susceptible to brute force attacks. As an impact it is known to affect confidentiality, integrity, and availability. The summary by CVE is:

Improper Restriction of Excessive Authentication Attempts in GitHub repository wger-project/wger prior to 2.2.

The weakness was published 11/24/2022. The advisory is shared at huntr.dev. This vulnerability is known as CVE-2022-2650 since 08/04/2022. Neither technical details nor an exploit are publicly available. MITRE ATT&CK project uses the attack technique T1110.001 for this issue.

Upgrading to version 2.2 eliminates this vulnerability. Applying the patch 5e3167e3a2dc95836fa2607fe201524c031a2c4c is able to eliminate this problem. The bugfix is ready for download at github.com. The best possible mitigation is suggested to be upgrading to the latest version.

Productinfo

Name

CPE 2.3info

CPE 2.2info

CVSSv3info

VulDB Meta Base Score: 6.1
VulDB Meta Temp Score: 6.0

VulDB Base Score: 4.5
VulDB Temp Score: 4.3
VulDB Vector: 🔒
VulDB Reliability: 🔍

CNA Base Score: 7.8
CNA Vector (huntr.dev): 🔒

CVSSv2info

AVACAuCIA
🔍🔍🔍🔍🔍🔍
🔍🔍🔍🔍🔍🔍
🔍🔍🔍🔍🔍🔍
VectorComplexityAuthenticationConfidentialityIntegrityAvailability
unlockunlockunlockunlockunlockunlock
unlockunlockunlockunlockunlockunlock
unlockunlockunlockunlockunlockunlock

VulDB Base Score: 🔒
VulDB Temp Score: 🔒
VulDB Reliability: 🔍

Exploitinginfo

Class: Excessive authentication
CWE: CWE-307 / CWE-799 / CWE-400
ATT&CK: T1110.001

Local: Yes
Remote: No

Availability: 🔒
Status: Not defined

EPSS Score: 🔒
EPSS Percentile: 🔒

Price Prediction: 🔍
Current Price Estimation: 🔒

0-Dayunlockunlockunlockunlock
Todayunlockunlockunlockunlock

Threat Intelligenceinfo

Interest: 🔍
Active Actors: 🔍
Active APT Groups: 🔍

Countermeasuresinfo

Recommended: Upgrade
Status: 🔍

0-Day Time: 🔒

Upgrade: wger 2.2
Patch: 5e3167e3a2dc95836fa2607fe201524c031a2c4c

Timelineinfo

08/04/2022 CVE reserved
11/24/2022 +112 days Advisory disclosed
11/24/2022 +0 days VulDB entry created
11/24/2022 +0 days VulDB last update

Sourcesinfo

Advisory: huntr.dev
Status: Confirmed

CVE: CVE-2022-2650 (🔒)

Entryinfo

Created: 11/24/2022 10:27 PM
Changes: 11/24/2022 10:27 PM (50)
Complete: 🔍

Discussion

No comments yet. Languages: en.

Please log in to comment.

Want to stay up to date on a daily basis?

Enable the mail alert feature now!