Wireshark up to 1.2.0 denial of service

CVSS Meta Temp Score
CVSS is a standardized scoring system to determine possibilities of attacks. The Temp Score considers temporal factors like disclosure, exploit and countermeasures. The unique Meta Score calculates the average score of different sources to provide a normalized scoring system.
Current Exploit Price (≈)
Our analysts are monitoring exploit markets and are in contact with vulnerability brokers. The range indicates the observed or calculated exploit price to be seen on exploit markets. A good indicator to understand the monetary effort required for and the popularity of an attack.
CTI Interest Score
Our Cyber Threat Intelligence team is monitoring different web sites, mailing lists, exploit markets and social media networks. The CTI Interest Score identifies the interest of attackers and the security community for this specific vulnerability in real-time. A high score indicates an elevated risk to be targeted for this vulnerability.
6.5$0-$5k0.00

A vulnerability has been found in Wireshark up to 1.2.0 (Packet Analyzer Software) and classified as critical. This vulnerability affects an unknown functionality. The manipulation with an unknown input leads to a denial of service vulnerability. The CWE definition for the vulnerability is CWE-404. The product does not release or incorrectly releases a resource before it is made available for re-use. As an impact it is known to affect availability. CVE summarizes:

Multiple unspecified vulnerabilities in Wireshark 1.2.0 allow remote attackers to cause a denial of service (application crash) via a file that records a malformed packet trace and is processed by the (1) Bluetooth L2CAP, (2) RADIUS, or (3) MIOP dissector. NOTE: it was later reported that the RADIUS issue also affects 0.10.13 through 1.0.9.

The weakness was shared 10/28/2009 with Wireshark (Website). The advisory is available at wireshark.org. This vulnerability was named CVE-2009-2560 since 07/21/2009. The attack can be initiated remotely. No form of authentication is required for a successful exploitation. The technical details are unknown and an exploit is not available.

It is declared as proof-of-concept. The vulnerability scanner Nessus provides a plugin with the ID 68032 (Oracle Linux 3 / 4 / 5 : wireshark (ELSA-2010-0360)), which helps to determine the existence of the flaw in a target environment. It is assigned to the family Oracle Linux Local Security Checks and running in the context l. The commercial vulnerability scanner Qualys is able to test this issue with plugin 116662 (Wireshark Denial of Service Vulnerabilities(wnpa-sec-2009-07,wnpa-sec-2009-08 )).

Upgrading eliminates this vulnerability. Applying a patch is able to eliminate this problem. The bugfix is ready for download at wireshark.org. The best possible mitigation is suggested to be upgrading to the latest version. A possible mitigation has been published 4 weeks after the disclosure of the vulnerability.

The vulnerability is also documented in the databases at X-Force (54019) and Tenable (68032).

Productinfo

Type

Name

Version

License

CPE 2.3info

CPE 2.2info

CVSSv4info

VulDB CVSS-B Score: 🔍
VulDB CVSS-BT Score: 🔍
VulDB Vector: 🔍
VulDB Reliability: 🔍

CVSSv3info

VulDB Meta Base Score: 7.5
VulDB Meta Temp Score: 6.5

VulDB Base Score: 7.5
VulDB Temp Score: 6.5
VulDB Vector: 🔍
VulDB Reliability: 🔍

CVSSv2info

AVACAuCIA
💳💳💳💳💳💳
💳💳💳💳💳💳
💳💳💳💳💳💳
VectorComplexityAuthenticationConfidentialityIntegrityAvailability
unlockunlockunlockunlockunlockunlock
unlockunlockunlockunlockunlockunlock
unlockunlockunlockunlockunlockunlock

VulDB Base Score: 🔍
VulDB Temp Score: 🔍
VulDB Reliability: 🔍

NVD Base Score: 🔍

Exploitinginfo

Class: Denial of service
CWE: CWE-404
CAPEC: 🔍
ATT&CK: 🔍

Local: No
Remote: Yes

Availability: 🔍
Status: Proof-of-Concept

EPSS Score: 🔍
EPSS Percentile: 🔍

Price Prediction: 🔍
Current Price Estimation: 🔍

0-Dayunlockunlockunlockunlock
Todayunlockunlockunlockunlock

Nessus ID: 68032
Nessus Name: Oracle Linux 3 / 4 / 5 : wireshark (ELSA-2010-0360)
Nessus File: 🔍
Nessus Risk: 🔍
Nessus Family: 🔍
Nessus Context: 🔍
Nessus Port: 🔍

OpenVAS ID: 66454
OpenVAS Name: Debian Security Advisory DSA 1942-1 (wireshark)
OpenVAS File: 🔍
OpenVAS Family: 🔍

Qualys ID: 🔍
Qualys Name: 🔍

Threat Intelligenceinfo

Interest: 🔍
Active Actors: 🔍
Active APT Groups: 🔍

Countermeasuresinfo

Recommended: Upgrade
Status: 🔍

Reaction Time: 🔍
Exposure Time: 🔍

Patch: wireshark.org

Timelineinfo

07/20/2009 🔍
07/21/2009 +1 days 🔍
07/21/2009 +0 days 🔍
07/28/2009 +7 days 🔍
10/26/2009 +90 days 🔍
10/28/2009 +2 days 🔍
10/28/2009 +0 days 🔍
11/19/2009 +21 days 🔍
11/25/2009 +6 days 🔍
11/26/2009 +1 days 🔍
07/12/2013 +1324 days 🔍
03/17/2021 +2805 days 🔍

Sourcesinfo

Product: wireshark.org

Advisory: wireshark.org
Organization: Wireshark
Status: Confirmed
Confirmation: 🔍

CVE: CVE-2009-2560 (🔍)
OVAL: 🔍

X-Force: 54019 - Wireshark RADIUS dissector denial of service, Medium Risk
Vulnerability Center: 22977 - Wireshark 1.2.0 Multiple Remote DoS Unspecified Vulnerabilities, Medium
SecurityFocus: 36846 - Wireshark 1.2.2 and 1.0.9 Multiple Vulnerabilities
Secunia: 37409 - Gentoo update for wireshark, Moderately Critical
OSVDB: 59461 - Wireshark RADIUS Dissector Unspecified DoS
Vupen: ADV-2009-3061

Entryinfo

Created: 11/19/2009 04:06 PM
Updated: 03/17/2021 03:51 PM
Changes: 11/19/2009 04:06 PM (86), 02/12/2017 12:56 PM (9), 03/17/2021 03:51 PM (3)
Complete: 🔍
Cache ID: 100:FC3:40

Discussion

No comments yet. Languages: en.

Please log in to comment.

Might our Artificial Intelligence support you?

Check our Alexa App!