Microsoft Word 2002/2003 File Information Block Parser memory corruption

CVSS Meta Temp Score
CVSS is a standardized scoring system to determine possibilities of attacks. The Temp Score considers temporal factors like disclosure, exploit and countermeasures. The unique Meta Score calculates the average score of different sources to provide a normalized scoring system.
Current Exploit Price (≈)
Our analysts are monitoring exploit markets and are in contact with vulnerability brokers. The range indicates the observed or calculated exploit price to be seen on exploit markets. A good indicator to understand the monetary effort required for and the popularity of an attack.
CTI Interest Score
Our Cyber Threat Intelligence team is monitoring different web sites, mailing lists, exploit markets and social media networks. The CTI Interest Score identifies the interest of attackers and the security community for this specific vulnerability in real-time. A high score indicates an elevated risk to be targeted for this vulnerability.
6.6$0-$5k0.00

A vulnerability was found in Microsoft Word 2002/2003 (Word Processing Software). It has been classified as very critical. Affected is an unknown part of the component File Information Block Parser. The manipulation with an unknown input leads to a memory corruption vulnerability. CWE is classifying the issue as CWE-119. The product performs operations on a memory buffer, but it can read from or write to a memory location that is outside of the intended boundary of the buffer. This is going to have an impact on confidentiality, integrity, and availability. CVE summarizes:

Stack-based buffer overflow in Microsoft Office Word 2002 SP3 and 2003 SP3, Office 2004 and 2008 for Mac, Open XML File Format Converter for Mac, Office Word Viewer 2003 SP3, and Office Word Viewer allow remote attackers to execute arbitrary code via a Word document with a malformed File Information Block (FIB) structure, aka "Microsoft Office Word File Information Memory Corruption Vulnerability."

The weakness was released 11/10/2009 by Jun Mao with VeriSign iDefense Labs as MS09-068 as confirmed bulletin (Technet). The advisory is shared for download at microsoft.com. This vulnerability is traded as CVE-2009-3135 since 09/10/2009. It is possible to launch the attack remotely. The exploitation doesn't require any form of authentication. There are neither technical details nor an exploit publicly available. The current price for an exploit might be approx. USD $0-$5k (estimation calculated on 03/17/2021).

It is declared as proof-of-concept. As 0-day the estimated underground price was around $25k-$100k. The vulnerability scanner Nessus provides a plugin with the ID 42442 (MS09-068: Vulnerability in Microsoft Office Word Could Allow Remote Code Execution (976307)), which helps to determine the existence of the flaw in a target environment. It is assigned to the family Windows : Microsoft Bulletins and running in the context l.

Upgrading eliminates this vulnerability. Applying the patch MS09-068 is able to eliminate this problem. The bugfix is ready for download at microsoft.com. The best possible mitigation is suggested to be upgrading to the latest version. A possible mitigation has been published immediately after the disclosure of the vulnerability. Furthermore it is possible to detect and prevent this kind of attack with TippingPoint and the filter 9247.

The vulnerability is also documented in the databases at X-Force (53977), Tenable (42442), SecurityFocus (BID 36950†), OSVDB (59857†) and Secunia (SA37277†). Entries connected to this vulnerability are available at VDB-178561, VDB-182671, VDB-190059 and VDB-213132.

Productinfo

Type

Vendor

Name

Version

License

CPE 2.3info

CPE 2.2info

CVSSv4info

VulDB CVSS-B Score: 🔍
VulDB CVSS-BT Score: 🔍
VulDB Vector: 🔍
VulDB Reliability: 🔍

CVSSv3info

VulDB Meta Base Score: 7.3
VulDB Meta Temp Score: 6.6

VulDB Base Score: 7.3
VulDB Temp Score: 6.6
VulDB Vector: 🔍
VulDB Reliability: 🔍

CVSSv2info

AVACAuCIA
💳💳💳💳💳💳
💳💳💳💳💳💳
💳💳💳💳💳💳
VectorComplexityAuthenticationConfidentialityIntegrityAvailability
unlockunlockunlockunlockunlockunlock
unlockunlockunlockunlockunlockunlock
unlockunlockunlockunlockunlockunlock

VulDB Base Score: 🔍
VulDB Temp Score: 🔍
VulDB Reliability: 🔍

NVD Base Score: 🔍

Exploitinginfo

Class: Memory corruption
CWE: CWE-119
CAPEC: 🔍
ATT&CK: 🔍

Local: No
Remote: Yes

Availability: 🔍
Status: Proof-of-Concept

EPSS Score: 🔍
EPSS Percentile: 🔍

Price Prediction: 🔍
Current Price Estimation: 🔍

0-Dayunlockunlockunlockunlock
Todayunlockunlockunlockunlock

Nessus ID: 42442
Nessus Name: MS09-068: Vulnerability in Microsoft Office Word Could Allow Remote Code Execution (976307)
Nessus File: 🔍
Nessus Risk: 🔍
Nessus Family: 🔍
Nessus Context: 🔍

OpenVAS ID: 900973
OpenVAS Name: Microsoft Office Word Remote Code Execution Vulnerability (976307)
OpenVAS File: 🔍
OpenVAS Family: 🔍

Threat Intelligenceinfo

Interest: 🔍
Active Actors: 🔍
Active APT Groups: 🔍

Countermeasuresinfo

Recommended: Upgrade
Status: 🔍

Reaction Time: 🔍
0-Day Time: 🔍
Exposure Time: 🔍

Patch: MS09-068
TippingPoint: 🔍

McAfee IPS: 🔍
McAfee IPS Version: 🔍

PaloAlto IPS: 🔍
Fortigate IPS: 🔍

Timelineinfo

09/10/2009 🔍
11/10/2009 +61 days 🔍
11/10/2009 +0 days 🔍
11/10/2009 +0 days 🔍
11/10/2009 +0 days 🔍
11/10/2009 +0 days 🔍
11/10/2009 +0 days 🔍
11/10/2009 +0 days 🔍
11/11/2009 +0 days 🔍
11/11/2009 +0 days 🔍
11/19/2009 +8 days 🔍
03/17/2021 +4136 days 🔍

Sourcesinfo

Vendor: microsoft.com

Advisory: MS09-068
Researcher: Jun Mao
Organization: VeriSign iDefense Labs
Status: Confirmed

CVE: CVE-2009-3135 (🔍)
OVAL: 🔍
IAVM: 🔍

X-Force: 53977
SecurityFocus: 36950 - Microsoft Word Record Parsing Remote Stack Buffer Overflow Vulnerability
Secunia: 37277 - Microsoft Office Word File Information Block Parsing Buffer Overflow, Highly Critical
OSVDB: 59857 - Microsoft Office Word Document Malformed File Information Block (FIB) Parsing Memory Corruption
SecurityTracker: 1023158 - Microsoft Word Memory Corruption Error Lets Remote Users Execute Arbitrary Code
Vulnerability Center: 24011 - [MS09-068] Microsoft Office Word Buffer Overflow Remote Code Execution or DoS Vulnerability, Medium
Vupen: ADV-2009-3194

See also: 🔍

Entryinfo

Created: 11/19/2009 04:12 PM
Updated: 03/17/2021 03:57 PM
Changes: 11/19/2009 04:12 PM (93), 02/17/2017 11:16 AM (11), 03/17/2021 03:57 PM (3)
Complete: 🔍
Cache ID: 3:A6A:40

Discussion

No comments yet. Languages: en.

Please log in to comment.

Might our Artificial Intelligence support you?

Check our Alexa App!