Apache Struts 1.3.10 processSimple.do message cross site scripting

CVSS Meta Temp Score
CVSS is a standardized scoring system to determine possibilities of attacks. The Temp Score considers temporal factors like disclosure, exploit and countermeasures. The unique Meta Score calculates the average score of different sources to provide a normalized scoring system.
Current Exploit Price (≈)
Our analysts are monitoring exploit markets and are in contact with vulnerability brokers. The range indicates the observed or calculated exploit price to be seen on exploit markets. A good indicator to understand the monetary effort required for and the popularity of an attack.
CTI Interest Score
Our Cyber Threat Intelligence team is monitoring different web sites, mailing lists, exploit markets and social media networks. The CTI Interest Score identifies the interest of attackers and the security community for this specific vulnerability in real-time. A high score indicates an elevated risk to be targeted for this vulnerability.
8.5$0-$5k0.00

A vulnerability was found in Apache Struts 1.3.10 (Programming Tool Software). It has been declared as critical. Affected by this vulnerability is an unknown code block of the file struts-cookbook/processSimple.do. The manipulation of the argument message with an unknown input leads to a cross site scripting vulnerability. The CWE definition for the vulnerability is CWE-79. The product does not neutralize or incorrectly neutralizes user-controllable input before it is placed in output that is used as a web page that is served to other users. As an impact it is known to affect confidentiality, integrity, and availability. The summary by CVE is:

Multiple cross-site scripting (XSS) vulnerabilities in Apache Struts 1.3.10 allow remote attackers to inject arbitrary web script or HTML via (1) the name parameter to struts-examples/upload/upload-submit.do, or the message parameter to (2) struts-cookbook/processSimple.do or (3) struts-cookbook/processDyna.do.

The bug was discovered 07/21/2011. The weakness was disclosed 02/01/2012 (Website). The advisory is shared at xforce.iss.net. The public release happened without involvement of Apache. This vulnerability is known as CVE-2012-1007 since 02/06/2012. The exploitation appears to be easy. The attack can be launched remotely. The exploitation doesn't need any form of authentication. It demands that the victim is doing some kind of user interaction. Technical details and also a public exploit are known. MITRE ATT&CK project uses the attack technique T1059.007 for this issue.

After immediately, there has been an exploit disclosed. It is possible to download the exploit at exploit-db.com. It is declared as highly functional. The vulnerability was handled as a non-public zero-day exploit for at least 195 days. During that time the estimated underground price was around $5k-$25k. The vulnerability scanner Nessus provides a plugin with the ID 60094 (Apache Struts struts-examples upload-submit.do 'theText' Parameter XSS), which helps to determine the existence of the flaw in a target environment. It is assigned to the family CGI abuses : XSS and running in the context r. The commercial vulnerability scanner Qualys is able to test this issue with plugin 371190 (IBM WebSphere Application Server Multiple Vulnerabilities (swg22016214)).

Upgrading to version 2.3.3 eliminates this vulnerability.

The vulnerability is also documented in the databases at X-Force (73052), Tenable (60094) and Exploit-DB (18452). The entries 4595, 4596, 4598 and 79101 are pretty similar.

Productinfo

Type

Vendor

Name

Version

License

CPE 2.3info

CPE 2.2info

CVSSv3info

VulDB Meta Base Score: 8.8
VulDB Meta Temp Score: 8.5

VulDB Base Score: 8.8
VulDB Temp Score: 8.5
VulDB Vector: 🔍
VulDB Reliability: 🔍

CVSSv2info

AVACAuCIA
💳💳💳💳💳💳
💳💳💳💳💳💳
💳💳💳💳💳💳
VectorComplexityAuthenticationConfidentialityIntegrityAvailability
unlockunlockunlockunlockunlockunlock
unlockunlockunlockunlockunlockunlock
unlockunlockunlockunlockunlockunlock

VulDB Base Score: 🔍
VulDB Temp Score: 🔍
VulDB Reliability: 🔍

NVD Base Score: 🔍

Exploitinginfo

Class: Cross site scripting
CWE: CWE-79 / CWE-74 / CWE-707
ATT&CK: T1059.007

Local: No
Remote: Yes

Availability: 🔍
Access: Public
Status: Highly functional
Download: 🔍

EPSS Score: 🔍
EPSS Percentile: 🔍

Price Prediction: 🔍
Current Price Estimation: 🔍

0-Dayunlockunlockunlockunlock
Todayunlockunlockunlockunlock

Nessus ID: 60094
Nessus Name: Apache Struts struts-examples upload-submit.do 'theText' Parameter XSS
Nessus File: 🔍
Nessus Risk: 🔍
Nessus Family: 🔍
Nessus Context: 🔍

OpenVAS ID: 802423
OpenVAS Name: Apache Struts CookBook/Examples Multiple Cross-Site Scripting Vulnerabilities
OpenVAS File: 🔍
OpenVAS Family: 🔍

Qualys ID: 🔍
Qualys Name: 🔍

Exploit-DB: 🔍

Threat Intelligenceinfo

Interest: 🔍
Active Actors: 🔍
Active APT Groups: 🔍

Countermeasuresinfo

Recommended: Upgrade
Status: 🔍

0-Day Time: 🔍
Exploit Delay Time: 🔍

Upgrade: Struts 2.3.3

Timelineinfo

07/21/2011 🔍
02/01/2012 +195 days 🔍
02/01/2012 +0 days 🔍
02/06/2012 +5 days 🔍
02/06/2012 +0 days 🔍
02/07/2012 +1 days 🔍
02/21/2012 +14 days 🔍
07/23/2012 +153 days 🔍
04/28/2019 +2470 days 🔍

Sourcesinfo

Vendor: apache.org

Advisory: xforce.iss.net
Status: Not defined
Confirmation: 🔍

CVE: CVE-2012-1007 (🔍)
X-Force: 73052 - Apache Struts name cross-site scripting, Medium Risk
SecurityFocus: 51902 - Apache Struts Multiple HTML Injection Vulnerabilities
OSVDB: 78992

scip Labs: https://www.scip.ch/en/?labs.20161013
See also: 🔍

Entryinfo

Created: 02/21/2012 01:00 AM
Updated: 04/28/2019 12:39 PM
Changes: 02/21/2012 01:00 AM (75), 04/28/2019 12:39 PM (7)
Complete: 🔍

Discussion

No comments yet. Languages: en.

Please log in to comment.

Do you know our Splunk app?

Download it now for free!