Zen Cart up to 1.2.0d admin/sqlpatch.php query_string sql injection

CVSS Meta Temp Score
CVSS is a standardized scoring system to determine possibilities of attacks. The Temp Score considers temporal factors like disclosure, exploit and countermeasures. The unique Meta Score calculates the average score of different sources to provide a normalized scoring system.
Current Exploit Price (≈)
Our analysts are monitoring exploit markets and are in contact with vulnerability brokers. The range indicates the observed or calculated exploit price to be seen on exploit markets. A good indicator to understand the monetary effort required for and the popularity of an attack.
CTI Interest Score
Our Cyber Threat Intelligence team is monitoring different web sites, mailing lists, exploit markets and social media networks. The CTI Interest Score identifies the interest of attackers and the security community for this specific vulnerability in real-time. A high score indicates an elevated risk to be targeted for this vulnerability.
6.6$0-$5k0.00

A vulnerability, which was classified as critical, was found in Zen Cart up to 1.2.0d (Warehouse Management System Software). Affected is some unknown functionality of the file admin/sqlpatch.php. The manipulation of the argument query_string with an unknown input leads to a sql injection vulnerability. CWE is classifying the issue as CWE-89. The product constructs all or part of an SQL command using externally-influenced input from an upstream component, but it does not neutralize or incorrectly neutralizes special elements that could modify the intended SQL command when it is sent to a downstream component. This is going to have an impact on confidentiality, integrity, and availability. CVE summarizes:

Zen Cart 1.3.8a, 1.3.8, and earlier does not require administrative authentication for admin/sqlpatch.php, which allows remote attackers to execute arbitrary SQL commands via the query_string parameter in an execute action, in conjunction with a PATH_INFO of password_forgotten.php, related to a "SQL Execution" issue.

The weakness was disclosed 06/23/2009 (Website). The advisory is shared for download at milw0rm.com. This vulnerability is traded as CVE-2009-2254 since 06/29/2009. The exploitability is told to be easy. It is possible to launch the attack remotely. The exploitation doesn't require any form of authentication. Technical details and a public exploit are known. The MITRE ATT&CK project declares the attack technique as T1505.

A public exploit has been developed in Python and been published immediately after the advisory. The exploit is shared for download at securityfocus.com. It is declared as proof-of-concept. By approaching the search of inurl:admin/sqlpatch.php it is possible to find vulnerable targets with Google Hacking. The vulnerability scanner Nessus provides a plugin with the ID 39501 (Zen Cart password_forgotten.php Admin Access Bypass), which helps to determine the existence of the flaw in a target environment. It is assigned to the family CGI abuses.

Applying a patch is able to eliminate this problem. A possible mitigation has been published before and not just after the disclosure of the vulnerability. Furthermore it is possible to detect and prevent this kind of attack with TippingPoint and the filter 9418.

The vulnerability is also documented in the databases at X-Force (51317) and Tenable (39501). The entry VDB-48793 is pretty similar.

Productinfo

Type

Name

Version

License

CPE 2.3info

CPE 2.2info

CVSSv4info

VulDB CVSS-B Score: 🔍
VulDB CVSS-BT Score: 🔍
VulDB Vector: 🔍
VulDB Reliability: 🔍

CVSSv3info

VulDB Meta Base Score: 7.3
VulDB Meta Temp Score: 6.6

VulDB Base Score: 7.3
VulDB Temp Score: 6.6
VulDB Vector: 🔍
VulDB Reliability: 🔍

CVSSv2info

AVACAuCIA
💳💳💳💳💳💳
💳💳💳💳💳💳
💳💳💳💳💳💳
VectorComplexityAuthenticationConfidentialityIntegrityAvailability
unlockunlockunlockunlockunlockunlock
unlockunlockunlockunlockunlockunlock
unlockunlockunlockunlockunlockunlock

VulDB Base Score: 🔍
VulDB Temp Score: 🔍
VulDB Reliability: 🔍

NVD Base Score: 🔍

Exploitinginfo

Class: Sql injection
CWE: CWE-89 / CWE-74 / CWE-707
CAPEC: 🔍
ATT&CK: 🔍

Local: No
Remote: Yes

Availability: 🔍
Access: Public
Status: Proof-of-Concept
Programming Language: 🔍
Download: 🔍
Google Hack: 🔍

EPSS Score: 🔍
EPSS Percentile: 🔍

Price Prediction: 🔍
Current Price Estimation: 🔍

0-Dayunlockunlockunlockunlock
Todayunlockunlockunlockunlock

Nessus ID: 39501
Nessus Name: Zen Cart password_forgotten.php Admin Access Bypass
Nessus File: 🔍
Nessus Risk: 🔍
Nessus Family: 🔍

OpenVAS ID: 100894
OpenVAS Name: Zen Cart Arbitrary Code Execution Vulnerability
OpenVAS File: 🔍
OpenVAS Family: 🔍

Exploit-DB: 🔍

Threat Intelligenceinfo

Interest: 🔍
Active Actors: 🔍
Active APT Groups: 🔍

Countermeasuresinfo

Recommended: Patch
Status: 🔍

0-Day Time: 🔍
Exploit Delay Time: 🔍
TippingPoint: 🔍

Timelineinfo

06/21/2009 🔍
06/23/2009 +1 days 🔍
06/23/2009 +0 days 🔍
06/23/2009 +0 days 🔍
06/23/2009 +0 days 🔍
06/24/2009 +0 days 🔍
06/24/2009 +0 days 🔍
06/29/2009 +4 days 🔍
06/30/2009 +1 days 🔍
10/05/2010 +462 days 🔍
03/17/2015 +1624 days 🔍
08/12/2021 +2340 days 🔍

Sourcesinfo

Advisory: milw0rm.com
Status: Not defined
Confirmation: 🔍

CVE: CVE-2009-2254 (🔍)
X-Force: 51317
Vulnerability Center: 27438 - Zen Cart 1.3.8a, 1.3.8 and Prior Remote SQL Injection Vulnerability, High
SecurityFocus: 35468 - Zen Cart 'admin/sqlpatch.php' SQL Injection Vulnerability
Secunia: 35550
OSVDB: 55343 - Zen Cart admin/sqlpatch.php query_string Parameter SQL Injection

scip Labs: https://www.scip.ch/en/?labs.20161013
See also: 🔍

Entryinfo

Created: 03/17/2015 11:38 PM
Updated: 08/12/2021 07:46 AM
Changes: 03/17/2015 11:38 PM (69), 08/14/2017 10:28 AM (12), 08/12/2021 07:40 AM (3), 08/12/2021 07:46 AM (1)
Complete: 🔍
Cache ID: 100:35A:40

Discussion

No comments yet. Languages: en.

Please log in to comment.

Interested in the pricing of exploits?

See the underground prices here!