Google Chrome up to 18.0.1025.162 XML Parser resource management

entryeditHistoryDiffjsonxmlCTI
CVSS Meta Temp Score
CVSS is a standardized scoring system to determine possibilities of attacks. The Temp Score considers temporal factors like disclosure, exploit and countermeasures. The unique Meta Score calculates the average score of different sources to provide a normalized scoring system.
Current Exploit Price (≈)
Our analysts are monitoring exploit markets and are in contact with vulnerability brokers. The range indicates the observed or calculated exploit price to be seen on exploit markets. A good indicator to understand the monetary effort required for and the popularity of an attack.
CTI Interest Score
Our Cyber Threat Intelligence team is monitoring different web sites, mailing lists, exploit markets and social media networks. The CTI Interest Score identifies the interest of attackers and the security community for this specific vulnerability in real-time. A high score indicates an elevated risk to be targeted for this vulnerability.
5.7$0-$5k0.00

A vulnerability was found in Google Chrome up to 18.0.1025.162 (Web Browser) and classified as problematic. This issue affects some unknown processing of the component XML Parser. The manipulation with an unknown input leads to a denial of service vulnerability. Using CWE to declare the problem leads to CWE-399. Impacted is confidentiality, integrity, and availability.

The bug was discovered 04/30/2012. The weakness was presented 04/30/2012 by Willem Pinckaers (SkyLined and wushi) with Google Chrome Security Team & iDefense Labs VCP as 117110 as confirmed knowledge base article (Website). The advisory is shared at code.google.com. The public release was coordinated in cooperation with Google. The identification of this vulnerability is CVE-2012-1521 since 03/08/2012. The attack may be initiated remotely. No form of authentication is needed for a successful exploitation. It demands that the victim is doing some kind of user interaction. Technical details are unknown but a public exploit is available.

It is declared as proof-of-concept. We expect the 0-day to have been worth approximately $25k-$100k. The vulnerability scanner Nessus provides a plugin with the ID 58963 (FreeBSD : chromium -- multiple vulnerabilities (94c0ac4f-9388-11e1-b242-00262d5ed8ee)), which helps to determine the existence of the flaw in a target environment. It is assigned to the family FreeBSD Local Security Checks and running in the context local. The commercial vulnerability scanner Qualys is able to test this issue with plugin 120198 (Google Chrome Prior to 18.0.1025.168 Multiple Vulnerabilities).

Upgrading to version 18.0.1025.168 eliminates this vulnerability. The upgrade is hosted for download at chrome.google.com. Applying a patch is able to eliminate this problem. The bugfix is ready for download at trac.webkit.org. The best possible mitigation is suggested to be upgrading to the latest version. A possible mitigation has been published immediately after the disclosure of the vulnerability.

The vulnerability is also documented in the databases at SecurityFocus (BID 53309), Secunia (SA48992), SecurityTracker (ID 1027001) and Tenable (58963). See 5332, 5334, 5337 and 5338 for similar entries.

Productinfoedit

Type

Vendor

Name

CPE 2.3infoedit

CPE 2.2infoedit

CVSSv3infoedit

VulDB Meta Base Score: 6.3
VulDB Meta Temp Score: 5.7

VulDB Base Score: 6.3
VulDB Temp Score: 5.7
VulDB Vector: 🔍
VulDB Reliability: 🔍

CVSSv2infoedit

AVACAuCIA
🔍🔍🔍🔍🔍🔍
🔍🔍🔍🔍🔍🔍
🔍🔍🔍🔍🔍🔍
VectorComplexityAuthenticationConfidentialityIntegrityAvailability
unlockunlockunlockunlockunlockunlock
unlockunlockunlockunlockunlockunlock
unlockunlockunlockunlockunlockunlock

VulDB Base Score: 🔍
VulDB Temp Score: 🔍
VulDB Reliability: 🔍

NVD Base Score: 🔍

Exploitinginfoedit

Class: Denial of service
CWE: CWE-399
ATT&CK: Unknown

Local: No
Remote: Yes

Availability: 🔍
Access: Public
Status: Proof-of-Concept

Price Prediction: 🔍
Current Price Estimation: 🔍

0-Dayunlockunlockunlockunlock
Todayunlockunlockunlockunlock

Nessus ID: 58963
Nessus Name: FreeBSD : chromium -- multiple vulnerabilities (94c0ac4f-9388-11e1-b242-00262d5ed8ee)
Nessus File: 🔍
Nessus Risk: 🔍
Nessus Family: 🔍
Nessus Context: 🔍

OpenVAS ID: 71386
OpenVAS Name: FreeBSD Ports: chromium
OpenVAS File: 🔍
OpenVAS Family: 🔍

Qualys ID: 🔍
Qualys Name: 🔍

Threat Intelligenceinfoedit

Threat: 🔍
Adversaries: 🔍
Geopolitics: 🔍
Economy: 🔍
Predictions: 🔍
Remediation: 🔍

Countermeasuresinfoedit

Recommended: Upgrade
Status: 🔍

Reaction Time: 🔍
0-Day Time: 🔍
Exposure Time: 🔍

Upgrade: Chrome 18.0.1025.168
Patch: trac.webkit.org

Timelineinfoedit

03/08/2012 🔍
04/30/2012 +53 days 🔍
04/30/2012 +0 days 🔍
04/30/2012 +0 days 🔍
04/30/2012 +0 days 🔍
05/01/2012 +1 days 🔍
05/01/2012 +0 days 🔍
05/02/2012 +1 days 🔍
05/02/2012 +0 days 🔍
05/05/2012 +3 days 🔍
05/07/2012 +2 days 🔍
05/02/2019 +2551 days 🔍

Sourcesinfoedit

Vendor: https://www.google.com/
Product: https://www.google.com/chrome/

Advisory: 117110
Researcher: Willem Pinckaers (SkyLined / wushi)
Organization: Google Chrome Security Team & iDefense Labs VCP
Status: Confirmed
Confirmation: 🔍
Coordinated: 🔍

CVE: CVE-2012-1521 (🔍)
OVAL: 🔍

SecurityFocus: 53309 - Google Chrome Prior to 18.0.1025.168 Multiple Security Vulnerabilities
Secunia: 48992 - Google Chrome Multiple Vulnerabilities, Highly Critical
SecurityTracker: 1027001
OSVDB: 81644

See also: 🔍

Entryinfoedit

Created: 05/07/2012 12:34 PM
Updated: 05/02/2019 07:07 AM
Changes: (10) vulnerability_cvss2_nvd_av vulnerability_cvss2_nvd_ac vulnerability_cvss2_nvd_au vulnerability_cvss2_nvd_ci vulnerability_cvss2_nvd_ii vulnerability_cvss2_nvd_ai source_secunia_date source_securityfocus source_securityfocus_date source_securityfocus_class
Complete: 🔍

Comments

No comments yet. Please log in to comment.

Are you interested in using VulDB?

Download the whitepaper to learn more about our service!