Adobe Acrobat Reader prior 9.0 memory corruption

entryeditHistoryDiffjsonxmlCTI
CVSS Meta Temp Score
CVSS is a standardized scoring system to determine possibilities of attacks. The Temp Score considers temporal factors like disclosure, exploit and countermeasures. The unique Meta Score calculates the average score of different sources to provide a normalized scoring system.
Current Exploit Price (≈)
Our analysts are monitoring exploit markets and are in contact with vulnerability brokers. The range indicates the observed or calculated exploit price to be seen on exploit markets. A good indicator to understand the monetary effort required for and the popularity of an attack.
CTI Interest Score
Our Cyber Threat Intelligence team is monitoring different web sites, mailing lists, exploit markets and social media networks. The CTI Interest Score identifies the interest of attackers and the security community for this specific vulnerability in real-time. A high score indicates an elevated risk to be targeted for this vulnerability.
6.6$0-$5k0.00

A vulnerability has been found in Adobe Acrobat Reader (Document Reader Software) and classified as critical. Affected by this vulnerability is an unknown functionality. The manipulation with an unknown input leads to a memory corruption vulnerability. The CWE definition for the vulnerability is CWE-119. As an impact it is known to affect confidentiality, integrity, and availability.

The weakness was disclosed 06/30/2010 by Tavis Ormandy with Google Security Team (Website). It is possible to read the advisory at adobe.com. This vulnerability is known as CVE-2010-2210 since 06/08/2010. The attack can be launched remotely. The exploitation doesn't need any form of authentication. The technical details are unknown and an exploit is not publicly available.

It is declared as proof-of-concept. The vulnerability scanner Nessus provides a plugin with the ID 47164 (Adobe Acrobat < 9.3.3 / 8.2.3 Multiple Vulnerabilities (APSB10-15)), which helps to determine the existence of the flaw in a target environment. It is assigned to the family Windows and running in the context local. The commercial vulnerability scanner Qualys is able to test this issue with plugin 165597 (SUSE Enterprise Linux Security Update Acrobat Reader (SUSE-SA:2010:029)).

Upgrading to version 9.0 eliminates this vulnerability. A possible mitigation has been published even before and not after the disclosure of the vulnerability.

The vulnerability is also documented in the databases at SecurityFocus (BID 41242), SecurityTracker (ID 1024159), Vulnerability Center (SBV-26295) and Tenable (47164). The entries 53889, 53888, 53886 and 53885 are pretty similar.

Productinfoedit

Type

Vendor

Name

CPE 2.3infoedit

CPE 2.2infoedit

CVSSv3infoedit

VulDB Meta Base Score: 7.3
VulDB Meta Temp Score: 6.6

VulDB Base Score: 7.3
VulDB Temp Score: 6.6
VulDB Vector: 🔍
VulDB Reliability: 🔍

CVSSv2infoedit

AVACAuCIA
🔍🔍🔍🔍🔍🔍
🔍🔍🔍🔍🔍🔍
🔍🔍🔍🔍🔍🔍
VectorComplexityAuthenticationConfidentialityIntegrityAvailability
unlockunlockunlockunlockunlockunlock
unlockunlockunlockunlockunlockunlock
unlockunlockunlockunlockunlockunlock

VulDB Base Score: 🔍
VulDB Temp Score: 🔍
VulDB Reliability: 🔍

NVD Base Score: 🔍

Exploitinginfoedit

Class: Memory corruption
CWE: CWE-119
ATT&CK: Unknown

Local: No
Remote: Yes

Availability: 🔍
Status: Proof-of-Concept

Price Prediction: 🔍
Current Price Estimation: 🔍

0-Dayunlockunlockunlockunlock
Todayunlockunlockunlockunlock

Nessus ID: 47164
Nessus Name: Adobe Acrobat < 9.3.3 / 8.2.3 Multiple Vulnerabilities (APSB10-15)
Nessus File: 🔍
Nessus Risk: 🔍
Nessus Family: 🔍
Nessus Context: 🔍

OpenVAS ID: 801365
OpenVAS Name: Adobe Acrobat and Reader Multiple Vulnerabilities -July10 (Windows)
OpenVAS File: 🔍
OpenVAS Family: 🔍

Qualys ID: 🔍
Qualys Name: 🔍

Threat Intelligenceinfoedit

Threat: 🔍
Adversaries: 🔍
Geopolitics: 🔍
Economy: 🔍
Predictions: 🔍
Remediation: 🔍

Countermeasuresinfoedit

Recommended: Upgrade
Status: 🔍

0-Day Time: 🔍

Upgrade: Acrobat Reader 9.0
McAfee IPS: 🔍
McAfee IPS Version: 🔍

Fortigate IPS: 🔍

Timelineinfoedit

06/08/2010 🔍
06/29/2010 +21 days 🔍
06/29/2010 +0 days 🔍
06/29/2010 +0 days 🔍
06/29/2010 +0 days 🔍
06/30/2010 +1 days 🔍
06/30/2010 +0 days 🔍
06/30/2010 +0 days 🔍
07/06/2010 +5 days 🔍
03/19/2015 +1717 days 🔍
11/13/2017 +970 days 🔍
10/16/2018 +336 days 🔍

Sourcesinfoedit

Vendor: https://www.adobe.com/

Advisory: adobe.com
Researcher: Tavis Ormandy
Organization: Google Security Team
Status: Confirmed
Confirmation: 🔍

CVE: CVE-2010-2210 (🔍)
OVAL: 🔍

SecurityFocus: 41242 - Adobe Acrobat and Reader CVE-2010-2210 Remote Memory Corruption Vulnerability
SecurityTracker: 1024159
Vulnerability Center: 26295 - [APSB10-15] Adobe Reader and Acrobat on Windows and MacOS X Remote Memory Corruption Vulnerability, Medium
Vupen: ADV-2010-1636

See also: 🔍

Entryinfoedit

Created: 03/19/2015 12:22 PM
Updated: 10/16/2018 09:09 AM
Changes: (14) advisory_person_name advisory_company_name advisory_confirm_url advisory_disputed countermeasure_date source_cve_assigned source_securityfocus_date source_securityfocus_class source_sectracker source_sectracker_date source_sectracker_cause source_vupen source_mcafee_ips_id source_mcafee_ips_version
Complete: 🔍

Comments

No comments yet. Please log in to comment.

Want to stay up to date on a daily basis?

Enable the mail alert feature now!