VDB-54309 · CVE-2010-0209 · BID 42358

Adobe Flash Player prior 9.0.114.0 code injection

CVSS Meta Temp Score
CVSS is a standardized scoring system to determine possibilities of attacks. The Temp Score considers temporal factors like disclosure, exploit and countermeasures. The unique Meta Score calculates the average score of different sources to provide a normalized scoring system.
Current Exploit Price (≈)
Our analysts are monitoring exploit markets and are in contact with vulnerability brokers. The range indicates the observed or calculated exploit price to be seen on exploit markets. A good indicator to understand the monetary effort required for and the popularity of an attack.
CTI Interest Score
Our Cyber Threat Intelligence team is monitoring different web sites, mailing lists, exploit markets and social media networks. The CTI Interest Score identifies the interest of attackers and the security community for this specific vulnerability in real-time. A high score indicates an elevated risk to be targeted for this vulnerability.
9.5$0-$5k0.00

A vulnerability, which was classified as very critical, was found in Adobe Flash Player (Multimedia Player Software). This affects an unknown part. The manipulation with an unknown input leads to a code injection vulnerability. CWE is classifying the issue as CWE-94. The product constructs all or part of a code segment using externally-influenced input from an upstream component, but it does not neutralize or incorrectly neutralizes special elements that could modify the syntax or behavior of the intended code segment. This is going to have an impact on confidentiality, integrity, and availability. The summary by CVE is:

Adobe Flash Player before 9.0.280 and 10.x before 10.1.82.76, and Adobe AIR before 2.0.3, allows attackers to execute arbitrary code or cause a denial of service (memory corruption) via unspecified vectors, a different vulnerability than CVE-2010-2213, CVE-2010-2214, and CVE-2010-2216.

The weakness was shared 08/11/2010 (Website). The advisory is shared at vupen.com. This vulnerability is uniquely identified as CVE-2010-0209. It is possible to initiate the attack remotely. No form of authentication is needed for exploitation. Neither technical details nor an exploit are publicly available. The price for an exploit might be around USD $0-$5k at the moment (estimation calculated on 09/22/2021). It is expected to see the exploit prices for this product decreasing in the near future.MITRE ATT&CK project uses the attack technique T1059 for this issue.

The vulnerability scanner Nessus provides a plugin with the ID 75418 (openSUSE Security Update : acroread (openSUSE-SU-2010:0573-1)), which helps to determine the existence of the flaw in a target environment. It is assigned to the family SuSE Local Security Checks. The commercial vulnerability scanner Qualys is able to test this issue with plugin 165602 (SUSE Enterprise Linux Security Update flash-player (SUSE-SA:2010:034)).

Upgrading to version 9.0.114.0 eliminates this vulnerability.

The vulnerability is also documented in the vulnerability database at Tenable (75418).

Productinfo

Type

Vendor

Name

Version

License

Support

CPE 2.3info

CPE 2.2info

CVSSv4info

VulDB CVSS-B Score: 🔍
VulDB CVSS-BT Score: 🔍
VulDB Vector: 🔍
VulDB Reliability: 🔍

CVSSv3info

VulDB Meta Base Score: 10.0
VulDB Meta Temp Score: 9.5

VulDB Base Score: 10.0
VulDB Temp Score: 9.5
VulDB Vector: 🔍
VulDB Reliability: 🔍

CVSSv2info

AVACAuCIA
💳💳💳💳💳💳
💳💳💳💳💳💳
💳💳💳💳💳💳
VectorComplexityAuthenticationConfidentialityIntegrityAvailability
unlockunlockunlockunlockunlockunlock
unlockunlockunlockunlockunlockunlock
unlockunlockunlockunlockunlockunlock

VulDB Base Score: 🔍
VulDB Temp Score: 🔍
VulDB Reliability: 🔍

NVD Base Score: 🔍

Exploitinginfo

Class: Code injection
CWE: CWE-94 / CWE-74 / CWE-707
CAPEC: 🔍
ATT&CK: 🔍

Local: No
Remote: Yes

Availability: 🔍
Status: Not defined

EPSS Score: 🔍
EPSS Percentile: 🔍

Price Prediction: 🔍
Current Price Estimation: 🔍

0-Dayunlockunlockunlockunlock
Todayunlockunlockunlockunlock

Nessus ID: 75418
Nessus Name: openSUSE Security Update : acroread (openSUSE-SU-2010:0573-1)
Nessus File: 🔍
Nessus Risk: 🔍
Nessus Family: 🔍
Nessus Port: 🔍

OpenVAS ID: 67863
OpenVAS Name: FreeBSD Ports: linux-flashplugin
OpenVAS File: 🔍
OpenVAS Family: 🔍

Qualys ID: 🔍
Qualys Name: 🔍

Threat Intelligenceinfo

Interest: 🔍
Active Actors: 🔍
Active APT Groups: 🔍

Countermeasuresinfo

Recommended: Upgrade
Status: 🔍

0-Day Time: 🔍

Upgrade: Flash Player 9.0.114.0
McAfee IPS: 🔍
McAfee IPS Version: 🔍

PaloAlto IPS: 🔍

Timelineinfo

01/06/2010 🔍
08/10/2010 +216 days 🔍
08/11/2010 +1 days 🔍
08/11/2010 +0 days 🔍
08/11/2010 +0 days 🔍
08/15/2010 +4 days 🔍
06/13/2014 +1398 days 🔍
03/19/2015 +279 days 🔍
09/22/2021 +2378 days 🔍

Sourcesinfo

Vendor: adobe.com

Advisory: vupen.com
Status: Not defined
Confirmation: 🔍

CVE: CVE-2010-0209 (🔍)
OVAL: 🔍

Vulnerability Center: 26793 - [APSB10-16] Adobe Flash Player and AIR AVM1 Remote Code Execution or DoS due to Memory Corruption Vulnerability, Critical
SecurityFocus: 42358 - Adobe Flash Player and AIR (CVE-2010-2214) Unspecified Memory Corruption Vulnerability
Secunia: 43026

Entryinfo

Created: 03/19/2015 02:37 PM
Updated: 09/22/2021 01:37 AM
Changes: 03/19/2015 02:37 PM (64), 03/02/2017 11:28 AM (10), 09/22/2021 01:29 AM (5), 09/22/2021 01:37 AM (1)
Complete: 🔍
Cache ID: 3:9D6:40

Discussion

No comments yet. Languages: en.

Please log in to comment.

Do you want to use VulDB in your project?

Use the official API to access entries easily!