Mozilla Firefox up to 12.0 memory corruption

CVSS Meta Temp Score
CVSS is a standardized scoring system to determine possibilities of attacks. The Temp Score considers temporal factors like disclosure, exploit and countermeasures. The unique Meta Score calculates the average score of different sources to provide a normalized scoring system.
Current Exploit Price (≈)
Our analysts are monitoring exploit markets and are in contact with vulnerability brokers. The range indicates the observed or calculated exploit price to be seen on exploit markets. A good indicator to understand the monetary effort required for and the popularity of an attack.
CTI Interest Score
Our Cyber Threat Intelligence team is monitoring different web sites, mailing lists, exploit markets and social media networks. The CTI Interest Score identifies the interest of attackers and the security community for this specific vulnerability in real-time. A high score indicates an elevated risk to be targeted for this vulnerability.
9.2$0-$5k0.00

A vulnerability, which was classified as very critical, was found in Mozilla Firefox (Web Browser). This affects an unknown code block. The manipulation with an unknown input leads to a memory corruption vulnerability. CWE is classifying the issue as CWE-119. The product performs operations on a memory buffer, but it can read from or write to a memory location that is outside of the intended boundary of the buffer. This is going to have an impact on confidentiality, integrity, and availability. The summary by CVE is:

Multiple unspecified vulnerabilities in the browser engine in Mozilla Firefox 4.x through 12.0, Firefox ESR 10.x before 10.0.5, Thunderbird 5.0 through 12.0, Thunderbird ESR 10.x before 10.0.5, and SeaMonkey before 2.10 allow remote attackers to cause a denial of service (memory corruption and application crash) or possibly execute arbitrary code via unknown vectors.

The weakness was presented 06/05/2012 by I. Bukanov, O. Pettav, B. Zbarsky and J. Ruderman (rshaw) as 2012-34 as confirmed knowledge base article (Website). The advisory is shared at mozilla.org. The public release was coordinated in cooperation with Mozilla. This vulnerability is uniquely identified as CVE-2012-1937 since 03/30/2012. It is possible to initiate the attack remotely. No form of authentication is needed for exploitation. It demands that the victim is doing some kind of user interaction. Neither technical details nor an exploit are publicly available. The price for an exploit might be around USD $0-$5k at the moment (estimation calculated on 03/25/2021).

The vulnerability scanner Nessus provides a plugin with the ID 59777 (Debian DSA-2499-1 : icedove - several vulnerabilities), which helps to determine the existence of the flaw in a target environment. It is assigned to the family Debian Local Security Checks and running in the context l. The commercial vulnerability scanner Qualys is able to test this issue with plugin 120275 (Red Hat Update for Xulrunner Firefox (RHSA-2012:0710)).

Upgrading to version 13.0 eliminates this vulnerability. A possible mitigation has been published immediately after the disclosure of the vulnerability.

The vulnerability is also documented in the vulnerability database at Tenable (59777).

Productinfo

Type

Vendor

Name

Version

License

CPE 2.3info

CPE 2.2info

CVSSv4info

VulDB CVSS-B Score: 🔍
VulDB CVSS-BT Score: 🔍
VulDB Vector: 🔍
VulDB Reliability: 🔍

CVSSv3info

VulDB Meta Base Score: 9.6
VulDB Meta Temp Score: 9.2

VulDB Base Score: 9.6
VulDB Temp Score: 9.2
VulDB Vector: 🔍
VulDB Reliability: 🔍

CVSSv2info

AVACAuCIA
💳💳💳💳💳💳
💳💳💳💳💳💳
💳💳💳💳💳💳
VectorComplexityAuthenticationConfidentialityIntegrityAvailability
unlockunlockunlockunlockunlockunlock
unlockunlockunlockunlockunlockunlock
unlockunlockunlockunlockunlockunlock

VulDB Base Score: 🔍
VulDB Temp Score: 🔍
VulDB Reliability: 🔍

NVD Base Score: 🔍

Exploitinginfo

Class: Memory corruption
CWE: CWE-119
CAPEC: 🔍
ATT&CK: 🔍

Local: No
Remote: Yes

Availability: 🔍
Status: Not defined

EPSS Score: 🔍
EPSS Percentile: 🔍

Price Prediction: 🔍
Current Price Estimation: 🔍

0-Dayunlockunlockunlockunlock
Todayunlockunlockunlockunlock

Nessus ID: 59777
Nessus Name: Debian DSA-2499-1 : icedove - several vulnerabilities
Nessus File: 🔍
Nessus Risk: 🔍
Nessus Family: 🔍
Nessus Context: 🔍
Nessus Port: 🔍

OpenVAS ID: 71468
OpenVAS Name: Debian Security Advisory DSA 2488-1 (iceweasel)
OpenVAS File: 🔍
OpenVAS Family: 🔍

Qualys ID: 🔍
Qualys Name: 🔍

Threat Intelligenceinfo

Interest: 🔍
Active Actors: 🔍
Active APT Groups: 🔍

Countermeasuresinfo

Recommended: Upgrade
Status: 🔍

Reaction Time: 🔍
0-Day Time: 🔍
Exposure Time: 🔍

Upgrade: Firefox 13.0

Timelineinfo

03/30/2012 🔍
06/05/2012 +67 days 🔍
06/05/2012 +0 days 🔍
06/05/2012 +0 days 🔍
06/05/2012 +0 days 🔍
06/05/2012 +0 days 🔍
06/06/2012 +1 days 🔍
06/06/2012 +0 days 🔍
06/06/2012 +0 days 🔍
06/06/2012 +0 days 🔍
06/08/2012 +2 days 🔍
06/29/2012 +21 days 🔍
03/25/2021 +3191 days 🔍

Sourcesinfo

Vendor: mozilla.org
Product: mozilla.org

Advisory: 2012-34
Researcher: I. Bukanov, O. Pettav, B. Zbarsky, J. Ruderman (rshaw)
Status: Confirmed
Confirmation: 🔍
Coordinated: 🔍

CVE: CVE-2012-1937 (🔍)
OVAL: 🔍

SecurityTracker: 1027120 - Mozilla Firefox Multiple Bugs Let Remote Users Execute Arbitrary Code
Vulnerability Center: 35267 - Mozilla Browsers Memory Corruption Vulnerability Allows Remote Code Execution \\ DoS - CVE-2012-1937, Medium
SecurityFocus: 53800 - Mozilla Firefox/Thunderbird/SeaMonkey CVE-2012-1937 Memory Corruption Vulnerability
Secunia: 49366 - Mozilla Firefox / Thunderbird / SeaMonkey Multiple Vulnerabilities, Highly Critical
OSVDB: 82667

Entryinfo

Created: 06/08/2012 05:28 PM
Updated: 03/25/2021 09:52 AM
Changes: 06/08/2012 05:28 PM (79), 01/31/2018 09:52 AM (12), 03/25/2021 09:52 AM (2)
Complete: 🔍
Cache ID: 3:4B9:40

Discussion

No comments yet. Languages: en.

Please log in to comment.

Do you need the next level of professionalism?

Upgrade your account now!