VDB-5549 · CVE-2012-1722 · BID 53953

Oracle Java SE JRE up to 7 Update 4 Deployment memory corruption

CVSS Meta Temp Score
CVSS is a standardized scoring system to determine possibilities of attacks. The Temp Score considers temporal factors like disclosure, exploit and countermeasures. The unique Meta Score calculates the average score of different sources to provide a normalized scoring system.
Current Exploit Price (≈)
Our analysts are monitoring exploit markets and are in contact with vulnerability brokers. The range indicates the observed or calculated exploit price to be seen on exploit markets. A good indicator to understand the monetary effort required for and the popularity of an attack.
CTI Interest Score
Our Cyber Threat Intelligence team is monitoring different web sites, mailing lists, exploit markets and social media networks. The CTI Interest Score identifies the interest of attackers and the security community for this specific vulnerability in real-time. A high score indicates an elevated risk to be targeted for this vulnerability.
9.0$0-$5k0.00

A vulnerability was found in Oracle Java SE JRE up to 7 Update 4 (Programming Language Software) and classified as very critical. This issue affects an unknown code block of the component Deployment. The manipulation with an unknown input leads to a memory corruption vulnerability. Using CWE to declare the problem leads to CWE-119. The product performs operations on a memory buffer, but it can read from or write to a memory location that is outside of the intended boundary of the buffer. Impacted is confidentiality, integrity, and availability. The summary by CVE is:

Unspecified vulnerability in the Java Runtime Environment (JRE) component in Oracle Java SE 7 update 4 and earlier, and 6 update 32 and earlier, allows remote attackers to affect confidentiality, integrity, and availability via unknown vectors related to Deployment, a different vulnerability than CVE-2012-1721.

The weakness was shared 06/12/2012 by Andrei Costin with Oracle as confirmed bulletin (Website). The advisory is shared at oracle.com. The vendor cooperated in the coordination of the public release. The identification of this vulnerability is CVE-2012-1722 since 03/16/2012. The attack may be initiated remotely. No form of authentication is needed for a successful exploitation. Technical details are unknown but a private exploit is available. The price for an exploit might be around USD $0-$5k at the moment (estimation calculated on 03/25/2021).

It is declared as proof-of-concept. The vulnerability scanner Nessus provides a plugin with the ID 72139 (GLSA-201401-30 : Oracle JRE/JDK: Multiple vulnerabilities), which helps to determine the existence of the flaw in a target environment. It is assigned to the family Gentoo Local Security Checks. The commercial vulnerability scanner Qualys is able to test this issue with plugin 119186 (HP-UX Running Java multiple Vulnerabilities (HPSBUX02805)).

Applying a patch is able to eliminate this problem. The bugfix is ready for download at oracle.com. A possible mitigation has been published immediately after the disclosure of the vulnerability.

The vulnerability is also documented in the vulnerability database at Tenable (72139). support.apple.com is providing further details. The entries 5127, 5539, 5540 and 5541 are related to this item.

Productinfo

Type

Vendor

Name

Version

License

CPE 2.3info

CPE 2.2info

CVSSv3info

VulDB Meta Base Score: 10.0
VulDB Meta Temp Score: 9.0

VulDB Base Score: 10.0
VulDB Temp Score: 9.0
VulDB Vector: 🔍
VulDB Reliability: 🔍

CVSSv2info

AVACAuCIA
💳💳💳💳💳💳
💳💳💳💳💳💳
💳💳💳💳💳💳
VectorComplexityAuthenticationConfidentialityIntegrityAvailability
unlockunlockunlockunlockunlockunlock
unlockunlockunlockunlockunlockunlock
unlockunlockunlockunlockunlockunlock

VulDB Base Score: 🔍
VulDB Temp Score: 🔍
VulDB Reliability: 🔍

NVD Base Score: 🔍

Exploitinginfo

Class: Memory corruption
CWE: CWE-119
ATT&CK: Unknown

Local: No
Remote: Yes

Availability: 🔍
Access: Private
Status: Proof-of-Concept

EPSS Score: 🔍
EPSS Percentile: 🔍

Price Prediction: 🔍
Current Price Estimation: 🔍

0-Dayunlockunlockunlockunlock
Todayunlockunlockunlockunlock

Nessus ID: 72139
Nessus Name: GLSA-201401-30 : Oracle JRE/JDK: Multiple vulnerabilities
Nessus File: 🔍
Nessus Risk: 🔍
Nessus Family: 🔍

OpenVAS ID: 802951
OpenVAS Name: Oracle Java SE Java Runtime Environment Multiple Unspecified Vulnerabilities(02) - (Windows)
OpenVAS File: 🔍
OpenVAS Family: 🔍

Qualys ID: 🔍
Qualys Name: 🔍

Threat Intelligenceinfo

Interest: 🔍
Active Actors: 🔍
Active APT Groups: 🔍

Countermeasuresinfo

Recommended: Patch
Status: 🔍

Reaction Time: 🔍
0-Day Time: 🔍
Exposure Time: 🔍

Patch: oracle.com

Timelineinfo

03/16/2012 🔍
06/12/2012 +88 days 🔍
06/12/2012 +0 days 🔍
06/12/2012 +0 days 🔍
06/12/2012 +0 days 🔍
06/13/2012 +1 days 🔍
06/13/2012 +0 days 🔍
06/14/2012 +1 days 🔍
06/16/2012 +2 days 🔍
06/16/2012 +0 days 🔍
06/18/2012 +2 days 🔍
03/25/2021 +3202 days 🔍

Sourcesinfo

Vendor: oracle.com

Advisory: oracle.com
Researcher: Andrei Costin
Organization: Oracle
Status: Confirmed
Confirmation: 🔍
Coordinated: 🔍

CVE: CVE-2012-1722 (🔍)
OVAL: 🔍
IAVM: 🔍

SecurityTracker: 1027153 - Oracle Java SE Multiple Flaws Let Remote Users Execute Arbitrary Code and Deny Service
Vulnerability Center: 35340 - [javacpujun2012-1515912] JRE Component in Oracle Java SE Remote Unspecified Vulnerability via Vectors Related to Deployment, Critical
SecurityFocus: 53953 - Oracle Java SE CVE-2012-1722 Remote Java Runtime Environment Vulnerability
Secunia: 49472 - Oracle Java Multiple Vulnerabilities, Highly Critical
OSVDB: 82876

scip Labs: https://www.scip.ch/en/?labs.20161013
Misc.: 🔍
See also: 🔍

Entryinfo

Created: 06/14/2012 02:35 PM
Updated: 03/25/2021 04:00 PM
Changes: 06/14/2012 02:35 PM (83), 04/19/2017 10:29 AM (12), 03/25/2021 04:00 PM (2)
Complete: 🔍

Discussion

No comments yet. Languages: en.

Please log in to comment.

Interested in the pricing of exploits?

See the underground prices here!