pango up to 1.28.3 pango/pangoft2-render.c pango_ft2_font_render_box_glyph memory corruption

CVSS Meta Temp Score
CVSS is a standardized scoring system to determine possibilities of attacks. The Temp Score considers temporal factors like disclosure, exploit and countermeasures. The unique Meta Score calculates the average score of different sources to provide a normalized scoring system.
Current Exploit Price (≈)
Our analysts are monitoring exploit markets and are in contact with vulnerability brokers. The range indicates the observed or calculated exploit price to be seen on exploit markets. A good indicator to understand the monetary effort required for and the popularity of an attack.
CTI Interest Score
Our Cyber Threat Intelligence team is monitoring different web sites, mailing lists, exploit markets and social media networks. The CTI Interest Score identifies the interest of attackers and the security community for this specific vulnerability in real-time. A high score indicates an elevated risk to be targeted for this vulnerability.
9.4$0-$5k0.00

A vulnerability has been found in pango and classified as very critical. This vulnerability affects the function pango_ft2_font_render_box_glyph of the file pango/pangoft2-render.c. The manipulation with an unknown input leads to a memory corruption vulnerability. The CWE definition for the vulnerability is CWE-119. The product performs operations on a memory buffer, but it can read from or write to a memory location that is outside of the intended boundary of the buffer. As an impact it is known to affect confidentiality, integrity, and availability. CVE summarizes:

Heap-based buffer overflow in the pango_ft2_font_render_box_glyph function in pango/pangoft2-render.c in libpango in Pango 1.28.3 and earlier, when the FreeType2 backend is enabled, allows user-assisted remote attackers to cause a denial of service (application crash) or possibly execute arbitrary code via a crafted font file, related to the glyph box for an FT_Bitmap object.

The weakness was presented 01/22/2011 by Dan Rosenberg as Bug 671122 as confirmed bug report (Bugzilla). The advisory is available at bugzilla.redhat.com. This vulnerability was named CVE-2011-0020 since 12/07/2010. The exploitation appears to be difficult. The attack can be initiated remotely. No form of authentication is required for a successful exploitation. Technical details and also a public exploit are known. The structure of the vulnerability defines a possible price range of USD $0-$5k at the moment (estimation calculated on 10/13/2021).

It is possible to download the exploit at securityfocus.com. It is declared as proof-of-concept. The vulnerability scanner Nessus provides a plugin with the ID 75599 (openSUSE Security Update : libpango-1_0-0 (openSUSE-SU-2011:0221-1)), which helps to determine the existence of the flaw in a target environment. It is assigned to the family SuSE Local Security Checks. The commercial vulnerability scanner Qualys is able to test this issue with plugin 155515 (Oracle Enterprise Linux Update for Pango (ELSA-2011-0180) (Deprecated)).

There is no information about possible countermeasures known. It may be suggested to replace the affected object with an alternative product.

The vulnerability is also documented in the databases at X-Force (64832) and Tenable (75599).

Productinfo

Name

Version

CPE 2.3info

CPE 2.2info

CVSSv4info

VulDB CVSS-B Score: 🔍
VulDB CVSS-BT Score: 🔍
VulDB Vector: 🔍
VulDB Reliability: 🔍

CVSSv3info

VulDB Meta Base Score: 10.0
VulDB Meta Temp Score: 9.4

VulDB Base Score: 10.0
VulDB Temp Score: 9.4
VulDB Vector: 🔍
VulDB Reliability: 🔍

CVSSv2info

AVACAuCIA
💳💳💳💳💳💳
💳💳💳💳💳💳
💳💳💳💳💳💳
VectorComplexityAuthenticationConfidentialityIntegrityAvailability
unlockunlockunlockunlockunlockunlock
unlockunlockunlockunlockunlockunlock
unlockunlockunlockunlockunlockunlock

VulDB Base Score: 🔍
VulDB Temp Score: 🔍
VulDB Reliability: 🔍

NVD Base Score: 🔍

Exploitinginfo

Class: Memory corruption
CWE: CWE-119
ATT&CK: Unknown

Local: No
Remote: Yes

Availability: 🔍
Access: Public
Status: Proof-of-Concept
Download: 🔍

EPSS Score: 🔍
EPSS Percentile: 🔍

Price Prediction: 🔍
Current Price Estimation: 🔍

0-Dayunlockunlockunlockunlock
Todayunlockunlockunlockunlock

Nessus ID: 75599
Nessus Name: openSUSE Security Update : libpango-1_0-0 (openSUSE-SU-2011:0221-1)
Nessus File: 🔍
Nessus Risk: 🔍
Nessus Family: 🔍
Nessus Port: 🔍

OpenVAS ID: 880472
OpenVAS Name: CentOS Update for evolution28-pango CESA-2011:0180 centos4 i386
OpenVAS File: 🔍
OpenVAS Family: 🔍

Qualys ID: 🔍
Qualys Name: 🔍

Threat Intelligenceinfo

Interest: 🔍
Active Actors: 🔍
Active APT Groups: 🔍

Countermeasuresinfo

Recommended: no mitigation known
Status: 🔍

0-Day Time: 🔍

Timelineinfo

12/07/2010 🔍
01/18/2011 +42 days 🔍
01/18/2011 +0 days 🔍
01/19/2011 +1 days 🔍
01/22/2011 +2 days 🔍
01/22/2011 +0 days 🔍
01/24/2011 +2 days 🔍
01/27/2011 +3 days 🔍
01/30/2011 +3 days 🔍
06/13/2014 +1230 days 🔍
03/19/2015 +279 days 🔍
10/13/2021 +2400 days 🔍

Sourcesinfo

Advisory: Bug 671122
Researcher: Dan Rosenberg
Status: Confirmed
Confirmation: 🔍

CVE: CVE-2011-0020 (🔍)
OVAL: 🔍

X-Force: 64832
SecurityTracker: 1024994 - Pango Heap Overflow in pango_ft2_font_render_box_glyph() Lets Remote Users Execute Arbitrary Code
Vulnerability Center: 29389 - Pango 1.28.3 and Earlier Remote Denial of Service or Arbitrary Code Execution Vulnerability, Medium
SecurityFocus: 45842 - Pango Font Parsing 'pangoft2-render.c' Heap Corruption Vulnerability
Secunia: 42934 - Pango "pango_ft2_font_render_box_glyph()" Buffer Overflow Vulnerability, Moderately Critical
OSVDB: 70596 - Pango pango/pangoft2-render.c pango_ft2_font_render_box_glyph() Function Overflow DoS
Vupen: ADV-2011-0186

scip Labs: https://www.scip.ch/en/?labs.20161013

Entryinfo

Created: 03/19/2015 11:27 PM
Updated: 10/13/2021 07:24 AM
Changes: 03/19/2015 11:27 PM (68), 08/20/2017 10:06 PM (22), 10/13/2021 07:24 AM (2)
Complete: 🔍

Discussion

No comments yet. Languages: en.

Please log in to comment.

Do you want to use VulDB in your project?

Use the official API to access entries easily!