PNP4Nagios up to 0.6.21 cross site scripting

CVSS Meta Temp Score
CVSS is a standardized scoring system to determine possibilities of attacks. The Temp Score considers temporal factors like disclosure, exploit and countermeasures. The unique Meta Score calculates the average score of different sources to provide a normalized scoring system.
Current Exploit Price (≈)
Our analysts are monitoring exploit markets and are in contact with vulnerability brokers. The range indicates the observed or calculated exploit price to be seen on exploit markets. A good indicator to understand the monetary effort required for and the popularity of an attack.
CTI Interest Score
Our Cyber Threat Intelligence team is monitoring different web sites, mailing lists, exploit markets and social media networks. The CTI Interest Score identifies the interest of attackers and the security community for this specific vulnerability in real-time. A high score indicates an elevated risk to be targeted for this vulnerability.
4.1$0-$5k0.00

A vulnerability was found in PNP4Nagios (Log Management Software). It has been declared as problematic. Affected by this vulnerability is an unknown code. The manipulation with an unknown input leads to a cross site scripting vulnerability. The CWE definition for the vulnerability is CWE-79. The product does not neutralize or incorrectly neutralizes user-controllable input before it is placed in output that is used as a web page that is served to other users. As an impact it is known to affect integrity. The summary by CVE is:

Cross-site scripting (XSS) vulnerability in share/pnp/application/views/kohana_error_page.php in PNP4Nagios before 0.6.22 allows remote attackers to inject arbitrary web script or HTML via a parameter that is not properly handled in an error message.

The weakness was presented 07/11/2014 (Website). The advisory is shared at sourceforge.net. This vulnerability is known as CVE-2014-4907 since 07/11/2014. The attack can be launched remotely. The exploitation doesn't need any form of authentication. It demands that the victim is doing some kind of user interaction. Neither technical details nor an exploit are publicly available. MITRE ATT&CK project uses the attack technique T1059.007 for this issue.

The vulnerability scanner Nessus provides a plugin with the ID 76485 (Fedora 20 : pnp4nagios-0.6.22-2.fc20 (2014-8098)), which helps to determine the existence of the flaw in a target environment. It is assigned to the family Fedora Local Security Checks. The commercial vulnerability scanner Qualys is able to test this issue with plugin 122358 (Fedora Security Update for pnp4nagios (FEDORA-2014-8098)).

Upgrading to version 0.6.6 eliminates this vulnerability.

The vulnerability is also documented in the databases at Tenable (76485), SecurityFocus (BID 68350†), Secunia (SA59603†) and Vulnerability Center (SBV-45507†). See VDB-70334 for similar entry.

Productinfo

Type

Name

Version

CPE 2.3info

CPE 2.2info

CVSSv4info

VulDB CVSS-B Score: 🔍
VulDB CVSS-BT Score: 🔍
VulDB Vector: 🔍
VulDB Reliability: 🔍

CVSSv3info

VulDB Meta Base Score: 4.3
VulDB Meta Temp Score: 4.1

VulDB Base Score: 4.3
VulDB Temp Score: 4.1
VulDB Vector: 🔍
VulDB Reliability: 🔍

CVSSv2info

AVACAuCIA
💳💳💳💳💳💳
💳💳💳💳💳💳
💳💳💳💳💳💳
VectorComplexityAuthenticationConfidentialityIntegrityAvailability
unlockunlockunlockunlockunlockunlock
unlockunlockunlockunlockunlockunlock
unlockunlockunlockunlockunlockunlock

VulDB Base Score: 🔍
VulDB Temp Score: 🔍
VulDB Reliability: 🔍

NVD Base Score: 🔍

Exploitinginfo

Class: Cross site scripting
CWE: CWE-79 / CWE-74 / CWE-707
CAPEC: 🔍
ATT&CK: 🔍

Local: No
Remote: Yes

Availability: 🔍
Status: Not defined

EPSS Score: 🔍
EPSS Percentile: 🔍

Price Prediction: 🔍
Current Price Estimation: 🔍

0-Dayunlockunlockunlockunlock
Todayunlockunlockunlockunlock

Nessus ID: 76485
Nessus Name: Fedora 20 : pnp4nagios-0.6.22-2.fc20 (2014-8098)
Nessus File: 🔍
Nessus Risk: 🔍
Nessus Family: 🔍
Nessus Port: 🔍

OpenVAS ID: 867773
OpenVAS Name: Fedora Update for pnp4nagios FEDORA-2014-8107
OpenVAS File: 🔍
OpenVAS Family: 🔍

Qualys ID: 🔍
Qualys Name: 🔍

Threat Intelligenceinfo

Interest: 🔍
Active Actors: 🔍
Active APT Groups: 🔍

Countermeasuresinfo

Recommended: Upgrade
Status: 🔍

0-Day Time: 🔍

Upgrade: PNP4Nagios 0.6.6
Patch: sourceforge.net

Timelineinfo

07/02/2014 🔍
07/02/2014 +0 days 🔍
07/02/2014 +0 days 🔍
07/11/2014 +9 days 🔍
07/11/2014 +0 days 🔍
07/11/2014 +0 days 🔍
07/14/2014 +3 days 🔍
07/17/2014 +3 days 🔍
03/26/2015 +252 days 🔍
03/24/2022 +2555 days 🔍

Sourcesinfo

Advisory: f846a6c9
Status: Not defined
Confirmation: 🔍

CVE: CVE-2014-4907 (🔍)
SecurityFocus: 68350 - PNP4Nagios 'kohana_error_page.php' Cross Site Scripting Vulnerability
Secunia: 59603 - PNP4Nagios Error Page Cross-Site Scripting Vulnerability, Less Critical
Vulnerability Center: 45507 - PNP4Nagios Before 0.6.22 Remote XSS due to an Error in the kohana_error_page.php Page, Medium

See also: 🔍

Entryinfo

Created: 03/26/2015 12:07 PM
Updated: 03/24/2022 04:53 PM
Changes: 03/26/2015 12:07 PM (65), 06/02/2017 07:57 AM (10), 03/24/2022 04:45 PM (4), 03/24/2022 04:53 PM (1)
Complete: 🔍
Cache ID: 44:442:40

Discussion

No comments yet. Languages: en.

Please log in to comment.

Do you want to use VulDB in your project?

Use the official API to access entries easily!