Apple iOS 8.1.2 iCloud Keychain Recovery memory corruption

CVSS Meta Temp Score
CVSS is a standardized scoring system to determine possibilities of attacks. The Temp Score considers temporal factors like disclosure, exploit and countermeasures. The unique Meta Score calculates the average score of different sources to provide a normalized scoring system.
Current Exploit Price (≈)
Our analysts are monitoring exploit markets and are in contact with vulnerability brokers. The range indicates the observed or calculated exploit price to be seen on exploit markets. A good indicator to understand the monetary effort required for and the popularity of an attack.
CTI Interest Score
Our Cyber Threat Intelligence team is monitoring different web sites, mailing lists, exploit markets and social media networks. The CTI Interest Score identifies the interest of attackers and the security community for this specific vulnerability in real-time. A high score indicates an elevated risk to be targeted for this vulnerability.
6.4$5k-$25k0.00

A vulnerability was found in Apple iOS 8.1.2 (Smartphone Operating System). It has been rated as critical. Affected by this issue is an unknown code block of the component iCloud Keychain Recovery. The manipulation with an unknown input leads to a memory corruption vulnerability. Using CWE to declare the problem leads to CWE-119. The product performs operations on a memory buffer, but it can read from or write to a memory location that is outside of the intended boundary of the buffer. Impacted is confidentiality, integrity, and availability. CVE summarizes:

Multiple buffer overflows in iCloud Keychain in Apple iOS before 8.2 and Apple OS X through 10.10.2 allow man-in-the-middle attackers to execute arbitrary code by modifying the client-server data stream during keychain recovery.

The weakness was presented 03/09/2015 by Andrey Belenko with NowSecure as HT204423 as confirmed advisory (Website). The advisory is shared for download at support.apple.com. The public release was coordinated in cooperation with the vendor. This vulnerability is handled as CVE-2015-1065 since 01/16/2015. The attack may be launched remotely. No form of authentication is required for exploitation. There are neither technical details nor an exploit publicly available. The current price for an exploit might be approx. USD $0-$5k (estimation calculated on 04/15/2022). It is expected to see the exploit prices for this product increasing in the near future.

The vulnerability scanner Nessus provides a plugin with the ID 81730 (Mac OS X Multiple Vulnerabilities (Security Update 2015-002)), which helps to determine the existence of the flaw in a target environment. It is assigned to the family MacOS X Local Security Checks. The commercial vulnerability scanner Qualys is able to test this issue with plugin 123362 (Apple Mac OS X Security Update 2015-002 Not Installed (APPLE-SA-2015-03-09-3) (FREAK)).

Upgrading to version 8.2 eliminates this vulnerability. A possible mitigation has been published immediately after the disclosure of the vulnerability.

The vulnerability is also documented in the databases at X-Force (101489) and Tenable (81730).

Productinfo

Type

Vendor

Name

Version

License

CPE 2.3info

CPE 2.2info

CVSSv4info

VulDB CVSS-B Score: 🔍
VulDB CVSS-BT Score: 🔍
VulDB Vector: 🔍
VulDB Reliability: 🔍

CVSSv3info

VulDB Meta Base Score: 7.3
VulDB Meta Temp Score: 6.4

VulDB Base Score: 7.3
VulDB Temp Score: 6.4
VulDB Vector: 🔍
VulDB Reliability: 🔍

CVSSv2info

AVACAuCIA
💳💳💳💳💳💳
💳💳💳💳💳💳
💳💳💳💳💳💳
VectorComplexityAuthenticationConfidentialityIntegrityAvailability
unlockunlockunlockunlockunlockunlock
unlockunlockunlockunlockunlockunlock
unlockunlockunlockunlockunlockunlock

VulDB Base Score: 🔍
VulDB Temp Score: 🔍
VulDB Reliability: 🔍

NVD Base Score: 🔍

Exploitinginfo

Class: Memory corruption
CWE: CWE-119
CAPEC: 🔍
ATT&CK: 🔍

Local: No
Remote: Yes

Availability: 🔍
Status: Unproven

EPSS Score: 🔍
EPSS Percentile: 🔍

Price Prediction: 🔍
Current Price Estimation: 🔍

0-Dayunlockunlockunlockunlock
Todayunlockunlockunlockunlock

Nessus ID: 81730
Nessus Name: Mac OS X Multiple Vulnerabilities (Security Update 2015-002)
Nessus File: 🔍
Nessus Risk: 🔍
Nessus Family: 🔍

Qualys ID: 🔍
Qualys Name: 🔍

Threat Intelligenceinfo

Interest: 🔍
Active Actors: 🔍
Active APT Groups: 🔍

Countermeasuresinfo

Recommended: Upgrade
Status: 🔍

Reaction Time: 🔍
0-Day Time: 🔍
Exposure Time: 🔍

Upgrade: iOS 8.2

Timelineinfo

01/16/2015 🔍
03/09/2015 +52 days 🔍
03/09/2015 +0 days 🔍
03/09/2015 +0 days 🔍
03/09/2015 +0 days 🔍
03/10/2015 +1 days 🔍
03/12/2015 +2 days 🔍
03/12/2015 +0 days 🔍
04/15/2022 +2591 days 🔍

Sourcesinfo

Vendor: apple.com

Advisory: HT204423
Researcher: Andrey Belenko
Organization: NowSecure
Status: Confirmed
Confirmation: 🔍
Coordinated: 🔍

CVE: CVE-2015-1065 (🔍)
X-Force: 101489 - Apple iOS iCloud Keychain recovery buffer overflow
SecurityTracker: 1031864
Vulnerability Center: 48933 - Apple MacOS X 10.10 - 10.10.2 Remote Code Execution due to Multiple Buffer Overflows, Medium
SecurityFocus: 73007 - Apple Mac OS X and iOS CVE-2015-1065 Multiple Buffer Overflow Vulnerabilities

scip Labs: https://www.scip.ch/en/?labs.20150917

Entryinfo

Created: 03/12/2015 09:44 AM
Updated: 04/15/2022 11:09 AM
Changes: 03/12/2015 09:44 AM (75), 06/22/2017 10:33 AM (3), 04/15/2022 11:03 AM (3), 04/15/2022 11:09 AM (1)
Complete: 🔍
Cache ID: 100:712:40

Discussion

No comments yet. Languages: en.

Please log in to comment.

Might our Artificial Intelligence support you?

Check our Alexa App!