Cisco IOS XE up to 3.15.0 High-Speed Logging input validation

CVSS Meta Temp Score
CVSS is a standardized scoring system to determine possibilities of attacks. The Temp Score considers temporal factors like disclosure, exploit and countermeasures. The unique Meta Score calculates the average score of different sources to provide a normalized scoring system.
Current Exploit Price (≈)
Our analysts are monitoring exploit markets and are in contact with vulnerability brokers. The range indicates the observed or calculated exploit price to be seen on exploit markets. A good indicator to understand the monetary effort required for and the popularity of an attack.
CTI Interest Score
Our Cyber Threat Intelligence team is monitoring different web sites, mailing lists, exploit markets and social media networks. The CTI Interest Score identifies the interest of attackers and the security community for this specific vulnerability in real-time. A high score indicates an elevated risk to be targeted for this vulnerability.
6.5$0-$5k0.00

A vulnerability, which was classified as critical, was found in Cisco IOS XE up to 3.15.0 (Router Operating System). This affects an unknown function of the component High-Speed Logging. The manipulation with an unknown input leads to a input validation vulnerability. CWE is classifying the issue as CWE-20. The product receives input or data, but it does not validate or incorrectly validates that the input has the properties that are required to process the data safely and correctly. This is going to have an impact on availability.

The weakness was shared 03/25/2015 with Cisco as cisco-sa-20150325-iosxe as confirmed advisory (Website). The advisory is shared at tools.cisco.com. This vulnerability is uniquely identified as CVE-2015-0640 since 01/07/2015. The exploitability is told to be easy. It is possible to initiate the attack remotely. No form of authentication is needed for exploitation. Neither technical details nor an exploit are publicly available.

The vulnerability scanner Nessus provides a plugin with the ID 82588 , which helps to determine the existence of the flaw in a target environment. It is .

Upgrading eliminates this vulnerability.

The vulnerability is also documented in the databases at X-Force (101796) and Tenable (82588). The entries 74108, 74110, 74111 and 74112 are related to this item.

Productinfo

Type

Vendor

Name

License

  • commercial

Support

  • end of life (version)

CPE 2.3info

CPE 2.2info

CVSSv3info

VulDB Meta Base Score: 7.5
VulDB Meta Temp Score: 6.5

VulDB Base Score: 7.5
VulDB Temp Score: 6.5
VulDB Vector: 🔍
VulDB Reliability: 🔍

CVSSv2info

AVACAuCIA
💳💳💳💳💳💳
💳💳💳💳💳💳
💳💳💳💳💳💳
VectorComplexityAuthenticationConfidentialityIntegrityAvailability
unlockunlockunlockunlockunlockunlock
unlockunlockunlockunlockunlockunlock
unlockunlockunlockunlockunlockunlock

VulDB Base Score: 🔍
VulDB Temp Score: 🔍
VulDB Reliability: 🔍

NVD Base Score: 🔍

Exploitinginfo

Class: Input validation
CWE: CWE-20
ATT&CK: Unknown

Local: No
Remote: Yes

Availability: 🔍
Status: Unproven

EPSS Score: 🔍
EPSS Percentile: 🔍

Price Prediction: 🔍
Current Price Estimation: 🔍

0-Dayunlockunlockunlockunlock
Todayunlockunlockunlockunlock

Nessus ID: 82588
Nessus File: 🔍
Nessus Risk: 🔍
Nessus Port: 🔍

Threat Intelligenceinfo

Interest: 🔍
Active Actors: 🔍
Active APT Groups: 🔍

Countermeasuresinfo

Recommended: Upgrade
Status: 🔍

0-Day Time: 🔍

Timelineinfo

01/07/2015 🔍
03/25/2015 +77 days 🔍
03/25/2015 +0 days 🔍
03/25/2015 +0 days 🔍
03/25/2015 +0 days 🔍
03/26/2015 +1 days 🔍
03/26/2015 +0 days 🔍
03/26/2015 +0 days 🔍
04/06/2015 +11 days 🔍
04/16/2022 +2567 days 🔍

Sourcesinfo

Vendor: cisco.com

Advisory: cisco-sa-20150325-iosxe
Organization: Cisco
Status: Confirmed

CVE: CVE-2015-0640 (🔍)
X-Force: 101796 - Cisco IOS XE high-speed logging functionality denial of service
SecurityTracker: 1031981 - Cisco ASR Series IOS-XE Bugs Let Remote Users Deny Service and Execute Arbitrary Code
Vulnerability Center: 49220 - [cisco-sa-20150325-iosxe] Cisco IOS-XE Remote DoS via Crafted IP Packets - CVE-2015-0640, High
SecurityFocus: 73337 - Cisco IOS XE Software Multiple Denial of Service Vulnerabilities

scip Labs: https://www.scip.ch/en/?labs.20150108
See also: 🔍

Entryinfo

Created: 03/26/2015 08:50 AM
Updated: 04/16/2022 08:12 AM
Changes: 03/26/2015 08:50 AM (71), 06/23/2017 10:40 AM (3), 04/16/2022 08:10 AM (3), 04/16/2022 08:12 AM (1)
Complete: 🔍

Discussion

No comments yet. Languages: en.

Please log in to comment.

Want to stay up to date on a daily basis?

Enable the mail alert feature now!