Woothemes Woocommerce up to 2.2.9 wp-admin/admin.php cross site scripting

CVSS Meta Temp Score
CVSS is a standardized scoring system to determine possibilities of attacks. The Temp Score considers temporal factors like disclosure, exploit and countermeasures. The unique Meta Score calculates the average score of different sources to provide a normalized scoring system.
Current Exploit Price (≈)
Our analysts are monitoring exploit markets and are in contact with vulnerability brokers. The range indicates the observed or calculated exploit price to be seen on exploit markets. A good indicator to understand the monetary effort required for and the popularity of an attack.
CTI Interest Score
Our Cyber Threat Intelligence team is monitoring different web sites, mailing lists, exploit markets and social media networks. The CTI Interest Score identifies the interest of attackers and the security community for this specific vulnerability in real-time. A high score indicates an elevated risk to be targeted for this vulnerability.

A vulnerability, which was classified as problematic, has been found in Woothemes Woocommerce up to 2.2.9 (E-Commerce Management Software). This issue affects some unknown processing of the file wp-admin/admin.php. The manipulation with an unknown input leads to a cross site scripting vulnerability. Using CWE to declare the problem leads to CWE-79. The software does not neutralize or incorrectly neutralizes user-controllable input before it is placed in output that is used as a web page that is served to other users. Impacted is integrity. The summary by CVE is:

Cross-site scripting (XSS) vulnerability in the WooCommerce plugin before 2.2.11 for WordPress allows remote attackers to inject arbitrary web script or HTML via the QUERY_STRING in the wc-reports page to wp-admin/admin.php.

The weakness was disclosed 02/24/2015 by Eric Flokstra (Website). The advisory is shared at wordpress.org. The identification of this vulnerability is CVE-2015-2069 since 02/24/2015. The attack may be initiated remotely. No form of authentication is needed for a successful exploitation. It demands that the victim is doing some kind of user interaction. Technical details are known, but no exploit is available. MITRE ATT&CK project uses the attack technique T1059.007 for this issue.

By approaching the search of inurl:wp-admin/admin.php it is possible to find vulnerable targets with Google Hacking.

Upgrading to version 2.2.10 eliminates this vulnerability.

The entry 94919 is pretty similar.





CPE 2.3info

CPE 2.2info


VulDB Meta Base Score: 4.3
VulDB Meta Temp Score: 4.1

VulDB Base Score: 4.3
VulDB Temp Score: 4.1
VulDB Vector: 🔍
VulDB Reliability: 🔍



VulDB Base Score: 🔍
VulDB Temp Score: 🔍
VulDB Reliability: 🔍

NVD Base Score: 🔍


Class: Cross site scripting
CWE: CWE-79 / CWE-74 / CWE-707
ATT&CK: T1059.007

Local: No
Remote: Yes

Availability: 🔍
Status: Not defined
Google Hack: 🔍

EPSS Score: 🔍
EPSS Percentile: 🔍

Price Prediction: 🔍
Current Price Estimation: 🔍


Threat Intelligenceinfo

Interest: 🔍
Active Actors: 🔍
Active APT Groups: 🔍


Recommended: Upgrade
Status: 🔍

0-Day Time: 🔍

Upgrade: Woocommerce 2.2.10


02/24/2015 🔍
02/24/2015 +0 days 🔍
02/24/2015 +0 days 🔍
03/30/2015 +34 days 🔍
05/28/2015 +59 days 🔍
04/16/2022 +2515 days 🔍


Advisory: 130458
Researcher: Eric Flokstra
Status: Not defined
Confirmation: 🔍

CVE: CVE-2015-2069 (🔍)
SecurityFocus: 74885 - WordPress WooCommerce 'wp-admin/admin.php' Cross Site Scripting Vulnerability

See also: 🔍


Created: 03/30/2015 12:22 PM
Updated: 04/16/2022 08:33 PM
Changes: 03/30/2015 12:22 PM (46), 04/13/2018 11:50 AM (10), 04/16/2022 08:33 PM (3)
Complete: 🔍


No comments yet. Languages: en.

Please log in to comment.

Interested in the pricing of exploits?

See the underground prices here!