Fabrice Bellard QEMU AHCI Native Command Queue use after free

entryeditHistoryDiffjsonxmlCTI
CVSS Meta Temp Score
CVSS is a standardized scoring system to determine possibilities of attacks. The Temp Score considers temporal factors like disclosure, exploit and countermeasures. The unique Meta Score calculates the average score of different sources to provide a normalized scoring system.
Current Exploit Price (≈)
Our analysts are monitoring exploit markets and are in contact with vulnerability brokers. The range indicates the observed or calculated exploit price to be seen on exploit markets. A good indicator to understand the monetary effort required for and the popularity of an attack.
CTI Interest Score
Our Cyber Threat Intelligence team is monitoring different web sites, mailing lists, exploit markets and social media networks. The CTI Interest Score identifies the interest of attackers and the security community for this specific vulnerability in real-time. A high score indicates an elevated risk to be targeted for this vulnerability.
7.6$0-$5k0.00

A vulnerability has been found in Fabrice Bellard QEMU (Virtualization Software) (affected version unknown) and classified as critical. Affected by this vulnerability is some unknown functionality of the component AHCI Native Command Queue. The manipulation with an unknown input leads to a memory corruption vulnerability. The CWE definition for the vulnerability is CWE-416. As an impact it is known to affect confidentiality, integrity, and availability.

The weakness was released 01/28/2016 by Qinghao Tang as Bug 1288532 as confirmed bug report (Bugzilla). The advisory is shared at bugzilla.redhat.com. This vulnerability is known as CVE-2016-1568 since 01/09/2016. The exploitation appears to be easy. An attack has to be approached locally. The exploitation doesn't need any form of authentication. Neither technical details nor an exploit are publicly available. The price for an exploit might be around USD $0-$5k at the moment (estimation calculated on 08/23/2018).

The vulnerability scanner Nessus provides a plugin with the ID 88628 (Debian DSA-3469-1 : qemu - security update), which helps to determine the existence of the flaw in a target environment. It is assigned to the family Debian Local Security Checks and running in the context local. The commercial vulnerability scanner Qualys is able to test this issue with plugin 168962 (OpenSuSE Security Update for qemu (openSUSE-SU-2016:1750-1)).

Applying a patch is able to eliminate this problem. A possible mitigation has been published 2 weeks after the disclosure of the vulnerability.

The vulnerability is also documented in the databases at SecurityFocus (BID 80191), X-Force (110304), Vulnerability Center (SBV-56705) and Tenable (88628). Additional details are provided at lists.gnu.org. Entries connected to this vulnerability are available at 80762, 87595, 94714 and 94718.

Productinfoedit

Type

Vendor

Name

CPE 2.3infoedit

CPE 2.2infoedit

CVSSv3infoedit

VulDB Meta Base Score: 8.8
VulDB Meta Temp Score: 7.6

VulDB Base Score: 9.0
VulDB Temp Score: 7.8
VulDB Vector: 🔍
VulDB Reliability: 🔍

NVD Base Score: 8.5
NVD Vector: 🔍

CVSSv2infoedit

AVACAuCIA
🔍🔍🔍🔍🔍🔍
🔍🔍🔍🔍🔍🔍
🔍🔍🔍🔍🔍🔍
VectorComplexityAuthenticationConfidentialityIntegrityAvailability
unlockunlockunlockunlockunlockunlock
unlockunlockunlockunlockunlockunlock
unlockunlockunlockunlockunlockunlock

VulDB Base Score: 🔍
VulDB Temp Score: 🔍
VulDB Reliability: 🔍

NVD Base Score: 🔍

Exploitinginfoedit

Class: Memory corruption
CWE: CWE-416
ATT&CK: Unknown

Local: Yes
Remote: No

Availability: 🔍
Status: Unproven

Price Prediction: 🔍
Current Price Estimation: 🔍

0-Dayunlockunlockunlockunlock
Todayunlockunlockunlockunlock

Nessus ID: 88628
Nessus Name: Debian DSA-3469-1 : qemu - security update
Nessus File: 🔍
Nessus Risk: 🔍
Nessus Family: 🔍
Nessus Context: 🔍

OpenVAS ID: 867773
OpenVAS Name: Fedora Update for qemu FEDORA-2016-42778
OpenVAS File: 🔍
OpenVAS Family: 🔍

Qualys ID: 🔍
Qualys Name: 🔍

Threat Intelligenceinfoedit

Threat: 🔍
Adversaries: 🔍
Geopolitics: 🔍
Economy: 🔍
Predictions: 🔍
Remediation: 🔍

Countermeasuresinfoedit

Recommended: Patch
Status: 🔍

Reaction Time: 🔍
0-Day Time: 🔍
Exposure Time: 🔍

Timelineinfoedit

01/08/2016 🔍
01/08/2016 +0 days 🔍
01/09/2016 +0 days 🔍
01/28/2016 +19 days 🔍
02/02/2016 +5 days 🔍
02/07/2016 +5 days 🔍
02/08/2016 +1 days 🔍
02/21/2016 +13 days 🔍
04/11/2016 +49 days 🔍
06/20/2018 +800 days 🔍
08/23/2018 +64 days 🔍

Sourcesinfoedit

Vendor: https://bellard.org/

Advisory: Bug 1288532
Researcher: Qinghao Tang
Status: Confirmed
Confirmation: 🔍

CVE: CVE-2016-1568 (🔍)
SecurityFocus: 80191 - QEMU CVE-2016-1568 Remote Code Execution Vulnerability
X-Force: 110304 - QEMU AHCI Native Command Queuing privilege escalation
Vulnerability Center: 56705 - QEMU Remote Code Execution Vulnerability in IDE AHCI Emulation, Medium

Misc.: 🔍
See also: 🔍

Entryinfoedit

Created: 02/02/2016 09:55 AM
Updated: 08/23/2018 08:19 AM
Changes: (22) vulnerability_cwe vulnerability_cvss3_vuldb_av vulnerability_cvss3_vuldb_ac vulnerability_cvss3_vuldb_pr vulnerability_cvss3_vuldb_ui vulnerability_cvss3_vuldb_s vulnerability_cvss3_vuldb_c vulnerability_cvss3_vuldb_i vulnerability_cvss3_vuldb_a advisory_person_name advisory_confirm_url countermeasure_date source_cve_nvd_published source_securityfocus_date source_securityfocus_class source_nessus_name source_nessus_filename source_nessus_family source_openvas_id source_openvas_filename source_openvas_title source_openvas_family
Complete: 🔍

Comments

No comments yet. Please log in to comment.

Do you need the next level of professionalism?

Upgrade your account now!