Cisco ASA up to 8.4 Command Line Interface EpicBanana/JetPlow privileges management

CVSS Meta Temp Score
CVSS is a standardized scoring system to determine possibilities of attacks. The Temp Score considers temporal factors like disclosure, exploit and countermeasures. The unique Meta Score calculates the average score of different sources to provide a normalized scoring system.
Current Exploit Price (≈)
Our analysts are monitoring exploit markets and are in contact with vulnerability brokers. The range indicates the observed or calculated exploit price to be seen on exploit markets. A good indicator to understand the monetary effort required for and the popularity of an attack.
CTI Interest Score
Our Cyber Threat Intelligence team is monitoring different web sites, mailing lists, exploit markets and social media networks. The CTI Interest Score identifies the interest of attackers and the security community for this specific vulnerability in real-time. A high score indicates an elevated risk to be targeted for this vulnerability.
7.0$0-$5k0.05

A vulnerability has been found in Cisco ASA up to 8.4 (Firewall Software) and classified as critical. This vulnerability affects an unknown function of the component Command Line Interface. The manipulation with an unknown input leads to a privilege escalation vulnerability (EpicBanana/JetPlow). The CWE definition for the vulnerability is CWE-269. As an impact it is known to affect confidentiality, integrity, and availability. CVE summarizes:

Cisco Adaptive Security Appliance (ASA) Software before 8.4(1) on ASA 5500, ASA 5500-X, PIX, and FWSM devices allows local users to gain privileges via invalid CLI commands, aka Bug ID CSCtu74257 or EPICBANANA.

The weakness was disclosed 08/17/2016 with Shadow Brokers as cisco-sa-20160817-asa-cli / CSCtu74257 as confirmed advisory (Website). The advisory is shared for download at tools.cisco.com. The advisory contains:

On August 15, 2016, Cisco was alerted to information posted online by the Shadow Brokers group, which claimed to possess disclosures from the Equation Group. The posted materials included exploits for firewall products from multiple vendors. The Cisco products mentioned were the PIX and ASA firewalls.
This vulnerability was named CVE-2016-6367. The exploitation appears to be easy. The attack needs to be approached locally. The successful exploitation requires a single authentication. Technical details are unknown but a public exploit is available. The current price for an exploit might be approx. USD $0-$5k (estimation calculated on 07/14/2017). This vulnerability has a historic impact due to its background and reception.

It is declared as proof-of-concept. It is possible to download the exploit at exploit-db.com. The vulnerability was handled as a non-public zero-day exploit for at least 2 days. During that time the estimated underground price was around $25k-$100k. The vulnerability scanner Nessus provides a plugin with the ID 93347 (Cisco ASA Software CLI Invalid Command Invocation (cisco-sa-20160817-asa-cli) (EPICBANANA)), which helps to determine the existence of the flaw in a target environment. It is assigned to the family CISCO.

Upgrading to version 8.4(1) eliminates this vulnerability.

The vulnerability is also documented in the databases at SecurityTracker (ID 1036636), Tenable (93347) and Exploit-DB (40271). The entries 90834 and 90833 are pretty similar.

Productinfoedit

Type

Vendor

Name

CPE 2.3infoedit

CPE 2.2infoedit

CVSSv3infoedit

VulDB Meta Base Score: 7.8
VulDB Meta Temp Score: 7.0

VulDB Base Score: 7.8
VulDB Temp Score: 7.0
VulDB Vector: 🔍
VulDB Reliability: 🔍

CVSSv2infoedit

AVACAuCIA
🔍🔍🔍🔍🔍🔍
🔍🔍🔍🔍🔍🔍
🔍🔍🔍🔍🔍🔍
VectorComplexityAuthenticationConfidentialityIntegrityAvailability
unlockunlockunlockunlockunlockunlock
unlockunlockunlockunlockunlockunlock
unlockunlockunlockunlockunlockunlock

VulDB Base Score: 🔍
VulDB Temp Score: 🔍
VulDB Reliability: 🔍

NVD Base Score: 🔍

Exploitinginfoedit

Name: EpicBanana/JetPlow
Class: Privilege escalation / EpicBanana/JetPlow
CWE: CWE-269
ATT&CK: Unknown

Local: Yes
Remote: No

Availability: 🔍
Access: Public
Status: Proof-of-Concept
Download: 🔍
Price Prediction: 🔍
Current Price Estimation: 🔍

0-Dayunlockunlockunlockunlock
Todayunlockunlockunlockunlock

Nessus ID: 93347
Nessus Name: Cisco ASA Software CLI Invalid Command Invocation (cisco-sa-20160817-asa-cli) (EPICBANANA)
Nessus File: 🔍
Nessus Family: 🔍

OpenVAS ID: 800316
OpenVAS Name: Cisco Adaptive Security Appliance CLI Remote Code Execution Vulnerability
OpenVAS File: 🔍
OpenVAS Family: 🔍

Exploit-DB: 🔍

Threat Intelligenceinfoedit

Interest: 🔍
Active Actors: 🔍
Active APT Groups: 🔍

Countermeasuresinfoedit

Recommended: Upgrade
Status: 🔍

0-Day Time: 🔍

Upgrade: ASA 8.4(1)

Timelineinfoedit

08/15/2016 🔍
08/17/2016 +2 days 🔍
08/17/2016 +0 days 🔍
08/18/2016 +1 days 🔍
08/18/2016 +0 days 🔍
07/14/2017 +330 days 🔍

Sourcesinfoedit

Vendor: https://www.cisco.com/

Advisory: cisco-sa-20160817-asa-cli / CSCtu74257
Organization: Shadow Brokers
Status: Confirmed

CVE: CVE-2016-6367 (🔍)
SecurityTracker: 1036636 - Cisco ASA Command Line Interface Bug Lets Local Users Deny Service and Gain Elevated Privileges

scip Labs: https://www.scip.ch/en/?labs.20161013
See also: 🔍

Entryinfoedit

Created: 08/18/2016 10:27 AM
Updated: 07/14/2017 10:09 AM
Changes: (20) software_type vulnerability_cwe vulnerability_cvss2_nvd_av vulnerability_cvss2_nvd_ac vulnerability_cvss2_nvd_au vulnerability_cvss2_nvd_ci vulnerability_cvss2_nvd_ii vulnerability_cvss2_nvd_ai source_cve_nvd_published source_cve_nvd_summary source_sectracker_date source_sectracker_title source_sectracker_cause source_nessus_name source_nessus_filename source_nessus_family source_openvas_id source_openvas_filename source_openvas_title source_openvas_family
Complete: 🔍

Comments

No comments yet. Languages: en.

Please log in to comment.

Interested in the pricing of exploits?

See the underground prices here!