Apple iTunes up to 12.5 on Windows Expat memory corruption

CVSS Meta Temp Score
CVSS is a standardized scoring system to determine possibilities of attacks. The Temp Score considers temporal factors like disclosure, exploit and countermeasures. The unique Meta Score calculates the average score of different sources to provide a normalized scoring system.
Current Exploit Price (≈)
Our analysts are monitoring exploit markets and are in contact with vulnerability brokers. The range indicates the observed or calculated exploit price to be seen on exploit markets. A good indicator to understand the monetary effort required for and the popularity of an attack.
CTI Interest Score
Our Cyber Threat Intelligence team is monitoring different web sites, mailing lists, exploit markets and social media networks. The CTI Interest Score identifies the interest of attackers and the security community for this specific vulnerability in real-time. A high score indicates an elevated risk to be targeted for this vulnerability.
4.8$0-$5k0.00

A vulnerability was found in Apple iTunes up to 12.5 on Windows (Multimedia Player Software). It has been classified as critical. This affects an unknown code of the component Expat. The manipulation with an unknown input leads to a memory corruption vulnerability. CWE is classifying the issue as CWE-119. The software performs operations on a memory buffer, but it can read from or write to a memory location that is outside of the intended boundary of the buffer. This is going to have an impact on availability.

The bug was discovered 11/08/2009. The weakness was presented 03/21/2017 as HT207599 as confirmed advisory (Website). The advisory is shared at support.apple.com. This vulnerability is uniquely identified as CVE-2009-3560 since 10/05/2009. The exploitability is told to be easy. It is possible to initiate the attack remotely. No form of authentication is needed for exploitation. Neither technical details nor an exploit are publicly available. The advisory points out:

Multiple issues existed in expat. These issues were addressed by updating expat to version 2.2.0.

It is declared as proof-of-concept. The vulnerability was handled as a non-public zero-day exploit for at least 26 days. During that time the estimated underground price was around $5k-$25k. The vulnerability scanner Nessus provides a plugin with the ID 44323 (Ubuntu 6.06 LTS : python-xml vulnerabilities (USN-890-4)), which helps to determine the existence of the flaw in a target environment. It is assigned to the family Ubuntu Local Security Checks and running in the context local. The commercial vulnerability scanner Qualys is able to test this issue with plugin 216004 (VMWare ESXi 4.1.0 Patch Release ESXi410-201201001 Missing (KB2009137)).

Upgrading to version 12.6 eliminates this vulnerability. A possible mitigation has been published immediately after the disclosure of the vulnerability.

The vulnerability is also documented in the databases at SecurityTracker (ID 1023278) and Tenable (44323). See 5322, 51038, 50685 and 53383 for similar entries.

Productinfo

Type

Vendor

Name

License

  • free

CPE 2.3info

CPE 2.2info

CVSSv3info

VulDB Meta Base Score: 5.3
VulDB Meta Temp Score: 4.8

VulDB Base Score: 5.3
VulDB Temp Score: 4.8
VulDB Vector: 🔍
VulDB Reliability: 🔍

CVSSv2info

AVACAuCIA
🔍🔍🔍🔍🔍🔍
🔍🔍🔍🔍🔍🔍
🔍🔍🔍🔍🔍🔍
VectorComplexityAuthenticationConfidentialityIntegrityAvailability
unlockunlockunlockunlockunlockunlock
unlockunlockunlockunlockunlockunlock
unlockunlockunlockunlockunlockunlock

VulDB Base Score: 🔍
VulDB Temp Score: 🔍
VulDB Reliability: 🔍

NVD Base Score: 🔍

Exploitinginfo

Class: Memory corruption
CWE: CWE-119
ATT&CK: Unknown

Local: No
Remote: Yes

Availability: 🔍
Status: Proof-of-Concept

EPSS Score: 🔍
EPSS Percentile: 🔍

Price Prediction: 🔍
Current Price Estimation: 🔍

0-Dayunlockunlockunlockunlock
Todayunlockunlockunlockunlock

Nessus ID: 44323
Nessus Name: Ubuntu 6.06 LTS : python-xml vulnerabilities (USN-890-4)
Nessus File: 🔍
Nessus Risk: 🔍
Nessus Family: 🔍
Nessus Context: 🔍

OpenVAS ID: 80056
OpenVAS Name: Oracle Linux Local Check: ELSA-2009-1625
OpenVAS File: 🔍
OpenVAS Family: 🔍

Qualys ID: 🔍
Qualys Name: 🔍

Threat Intelligenceinfo

Interest: 🔍
Active Actors: 🔍
Active APT Groups: 🔍

Countermeasuresinfo

Recommended: Upgrade
Status: 🔍

Reaction Time: 🔍
0-Day Time: 🔍
Exposure Time: 🔍

Upgrade: iTunes 12.6

Timelineinfo

10/05/2009 🔍
11/08/2009 +34 days 🔍
12/03/2009 +25 days 🔍
12/04/2009 +1 days 🔍
12/04/2009 +0 days 🔍
01/27/2010 +54 days 🔍
03/21/2017 +2610 days 🔍
03/21/2017 +0 days 🔍
03/29/2017 +8 days 🔍
11/24/2022 +2066 days 🔍

Sourcesinfo

Vendor: apple.com

Advisory: HT207599
Status: Confirmed
Confirmation: 🔍

CVE: CVE-2009-3560 (🔍)
OVAL: 🔍
IAVM: 🔍

SecurityTracker: 1023278
SecurityFocus: 37203 - Expat XML Parsing Remote Denial of Service Vulnerability
Secunia: 37537
OSVDB: 60797 - CVE-2009-3560 - Expat - Denial-Of-Service Issue
Vupen: ADV-2010-0528

See also: 🔍

Entryinfo

Created: 03/29/2017 04:52 PM
Updated: 11/24/2022 07:42 AM
Changes: 03/29/2017 04:52 PM (56), 09/14/2019 07:05 AM (24), 11/24/2022 07:36 AM (2), 11/24/2022 07:42 AM (7)
Complete: 🔍

Discussion

No comments yet. Languages: en.

Please log in to comment.

Want to stay up to date on a daily basis?

Enable the mail alert feature now!