VDB-99897 · CVE-2017-7875 · BID 97689

feh up to 2.18.2 IPC Message wallpaper.c out-of-bounds write

CVSS Meta Temp Score
CVSS is a standardized scoring system to determine possibilities of attacks. The Temp Score considers temporal factors like disclosure, exploit and countermeasures. The unique Meta Score calculates the average score of different sources to provide a normalized scoring system.
Current Exploit Price (≈)
Our analysts are monitoring exploit markets and are in contact with vulnerability brokers. The range indicates the observed or calculated exploit price to be seen on exploit markets. A good indicator to understand the monetary effort required for and the popularity of an attack.
CTI Interest Score
Our Cyber Threat Intelligence team is monitoring different web sites, mailing lists, exploit markets and social media networks. The CTI Interest Score identifies the interest of attackers and the security community for this specific vulnerability in real-time. A high score indicates an elevated risk to be targeted for this vulnerability.
8.4$0-$5k0.00

A vulnerability was found in feh up to 2.18.2. It has been classified as critical. This affects an unknown function of the file wallpaper.c of the component IPC Message Handler. The manipulation with an unknown input leads to a out-of-bounds write vulnerability. CWE is classifying the issue as CWE-787. The product writes data past the end, or before the beginning, of the intended buffer. This is going to have an impact on confidentiality, integrity, and availability. The summary by CVE is:

In wallpaper.c in feh before v2.18.3, if a malicious client pretends to be the E17 window manager, it is possible to trigger an out-of-boundary heap write while receiving an IPC message. An integer overflow leads to a buffer overflow and/or a double free.

The bug was discovered 04/14/2017. The weakness was disclosed 04/14/2017 (Website). The advisory is shared at feh.finalrewind.org. This vulnerability is uniquely identified as CVE-2017-7875 since 04/14/2017. The exploitability is told to be easy. It is possible to initiate the attack remotely. No form of authentication is needed for exploitation. Technical details are known, but no exploit is available.

The vulnerability scanner Nessus provides a plugin with the ID 99420 (Debian DLA-899-1 : feh security update), which helps to determine the existence of the flaw in a target environment. It is assigned to the family Debian Local Security Checks and running in the context l.

Upgrading to version 2.18.3 eliminates this vulnerability. A possible mitigation has been published 3 days after the disclosure of the vulnerability.

The vulnerability is also documented in the vulnerability database at Tenable (99420).

Productinfo

Name

Version

License

CPE 2.3info

CPE 2.2info

CVSSv4info

VulDB CVSS-B Score: 🔍
VulDB CVSS-BT Score: 🔍
VulDB Vector: 🔍
VulDB Reliability: 🔍

CVSSv3info

VulDB Meta Base Score: 8.5
VulDB Meta Temp Score: 8.4

VulDB Base Score: 7.3
VulDB Temp Score: 7.0
VulDB Vector: 🔍
VulDB Reliability: 🔍

NVD Base Score: 9.8
NVD Vector: 🔍

CVSSv2info

AVACAuCIA
💳💳💳💳💳💳
💳💳💳💳💳💳
💳💳💳💳💳💳
VectorComplexityAuthenticationConfidentialityIntegrityAvailability
unlockunlockunlockunlockunlockunlock
unlockunlockunlockunlockunlockunlock
unlockunlockunlockunlockunlockunlock

VulDB Base Score: 🔍
VulDB Temp Score: 🔍
VulDB Reliability: 🔍

NVD Base Score: 🔍

Exploitinginfo

Class: Out-of-bounds write
CWE: CWE-787 / CWE-119
ATT&CK: Unknown

Local: No
Remote: Yes

Availability: 🔍
Status: Not defined

EPSS Score: 🔍
EPSS Percentile: 🔍

Price Prediction: 🔍
Current Price Estimation: 🔍

0-Dayunlockunlockunlockunlock
Todayunlockunlockunlockunlock

Nessus ID: 99420
Nessus Name: Debian DLA-899-1 : feh security update
Nessus File: 🔍
Nessus Risk: 🔍
Nessus Family: 🔍
Nessus Context: 🔍

OpenVAS ID: 54601
OpenVAS Name: Debian LTS Advisory ([SECURITY] [DLA 899-1] feh security update)
OpenVAS File: 🔍
OpenVAS Family: 🔍

Threat Intelligenceinfo

Interest: 🔍
Active Actors: 🔍
Active APT Groups: 🔍

Countermeasuresinfo

Recommended: Upgrade
Status: 🔍

Reaction Time: 🔍
0-Day Time: 🔍
Exposure Time: 🔍

Upgrade: feh 2.18.3
Patch: github.com

Timelineinfo

04/14/2017 🔍
04/14/2017 +0 days 🔍
04/14/2017 +0 days 🔍
04/14/2017 +0 days 🔍
04/14/2017 +0 days 🔍
04/15/2017 +1 days 🔍
04/17/2017 +2 days 🔍
04/18/2017 +1 days 🔍
11/29/2022 +2051 days 🔍

Sourcesinfo

Advisory: f7a547b7ef8fc8ebdeaa4c28515c9d72e592fb6d
Status: Not defined
Confirmation: 🔍

CVE: CVE-2017-7875 (🔍)
SecurityFocus: 97689 - feh 'src/wallpaper.c' Integer Overflow Vulnerability
OSVDB: - CVE-2017-7875 - feh - Integer Overflow Issue

Entryinfo

Created: 04/15/2017 03:33 PM
Updated: 11/29/2022 02:22 PM
Changes: 04/15/2017 03:33 PM (78), 11/29/2022 02:19 PM (5), 11/29/2022 02:22 PM (1)
Complete: 🔍

Discussion

No comments yet. Languages: en.

Please log in to comment.

Do you need the next level of professionalism?

Upgrade your account now!