Moodle Vulnerabilities

Timeline

The analysis of the timeline helps to identify the required approach and handling of single vulnerabilities and vulnerability collections. This overview makes it possible to see less important slices and more severe hotspots at a glance. Initiating immediate vulnerability response and prioritizing of issues is possible.

Last Year

The analysis of the timeline helps to identify the required approach and handling of single vulnerabilities and vulnerability collections. This overview makes it possible to see less important slices and more severe hotspots at a glance. Initiating immediate vulnerability response and prioritizing of issues is possible.

Version

2.1.196
2.185
2.2.169
2.6.169
2.1.269

Grouping all affected versions of a specific product helps to determine existing issues. This makes it possible to determine vendors and products which need attention when it comes to remediations.

Remediation

Official Fix386
Temporary Fix0
Workaround0
Unavailable0
Not Defined86

Vendors and researchers are eager to find countermeasures to mitigate security vulnerabilities. These can be distinguished between multiple forms and levels of remediation which influence risks differently.

Exploitability

High5
Functional0
Proof-of-Concept32
Unproven7
Not Defined428

Researcher and attacker which are looking for security vulnerabilities try to exploit them for academic purposes or personal gain. The level and quality of exploitability can be distinguished to determine simplicity and strength of attacks.

Access Vector

Not Defined0
Physical0
Local2
Adjacent31
Network439

The approach a vulnerability it becomes important to use the expected access vector. This is typically via the network, local, or physically even.

Authentication

Not Defined0
High6
Low230
None236

To exploit a vulnerability a certail level of authentication might be required. Vulnerabilities without such a requirement are much more popular.

User Interaction

Not Defined0
Required175
None297

Some attack scenarios require some user interaction by a victim. This is typical for phishing, social engineering and cross site scripting attacks.

C3BM Index

Our unique C3BM Index (CVSSv3 Base Meta Index) cumulates the CVSSv3 Meta Base Scores of all entries over time. Comparing this index to the amount of disclosed vulnerabilities helps to pinpoint the most important events.

Last Year

Our unique C3BM Index (CVSSv3 Base Meta Index) cumulates the CVSSv3 Meta Base Scores of all entries over time. Comparing this index to the amount of disclosed vulnerabilities helps to pinpoint the most important events.

CVSSv3 Base

≤10
≤20
≤30
≤457
≤5155
≤6115
≤793
≤839
≤95
≤108

The Common Vulnerability Scoring System (CVSS) is an industry standard to define the characteristics and impacts of security vulnerabilities. The base score represents the intrinsic aspects that are constant over time and across user environments. Our unique meta score merges all available scores from different sources to aggregate to the most reliable result.

CVSSv3 Temp

≤10
≤20
≤31
≤471
≤5150
≤6150
≤771
≤817
≤95
≤107

The Common Vulnerability Scoring System (CVSS) uses temp scores to reflect the characteristics of a vulnerability that may change over time but not across user environments. This includes reporting confidence, exploitability and remediation levels. We do also provide our unique meta score for temp scores, even though other sources rarely publish them.

VulDB

≤10
≤20
≤32
≤476
≤5146
≤6106
≤782
≤839
≤914
≤107

The moderation team is always defining the base vector and base score for an entry. These and all other available scores are used to generate the meta score.

NVD

≤10
≤20
≤31
≤43
≤547
≤631
≤738
≤818
≤916
≤105

The National Vulnerability Database (NVD) is also defining CVSS vectors and scores. These are usually not complete and might differ from VulDB scores.

CNA

≤10
≤20
≤30
≤40
≤50
≤60
≤70
≤80
≤90
≤100

A CVE Numbering Authority (CNA) is responsible for assigning new CVE entries. They might also include a CVSS score. These are usually not complete and might differ from VulDB scores.

Vendor

≤10
≤20
≤30
≤40
≤50
≤60
≤70
≤80
≤90
≤100

Some vendors are willing to publish their own CVSS vectors and scores for vulnerabilities in their products. The coverage varies from vendor to vendor.

Research

≤10
≤20
≤30
≤40
≤50
≤60
≤70
≤80
≤90
≤100

There are sometimes also security researcher which provide their own CVSS vectors and scores for vulnerabilities they have found and published.

Exploit 0-day

<1k0
<2k0
<5k62
<10k165
<25k216
<50k29
<100k0
≥100k0

The moderation team is working with the threat intelligence team to determine prices for exploits. Our unique algorithm is used to identify the 0-day prices for an exploit, before it got distributed or became public. Calculated prices are aligned to prices disclosed by vulnerability broker and compared to prices we see on exploit markets.

Exploit Today

<1k348
<2k25
<5k52
<10k45
<25k2
<50k0
<100k0
≥100k0

The 0-day prices do not consider time-relevant factors. The today price does reflect price impacts like disclosure of vulnerability details, alternative exploits, availability of countermeasures. These dynamic aspects might decrease the exploit prices over time. Under certain circumstances this happens very fast.

Exploit Market Volume

Our unique calculation of exploit prices makes it possible to forecast the expected exploit market volume. The calculated prices for all possible 0-day expoits are cumulated for this task. Comparing the volume to the amount of disclosed vulnerabilities helps to pinpoint the most important events.

Last Year

Our unique calculation of exploit prices makes it possible to forecast the expected exploit market volume. The calculated prices for all possible 0-day expoits are cumulated for this task. Comparing the volume to the amount of disclosed vulnerabilities helps to pinpoint the most important events.

🔴 CTI Activities

Our unique Cyber Threat Intelligence aims to determine the ongoing research of actors to anticipiate their acitivities. Observing exploit markets on the Darknet, discussions of vulnerabilities on mailinglists, and exchanges on social media makes it possible to identify planned attacks. Monitored actors and activities are classified whether they are offensive or defensive. They are also weighted as some actors are well-known for certain products and technologies. And some of their disclosures might contain more or less details about technical aspects and personal context. The world map highlights active actors in real-time.

Affected Versions (347): 1.0, 1.1, 1.1.1, 1.2, 1.2.1, 1.3, 1.3.1, 1.3.2, 1.3.3, 1.3.4, 1.4, 1.4.1, 1.4.2, 1.4.3, 1.4.4, 1.4.5, 1.5, 1.5 Beta, 1.5.1, 1.5.2, 1.5.3, 1.6, 1.6.1, 1.6.2, 1.6.3, 1.6.4, 1.6.5, 1.6.6, 1.6.7, 1.6.8, 1.7, 1.7.1, 1.7.2, 1.7.3, 1.7.4, 1.7.5, 1.7.6, 1.8, 1.8.1, 1.8.2, 1.8.3, 1.8.4, 1.8.5, 1.8.6, 1.8.7, 1.8.8, 1.8.9, 1.8.11, 1.9, 1.9.1, 1.9.2, 1.9.3, 1.9.4, 1.9.5, 1.9.6, 1.9.7, 1.9.8, 1.9.9, 1.9.11, 1.9.12, 1.9.13, 1.9.14, 1.9.15, 1.9.16, 1.9.17, 1.9.18, 2.0, 2.0.1, 2.0.2, 2.0.3, 2.0.4, 2.0.5, 2.0.6, 2.0.7, 2.0.8, 2.0.8-2.fc16, 2.0.9, 2.1, 2.1.1, 2.1.2, 2.1.3, 2.1.4, 2.1.5, 2.1.6, 2.1.7, 2.1.8, 2.1.9, 2.2, 2.2.1, 2.2.2, 2.2.3, 2.2.4, 2.2.5, 2.2.6, 2.2.7, 2.2.8, 2.2.9, 2.2.11, 2.3, 2.3.1, 2.3.2, 2.3.3, 2.3.4, 2.3.5, 2.3.6, 2.3.7, 2.3.8, 2.3.9, 2.3.11, 2.4, 2.4.1, 2.4.2, 2.4.3, 2.4.4, 2.4.5, 2.4.6, 2.4.7, 2.4.8, 2.4.9, 2.4.11, 2.5, 2.5.1, 2.5.2, 2.5.3, 2.5.4, 2.5.5, 2.5.6, 2.5.7, 2.5.8, 2.5.9, 2.6, 2.6.1, 2.6.2, 2.6.3, 2.6.4, 2.6.5, 2.6.6, 2.6.7, 2.6.8, 2.6.9, 2.6.11, 2.7, 2.7.1, 2.7.2, 2.7.3, 2.7.4, 2.7.5, 2.7.6, 2.7.7, 2.7.8, 2.7.9, 2.7.11, 2.7.12, 2.7.13, 2.8, 2.8.1, 2.8.2, 2.8.3, 2.8.4, 2.8.5, 2.8.6, 2.8.7, 2.8.8, 2.8.9, 2.8.11, 2.9, 2.9.1, 2.9.2, 2.9.3, 2.9.4, 2.9.5, 3, 3.0, 3.0.1, 3.0.2, 3.0.3, 3.1, 3.1.1, 3.1.2, 3.1.3, 3.1.4, 3.1.5, 3.1.6, 3.1.7, 3.1.8, 3.1.9, 3.1.11, 3.1.12, 3.1.13, 3.1.14, 3.1.15, 3.1.16, 3.2, 3.2.2, 3.2.7, 3.3, 3.3.1, 3.3.2, 3.3.3, 3.3.4, 3.3.5, 3.3.6, 3.3.7, 3.3.8, 3.4, 3.4.1, 3.4.2, 3.4.3, 3.4.4, 3.4.5, 3.4.6, 3.4.7, 3.4.8, 3.5, 3.5.1, 3.5.2, 3.5.3, 3.5.4, 3.5.5, 3.5.6, 3.5.7, 3.5.8, 3.5.9, 3.5.11, 3.5.12, 3.5.13, 3.5.14, 3.5.15, 3.5.16, 3.5.17, 3.5.143.7, 3.5.143.7.1, 3.5.143.7.2, 3.5.143.7.3, 3.5.143.7.4, 3.5.143.7.5, 3.5.143.7.6, 3.5.143.7.7, 3.5.143.7.8, 3.6, 3.6.1, 3.6.2, 3.6.3, 3.6.4, 3.6.5, 3.6.6, 3.6.7, 3.6.8, 3.6.9, 3.7, 3.7.1, 3.7.2, 3.7.3, 3.7.4, 3.7.5, 3.7.6, 3.7.7, 3.7.8, 3.8, 3.8.1, 3.8.2, 3.8.3, 3.8.4, 3.8.5, 3.8.6, 3.8.7, 3.8.8, 3.9, 3.9.1, 3.9.2, 3.9.3, 3.9.4, 3.9.5, 3.9.6, 3.9.7, 3.9.8, 3.9.9, 3.9.11, 3.9.12, 3.10, 3.10.1, 3.10.2, 3.10.3, 3.10.4, 3.10.5, 3.10.6, 3.10.7, 3.10.8, 3.10.9, 3.11, 3.11.1, 3.11.2, 3.11.3, 3.11.4, 3.11.5, 6.x-1, 6.x-1.1, 9.0, 9.1, 9.2, 9.3, 9.4, 9.5, 9.6, 9.7, 9.8, 9.9, 9.10, 9.11, 9.12, 9.13, 9.14, 9.15, 9.16, 9.17, 9.18, 9.19, 9.20, 9.21, 9.22, 9.23, 9.24, 9.25, 9.26, 9.27, 9.28, 9.29, 9.30, 9.31, 9.32, 9.33, 9.34, 9.35, 9.36, 9.37, 9.38, 9.39, 9.40, 9.41, 9.42, 9.43, 9.44, 9.45, 9.46, 9.47, 9.48, 9.49

Link to Product Website: https://moodle.org/

Software Type: Learning Management Software

PublishedBaseTempVulnerability0dayTodayExpRemCTICVE
11/26/20226.36.0Moodle LTI Provider Library server-side request forgery$5k-$25k$0-$5kNot DefinedOfficial Fix0.13CVE-2022-45152
11/23/20223.53.4Moodle Policy Tool cross site scripting$5k-$25k$0-$5kNot DefinedOfficial Fix0.07CVE-2022-45150
11/23/20224.34.1Moodle cross-site request forgery$5k-$25k$0-$5kNot DefinedOfficial Fix0.06CVE-2022-45149
11/23/20223.53.4Moodle User Profile Field cross site scripting$5k-$25k$0-$5kNot DefinedOfficial Fix0.09CVE-2022-45151
10/06/20226.56.4Moodle H5P Library cross-site request forgery$5k-$25k$0-$5kNot DefinedOfficial Fix0.03CVE-2022-2986
10/01/20225.35.2Moodle Mustache Template Helper cross site scripting$0-$5k$5k-$25kNot DefinedNot Defined0.06CVE-2022-40313
10/01/20223.93.8Moodle H5P Activity Attempt Report information disclosure$0-$5k$0-$5kNot DefinedNot Defined0.03CVE-2022-40316
10/01/20227.27.2Moodle Administration Page sql injection$5k-$25k$5k-$25kNot DefinedNot Defined0.07CVE-2022-40315
10/01/20228.07.9Moodle Backup File Privilege Escalation$5k-$25k$5k-$25kNot DefinedNot Defined0.03CVE-2022-40314
09/29/20225.55.5Moodle Shibboleth Authentication Plugin Privilege Escalation$5k-$25k$5k-$25kNot DefinedNot Defined0.08CVE-2021-40691
09/29/20223.93.9Moodle Quiz information disclosure$0-$5k$0-$5kNot DefinedNot Defined0.04CVE-2021-40695
09/29/20223.63.6Moodle LaTeX Preamble information disclosure$0-$5k$0-$5kNot DefinedNot Defined0.04CVE-2021-40694
09/29/20226.46.4Moodle improper authentication$5k-$25k$5k-$25kNot DefinedNot Defined0.04CVE-2021-40693
09/29/20223.93.9Moodle Course information disclosure$0-$5k$0-$5kNot DefinedNot Defined0.04CVE-2021-40692
09/14/20224.44.4Moodle Course cross site scripting$0-$5k$5k-$25kNot DefinedNot Defined0.04CVE-2021-36568
08/17/20224.84.7Moodle Admin Task Log cross site scripting$0-$5k$0-$5kNot DefinedOfficial Fix0.03CVE-2020-14320
08/17/20227.17.0Moodle Manager Role improper authorization$5k-$25k$0-$5kNot DefinedOfficial Fix0.03CVE-2020-14321
08/17/20226.36.0Moodle Header data authenticity$5k-$25k$0-$5kNot DefinedOfficial Fix0.04CVE-2020-1755
08/17/20225.55.4Moodle yui_combo denial of service$0-$5k$0-$5kNot DefinedOfficial Fix0.04CVE-2020-14322
08/17/20224.34.1Moodle PHP Unit Webrunner Admin Tool input validation$5k-$25k$0-$5kNot DefinedOfficial Fix0.00CVE-2020-1756
08/06/20224.44.4Moodle Conversation Overview cross site scripting$0-$5k$0-$5kNot DefinedOfficial Fix0.04CVE-2020-1691
08/05/20223.93.8Moodle Grade History Report access control$5k-$25k$0-$5kNot DefinedOfficial Fix0.05CVE-2020-1754
07/26/20224.84.7Moodle LTI Module cross site scripting$0-$5k$0-$5kNot DefinedOfficial Fix0.03CVE-2022-35653
07/26/20224.84.7Moodle SCORM Track Detail cross site scripting$0-$5k$0-$5kNot DefinedOfficial Fix0.00CVE-2022-35651
07/26/20225.85.7Moodle Mobile Auto-Login Feature redirect$5k-$25k$0-$5kNot DefinedOfficial Fix0.03CVE-2022-35652

447 more entries are not shown

Want to stay up to date on a daily basis?

Enable the mail alert feature now!