NSS 3.24.0 SSLv2 Message Denial of Service

CVSS Meta Temp ScoreAktueller Exploitpreis (≈)CTI Interest Score
6.3$0-$5k0.00

Es wurde eine Schwachstelle in NSS 3.24.0 entdeckt. Sie wurde als problematisch eingestuft. Hiervon betroffen ist eine unbekannte Funktionalität der Komponente SSLv2 Message Handler. Dank der Manipulation mit einer unbekannten Eingabe kann eine Denial of Service-Schwachstelle ausgenutzt werden. Im Rahmen von CWE wurde eine Klassifizierung als CWE-476 vorgenommen. Auswirken tut sich dies auf die Verfügbarkeit. Die Zusammenfassung von CVE lautet:

Null pointer dereference vulnerability in NSS since 3.24.0 was found when server receives empty SSLv2 messages resulting into denial of service by remote attacker.

Die Entdeckung des Problems geschah am 03.01.2017. Die Schwachstelle wurde am 30.05.2017 (Website) publiziert. Das Advisory findet sich auf hg.mozilla.org. Die Identifikation der Schwachstelle wird mit CVE-2017-7502 vorgenommen. Der Angriff kann über das Netzwerk erfolgen. Zur Ausnutzung ist keine spezifische Authentisierung erforderlich. Technische Details sind nicht bekannt und ein Exploit zur Schwachstelle ist ebenfalls nicht vorhanden.

Vor einer Veröffentlichung handelte es sich 147 Tage um eine Zero-Day Schwachstelle. Während dieser Zeit erzielte er wohl etwa $0-$5k auf dem Schwarzmarkt. Für den Vulnerability Scanner Nessus wurde am 23.06.2017 ein Plugin mit der ID 101001 (Amazon Linux AMI : nss (ALAS-2017-848)) herausgegeben, womit die Existenz der Schwachstelle geprüft werden kann. Es wird im Kontext l ausgeführt. Der kommerzielle Vulnerability Scanner Qualys bietet das Plugin 176051 (Debian Security Update for nss (DSA 3872-1)) zur Prüfung der Schwachstelle an.

Die Schwachstelle kann durch das Filtern von mittels Firewalling mitigiert werden. Das Erscheinen einer Gegenmassnahme geschah 4 Wochen nach der Veröffentlichung der Schwachstelle. Es wurde nachweislich noch im Rahmen gehandelt.

Unter anderem wird der Fehler auch in den Datenbanken von Tenable (101001), SecurityFocus (BID 98744†) und SecurityTracker (ID 1038579†) dokumentiert.

Produktinfo

Name

Version

CPE 2.3info

CPE 2.2info

CVSSv4info

VulDB CVSS-B Score: 🔍
VulDB CVSS-BT Score: 🔍
VulDB Vector: 🔍
VulDB Zuverlässigkeit: 🔍

CVSSv3info

VulDB Meta Base Score: 6.4
VulDB Meta Temp Score: 6.3

VulDB Base Score: 5.3
VulDB Temp Score: 5.2
VulDB Vector: 🔍
VulDB Zuverlässigkeit: 🔍

NVD Base Score: 7.5
NVD Vector: 🔍

CVSSv2info

AVACAuCIA
💳💳💳💳💳💳
💳💳💳💳💳💳
💳💳💳💳💳💳
VektorKomplexitätAuthentisierungVertraulichkeitIntegritätVerfügbarkeit
freischaltenfreischaltenfreischaltenfreischaltenfreischaltenfreischalten
freischaltenfreischaltenfreischaltenfreischaltenfreischaltenfreischalten
freischaltenfreischaltenfreischaltenfreischaltenfreischaltenfreischalten

VulDB Base Score: 🔍
VulDB Temp Score: 🔍
VulDB Zuverlässigkeit: 🔍

NVD Base Score: 🔍

Exploitinginfo

Klasse: Denial of Service
CWE: CWE-476 / CWE-404
CAPEC: 🔍
ATT&CK: 🔍

Lokal: Nein
Remote: Ja

Verfügbarkeit: 🔍
Status: Nicht definiert

EPSS Score: 🔍
EPSS Percentile: 🔍

Preisentwicklung: 🔍
Aktuelle Preisschätzung: 🔍

0-Dayfreischaltenfreischaltenfreischaltenfreischalten
Heutefreischaltenfreischaltenfreischaltenfreischalten

Nessus ID: 101001
Nessus Name: Amazon Linux AMI : nss (ALAS-2017-848)
Nessus Datei: 🔍
Nessus Risiko: 🔍
Nessus Family: 🔍
Nessus Context: 🔍

OpenVAS ID: 703872
OpenVAS Name: Debian Security Advisory DSA 3872-1 (nss - security update)
OpenVAS Datei: 🔍
OpenVAS Family: 🔍

Qualys ID: 🔍
Qualys Name: 🔍

Threat Intelligenceinfo

Interesse: 🔍
Aktive Akteure: 🔍
Aktive APT Gruppen: 🔍

Gegenmassnahmeninfo

Empfehlung: Firewall
Status: 🔍

Reaktionszeit: 🔍
0-Day Time: 🔍
Exposure Time: 🔍

Timelineinfo

05.04.2017 🔍
03.01.2017 +16935 Tage 🔍
28.04.2017 +115 Tage 🔍
30.05.2017 +32 Tage 🔍
30.05.2017 +0 Tage 🔍
30.05.2017 +0 Tage 🔍
31.05.2017 +1 Tage 🔍
22.06.2017 +22 Tage 🔍
23.06.2017 +1 Tage 🔍
07.12.2022 +1993 Tage 🔍

Quelleninfo

Advisory: RHSA-2017:1364
Status: Bestätigt
Bestätigung: 🔍

CVE: CVE-2017-7502 (🔍)
OVAL: 🔍

SecurityTracker: 1038579
SecurityFocus: 98744 - Mozilla Network Security Services CVE-2017-7502 Denial of Service Vulnerability
OSVDB: - CVE-2017-7502 - Mozilla - Network Security Services - Denial of Service Issue

Eintraginfo

Erstellt: 31.05.2017 08:15
Aktualisierung: 07.12.2022 14:14
Anpassungen: 31.05.2017 08:15 (85), 07.12.2022 14:14 (4)
Komplett: 🔍
Cache ID: 3:CA9:40

Diskussion

Bisher keine Kommentare. Sprachen: de + en.

Bitte loggen Sie sich ein, um kommentieren zu können.

Do you want to use VulDB in your project?

Use the official API to access entries easily!